Bug 733 - kernel total freeze switching X->fb (matrox)
Summary: kernel total freeze switching X->fb (matrox)
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/other (show other bugs)
Version: XOrg 6.7.0
Hardware: x86 (IA32) Linux (All)
: high critical
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-08 06:25 UTC by Alessandro Lepore
Modified: 2019-10-14 13:20 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro Lepore 2004-06-08 06:25:41 UTC
I have this problem with linux 2.6 (2.4 was ok).
I hope this is the right place to report this, i think it is related with
"drm" mga module..

The problem is: framebuffer (matroxfb) works fine, X (xfree 4.3 or Xorg
6.7) works fine, but sometimes when i hit "ctrl alt F1" for switching
on the console, the system freeze.
It's not only a xfree freeze: no SysRq reboot and no working network
(sshd is not responding). hard freeze.
This happen *sometimes* : i switch between X and console many times
during the day, the box freeze only 2-3 times a day.

I don't known where to go to find the problem, the only interesting
element i have is:

2.4:
kernel: [drm] AGP 0.99 Aperture @ 0xe0000000 64MB
kernel: [drm] Initialized mga 3.0.2 20010321 on minor 0
2.6:
kernel: [drm] Initialized mga 3.1.0 20021029 on minor 0
kernel: agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
kernel: agpgart: Putting AGP V2 device at 0000:00:00.0 into 1x mode
kernel: agpgart: Putting AGP V2 device at 0000:02:00.0 into 1x mode

seems related with the module version..

my stuffs:

video card: Matrox G400 DH on nvidia nforce2 motherboard
kernel: vanilla 2.6.3/5 (nforce2 agp/matrox drm/matroxfb support)
X server: Xfree 4.3.0 or Xorg r6.7 using "mga" driver

now i'm using dri CVS.. seems more stable, but i'v just got an hard freeze while
using mozilla..

i've posted this on the LKML
there are other people with this problem, replies:

-
It also happens with Matrox G550 on VIA board.
All 2.6.x kernels. XFree86 4.3 and 4.4.
And 1280x1024-16@60 do not work (in fb, X is fine) :-(
-
Same thing here with Asus P4-PE board.
No matroxfb here, so this doesn't seem to be the problem.
I guess it's more an issue with agpart/drm.
-
Add me to the list... Matrox G400, AMD Irongate chipset.
It never seems to happen when X shuts down on it's own or when it
just startet up, that is, when I switch from the login screen.
-

helpppppp !!
Comment 1 Alessandro Lepore 2004-06-08 06:36:13 UTC
there's a similar bug: http://freedesktop.org/bugzilla/show_bug.cgi?id=715
similar but not the same: i'v not a working mouse, no X log or kernel logs,
nothing works.
Comment 2 Adam Jackson 2004-06-08 09:39:47 UTC
i smell race condition.  do you by chance have CONFIG_PREEMPT enabled in your
kernel?
Comment 3 Alessandro Lepore 2004-06-09 19:29:19 UTC
(In reply to comment #2)
> i smell race condition.  do you by chance have CONFIG_PREEMPT enabled in your
> kernel?

yes, there was preemption.
no preemption now: seems stable.
if this is the problem, will be fixed?
Comment 4 Alessandro Lepore 2004-06-13 07:00:59 UTC
(In reply to comment #3)
> no preemption now: seems stable.

freezed again (without preemption) after 1 week of stability..
i have noted that i was using some "turbo" settings for RAM timing..
i'll try with more stable settings.
Comment 5 Alessandro Lepore 2004-06-14 06:11:58 UTC
(In reply to comment #4)
> i'll try with more stable settings.

ram is ok, it still freeze without preemption. ;(

Comment 6 Nicolai Haehnle 2004-06-15 02:33:01 UTC
Have you tried without framebuffer support, i.e. plain old VGA console? I don't use fbdev 
here, and haven't been able to reproduce the lockup. 
Comment 7 Peter Daum 2004-07-17 09:33:24 UTC
(In reply to comment #6)
> Have you tried without framebuffer support, i.e. plain old VGA console?
> I don't use fbdev here, and haven't been able to reproduce the lockup. 

It don't think it's the framebuffer - I had the lockups with all 2.6.x Kernels
with a 80x43 VGA console (no problems with 2.4.x)
Comment 8 chemtech 2013-03-15 13:33:46 UTC
Alessandro Lepore,
Do you still experience this issue with newer drivers ?
Please check the status of your issue.
Comment 9 Martin Peres 2019-10-14 13:20:24 UTC
Hi,

Freedesktop's Bugzilla instance is EOLed and open bugs are about to be migrated to http://gitlab.freedesktop.org.

To avoid migrating out of date bugs, I am now closing all the bugs that did not see any activity in the past year. If the issue is still happening, please create a new bug in the relevant project at https://gitlab.freedesktop.org/drm (use misc by default).

Sorry about the noise!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.