Bug 73840 - [SNB] Chromium+google maps GPU hang when secondary monitor is connected
Summary: [SNB] Chromium+google maps GPU hang when secondary monitor is connected
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 10.0
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-20 17:40 UTC by milan.plzik
Modified: 2018-05-12 07:24 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg with drm.debug=1 (503.90 KB, text/plain)
2014-01-20 17:40 UTC, milan.plzik
Details
glxinfo output on affected machine (15.05 KB, text/plain)
2014-01-20 17:41 UTC, milan.plzik
Details
i915_error_state on affected machine after triggering bug (2.02 MB, text/plain)
2014-01-20 17:42 UTC, milan.plzik
Details
Xorg.0.log on affected machine after triggering bug (29.99 KB, text/plain)
2014-01-20 17:43 UTC, milan.plzik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description milan.plzik 2014-01-20 17:40:51 UTC
Created attachment 92471 [details]
dmesg with drm.debug=1

After connecting secondary monitor and opening Chromium with maps.google.com, I experience hangs in range of minutes. Following message appears in dmesg:

[ 2052.057508] [drm:ring_stuck] *ERROR* Kicking stuck wait on render ring

Attaching necessary debug info.
Comment 1 milan.plzik 2014-01-20 17:41:47 UTC
Created attachment 92472 [details]
glxinfo output on affected machine
Comment 2 milan.plzik 2014-01-20 17:42:28 UTC
Created attachment 92473 [details]
i915_error_state on affected machine after triggering bug
Comment 3 milan.plzik 2014-01-20 17:43:13 UTC
Created attachment 92474 [details]
Xorg.0.log on affected machine after triggering bug
Comment 4 Matt Turner 2017-03-22 02:19:52 UTC
Sorry no one ever investigated your bug.

Please reopen if you can still reproduce with Mesa 17.0.
Comment 5 vadym 2018-05-11 13:58:07 UTC
Can't reproduce this bug on:

    Linux Mint 18.3 (Kernel 4.16.0-041600-generic)
    Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
    Intel(R) Sandybridge Mobile  (0x126)
    chromium-browser (65.0.3325.181 Built on Ubuntu)
    Mesa 10.0.2 (git-108e50c), Mesa 17.2.8 (from default install), Mesa 18.1.0-devel (git-108e50c)

In all cases chromium operated normally without any issues. Tried map, satellite and street views.
Comment 6 milan.plzik 2018-05-11 14:45:40 UTC
Note that this bug was filed back in 2014; I can not replicate this issue on the same hardware now.
Comment 7 Mark Janes 2018-05-11 15:07:39 UTC
No worries!  Mesa has come a *long* way since 2014.  I'm sure this bug was real (and frustrating) at the time.  Sorry it took so long to address it.

Thank you for taking the time to write up the bug.  We do read everything entered into bugzilla, although that may not have been true 4 years ago.
Comment 8 milan.plzik 2018-05-12 07:24:52 UTC
No strong feelings there at all -- I believe the whole stack has changed/improved so much that the bug could have gotten fixed as a side effect :) . So, thanks for all the fixes :)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.