Bug 74094 - [965gm] GPU hang with html5 videos (youtube) in Chromium
Summary: [965gm] GPU hang with html5 videos (youtube) in Chromium
Status: RESOLVED DUPLICATE of bug 80568
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 9.2
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-26 20:19 UTC by Hanno Böck
Modified: 2014-11-18 10:26 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
gzipped output of /sys/class/drm/card0/error after gpu crash (127.06 KB, text/plain)
2014-01-26 20:19 UTC, Hanno Böck
Details
gzipped output of /sys/class/drm/card0/error with kernel 3.12.9 (129.48 KB, application/gzip)
2014-01-27 10:24 UTC, Hanno Böck
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hanno Böck 2014-01-26 20:19:21 UTC
Created attachment 92822 [details]
gzipped output of /sys/class/drm/card0/error after gpu crash

Lately, from time to time my screen turns suddenly black. The system still works, I can access it remotely and shutdown cleanly. This happens quite often when I try to run youtube videos with flash, so this may be related.

In the kernel log I can read this:
Jan 26 20:25:46 pc kernel: [drm] stuck on render ring
Jan 26 20:25:46 pc kernel: [drm] GPU crash dump saved to /sys/class/drm/card0/error
Jan 26 20:25:46 pc kernel: [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Jan 26 20:25:46 pc kernel: [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Jan 26 20:25:46 pc kernel: [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
Jan 26 20:25:46 pc kernel: [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Jan 26 20:25:46 pc kernel: [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0x2e66000 ctx 0) at 0x2e66f34
Jan 26 20:25:46 pc kernel: [drm:i915_reset] *ERROR* Failed to reset chip.

I will attach the output of 
/sys/class/drm/card0/error

xorg-server is 1.15.0, kernel 3.13, xf86-video-intel 2.99.907, mesa 9.2.5, libdrm 2.4.52. Distribution is Gentoo Linux.
Comment 1 Hanno Böck 2014-01-26 20:19:58 UTC
Forgot to mention: My graphics card (lspci output) is
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)
In a Thinkpad T61 laptop.
Comment 2 Chris Wilson 2014-01-26 20:25:33 UTC

*** This bug has been marked as a duplicate of bug 73348 ***
Comment 3 Chris Wilson 2014-01-26 20:27:50 UTC
Too fast. Different bug.

Erm, the error state is broken. GRRR.
Comment 4 Chris Wilson 2014-01-26 20:28:45 UTC
That error state is unusable for bug diagnosis.
Comment 5 Hanno Böck 2014-01-26 20:51:34 UTC
> That error state is unusable for bug diagnosis.

Okay, so how do I get one that is usable? You've marked this bug "needinfo", but you haven't told me what kind of additional info you need.
Comment 6 Chris Wilson 2014-01-26 22:00:13 UTC
An error state from 3.12 should do fine. And if it doesn't hang then we know it is a kernel regression and not the mesa batchbuffer.
Comment 7 drrossum 2014-01-27 01:56:50 UTC
What works for me when my GM965 GPU hangs is to suspend and resume.  That might be less inconvenient than rebooting your machine.
Comment 8 Hanno Böck 2014-01-27 10:24:44 UTC
Created attachment 92843 [details]
gzipped output of /sys/class/drm/card0/error with kernel 3.12.9

Attached is the error-output with kernel 3.12.9.

One additional information: I was wrong above, this isn't triggered by a flash-video, but by a html5-video on youtube. Flash videos work, so it seems it's something in chromiums internal video playback that triggers this error. I also now have a video that always triggers this bug, so I have reproducibility, which should make further investigation easier.
Comment 9 Hanno Böck 2014-02-03 15:10:16 UTC
Is there any more info from me you need to investigate this bug?

I have tried a number of things:
* Downgrading to the latest stable xf86-video-intel 2.21.15
* Upgrading mesa to version 10.0.0.2
* Upgrading both xf86-video-intel and mesa to latest git code
* Switching from sna to uxa

None of this changed anything, the bug persists. This is pretty severe, as it can happen all the time when I surf the net that some video crashes my system.
Comment 10 Matt Turner 2014-11-14 19:46:39 UTC

*** This bug has been marked as a duplicate of bug 80568 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.