Bug 7470 - Bold is too heavy compared to regular
Summary: Bold is too heavy compared to regular
Status: RESOLVED NOTABUG
Alias: None
Product: DejaVu
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: All All
: high normal
Assignee: Deja Vu bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on: 7469
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-09 10:09 UTC by Nicolas Mailhot
Modified: 2007-03-09 08:51 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Mailhot 2006-07-09 10:09:21 UTC
Andy Burns <fedora at adslpipe dot co dot uk> writes :

I think my only issue now (which I forgot to add originally) is the 
perceived increased size of bold fonts, which others have mentioned, to 
me it seems to be equivalent to at least a +1 point size compared to the 
"book" weight.

However Arthur Pemberton <pemboa at gmail dot com> thinks :

I installed the font when the thread last came up over on
fedora-devel-list and I have got to say that it is a big difference.
The fonts seem easier to read, and the contrast beween bold and normal
is a lot better.
Comment 1 Ben Laenen 2006-07-09 15:50:19 UTC
could you post a screenshot? I'm not entirely sure I understand what you're 
saying. Bold with bigger glyphs than Book seems very odd to me.
Comment 2 Nicolas Mailhot 2006-07-18 08:01:08 UTC
De:       "Steven Stern" <subscribed-lists at sterndata dot com>

On the sans serif font, the bold is a bit too "fat" in comparison to the
regular type.
Comment 3 Denis Jacquerye 2006-07-19 06:09:38 UTC
Bold is indeed wider and bolder than Book. 
I'd even say it looks likes Black or Heavy at some sizes.

Unfortunately this is not something that can be fixed easily.
1. people are already using Bold, changing it would mean changing all their
documents
2. adding a SemiBold is feasable but a lot of work, especially if we want the
same  quality.

With the work that has been done on ExtraLight and Book, a Medium or a SemiBold
weight could easily be interpolated, although it would be better to interpolate
 them from Book and Bold. Kerning and hinting would still need to be done. If
anybody's interested in the task we could look into adding it.
Comment 4 Bhikkhu Pesala 2006-12-10 00:43:00 UTC
DejaVu Serif Regular (Measurements for Sans are almost identical)
Stem height = 1493
Stem width = 203 (202 for Sans)
Weight Ratio = 7.35
2_6-Medium..................5.5 ≤ WeightRat < 7.5

DejaVu Serif Bold
Stem height = 1493
Stem width = 384
Weight Ratio = 3.89
2_8-Bold....................3.5 ≤ WeightRat < 4.5

So, DejaVu Serif's regular is at the upper end of the scale for "Medium" weight, 
and DejaVu Serif bold is near the middle of the range for "Bold" weight. In 
other words, it is just about as it should be. 
Comment 5 John Karp 2007-03-09 08:51:30 UTC
Nobody has contested Bhikkhu's analysis, so I'm going to close this as 'not a bug'. And even if it were a bug, what Denis said would apply, and it would be 'won't fix'.

It is obvious there is a wide gap in between 'book' and 'bold'. Addressing that issue is bug #7469.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.