Bug 74760 - [G45] Anno 1701 colors of textures are corrupted
Summary: [G45] Anno 1701 colors of textures are corrupted
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 10.0
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-09 20:10 UTC by chefchenko
Modified: 2019-09-25 18:50 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
screenshot (329.72 KB, image/jpeg)
2014-02-09 20:10 UTC, chefchenko
Details
winedbg error log (51.27 KB, text/plain)
2014-02-10 12:11 UTC, chefchenko
Details
intel reg dumper output (13.59 KB, application/octet-stream)
2014-02-10 12:43 UTC, chefchenko
Details
intel bios dump (64.00 KB, application/octet-stream)
2014-02-10 12:44 UTC, chefchenko
Details
strace extract (30.61 KB, text/plain)
2014-02-10 13:24 UTC, chefchenko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description chefchenko 2014-02-09 20:10:59 UTC
Created attachment 93722 [details]
screenshot

Hi!

I'm running Anno 1701 on Linux (Open Suse 13.1) using wine (32bit). Mesa version is 10.0.3.
However textures are broken for some reason (see screenshot).
Turning on normal maps helps somewhat, but the problem does not disappear entirely.


Best regards
Comment 1 chefchenko 2014-02-09 20:14:02 UTC
edit: you have to right click and choose save as to see the screenshot for some reason.
Comment 2 Jan Vesely 2014-02-09 20:27:30 UTC
Comment on attachment 93722 [details]
screenshot

Changed mimetype to image/jpeg
Comment 3 Chris Forbes 2014-02-09 21:06:28 UTC
Can you provide an apitrace?
Comment 4 chefchenko 2014-02-10 12:11:08 UTC
Created attachment 93763 [details]
winedbg error log
Comment 5 chefchenko 2014-02-10 12:43:26 UTC
Created attachment 93767 [details]
intel reg dumper output
Comment 6 chefchenko 2014-02-10 12:44:02 UTC
Created attachment 93768 [details]
intel bios dump
Comment 7 chefchenko 2014-02-10 12:48:07 UTC
lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

uname -r 3.11.10-7-desktop

uname -m x86_64 (however it's biarch)

pkg-config --modversion libdrm 2.4.46


hope that's enough. If not would someone please tell me how to do an API trace (what debug libraries do I have to install and what commands to use)
Comment 8 chefchenko 2014-02-10 13:24:07 UTC
Created attachment 93772 [details]
strace extract
Comment 9 Matt Turner 2014-09-21 19:58:26 UTC
We'll need an apitrace: https://github.com/apitrace/apitrace
Comment 10 Pavel Ondračka 2014-09-22 06:26:15 UTC
There is a trace I've made for bug 60963 ( http://pavel.ondracka.cz/Anno1701.trace ), there is also similar bug for r300g (bug 60965), so this may actually be some shared component.

BTW as a workaround, you can switch to ARB backend instead of glsl in Wine, this helps with r300g.
Comment 11 chefchenko 2014-09-24 12:17:31 UTC
Hi again!

I made an Apitrace:

apitrace trace wine Anno1701.exe > debug.txt
ERROR: ld.so: object '/usr/bin/../lib/apitrace/wrappers/glxtrace.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/bin/../lib/apitrace/wrappers/glxtrace.so' from LD_PRELOAD cannot be preloaded: ignored.
apitrace: loaded into /usr/bin/wineserver
apitrace: loaded into /usr/bin/wine64-preloader
apitrace: loaded into /usr/bin/wine64-preloader
apitrace: loaded into /usr/bin/wine64-preloader
apitrace: loaded into /usr/bin/wine64-preloader
apitrace: loaded into /usr/bin/wine64-preloader
apitrace: loaded into /usr/bin/wine64-preloader
fixme:win:EnumDisplayDevicesW ((null),0,0x33b3b8,0x00000000), stub!
fixme:d3d9:Direct3DShaderValidatorCreate9 stub
err:d3d:wined3d_debug_callback 0x89561d8: "GL_INVALID_VALUE in glPointSize".
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ state.c / 1565
err:ntdll:RtlpWaitForCriticalSection section 0x1050c70 "?" wait timed out in thread 0009, blocked by 0024, retrying (60 sec)
err:d3d:wined3d_debug_callback 0x84dde08: "GL_INVALID_VALUE in glPointSize".
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ state.c / 1565
err:ntdll:RtlpWaitForCriticalSection section 0x1050c70 "?" wait timed out in thread 0009, blocked by 0024, retrying (60 sec)
err:ntdll:RtlpWaitForCriticalSection section 0x1050c70 "?" wait timed out in thread 0009, blocked by 0024, retrying (60 sec)
Comment 12 chefchenko 2014-09-24 13:27:18 UTC
confirmed. With the following regedit entry:
UseGLSL=disabled

the strange colors are gone. Thank you for the tip!
Comment 13 Matt Turner 2014-09-24 19:56:59 UTC
(In reply to comment #11)
> Hi again!
> 
> I made an Apitrace:

Is it a working trace that reproduces the issue? Can you post it for us to try?
Comment 14 Pavel Ondračka 2014-09-25 07:11:59 UTC
(In reply to comment #13)
> (In reply to comment #11)
> > Hi again!
> > 
> > I made an Apitrace:
> 
> Is it a working trace that reproduces the issue? Can you post it for us to
> try?

BTW there is already a trace that reproduces the issue posted in Comment 10.
Comment 15 Matt Turner 2014-09-25 18:22:04 UTC
(In reply to comment #14)
> (In reply to comment #13)
> > (In reply to comment #11)
> > > Hi again!
> > > 
> > > I made an Apitrace:
> > 
> > Is it a working trace that reproduces the issue? Can you post it for us to
> > try?
> 
> BTW there is already a trace that reproduces the issue posted in Comment 10.

That trace just enters the menu and then quits. I didn't see any game play or anything resembling the attached screenshots.
Comment 16 Pavel Ondračka 2014-09-26 09:37:20 UTC
(In reply to comment #15)
> (In reply to comment #14)
> > (In reply to comment #13)
> > > (In reply to comment #11)
> > > > Hi again!
> > > > 
> > > > I made an Apitrace:
> > > 
> > > Is it a working trace that reproduces the issue? Can you post it for us to
> > > try?
> > 
> > BTW there is already a trace that reproduces the issue posted in Comment 10.
> 
> That trace just enters the menu and then quits. I didn't see any game play
> or anything resembling the attached screenshots.

Sorry about not being specific. This bug is reproducible even in the menu, just look at the ships behind the window.
Comment 17 chefchenko 2014-09-26 16:18:48 UTC
Pavel is correct, the strange colors are already in the menu corrupted. Maybe this bug should be marked a duplicate of that bug. Pavel can you please post a screenshot of the menu, if the screenshot were exactly the same as mine, I would mark this bug as a duplicate of bug 60965.
Comment 18 GitLab Migration User 2019-09-25 18:50:17 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1415.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.