Bug 75064 - HDMI passthrough of TrueHD/DTS-HD audio fails at modes lower than 60hz
Summary: HDMI passthrough of TrueHD/DTS-HD audio fails at modes lower than 60hz
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2014-02-16 20:30 UTC by Cincho
Modified: 2019-11-19 08:43 UTC (History)
11 users (show)

See Also:
i915 platform:
i915 features:

xrandr (3.20 KB, text/plain)
2014-02-16 20:30 UTC, Cincho
no flags Details
dmesg (54.65 KB, text/plain)
2014-02-16 20:31 UTC, Cincho
no flags Details
aplay (237 bytes, text/plain)
2014-02-16 20:32 UTC, Cincho
no flags Details
OpenELEC debug logs (63.99 KB, application/octet-stream)
2014-10-02 19:21 UTC, EnzoBartoli
no flags Details
Kodi 14 debug log with Dolby TrueHD/DTS-HD MA audio (25.91 KB, application/octet-stream)
2015-01-04 15:22 UTC, francesco.borromini
no flags Details
Log File with DRM.debug=0xe (73.29 KB, text/plain)
2015-10-06 19:55 UTC, Jan
no flags Details
kernel 4.15.rc8 log with drm.debug=0xe and non-working dts-hd (532.66 KB, text/plain)
2018-02-20 18:19 UTC, Dominique Dumont
no flags Details

Description Cincho 2014-02-16 20:30:50 UTC
Created attachment 94175 [details]

Apologies if this is posted in wrong place.

My Setup
AMD A4-5300 (RADEON HD7480)/MSI-FM2-A75MA-E35
--> HDMI -->
--> HDMI -->

No HD-Audio pass through to AVR in any mode other than 60hz leading to dropping/clicking/popping issues with DTS-MA & TrueHD.

I supplied Xrandr at XBMC forums and was advised AVR does not support hd audio in other combination (24p modes), and was advised to raise bug here.

Please see thread here (it is short)

FYI, HD Audio was accepted by AVR in 24p mode with fglrx drivers.

Please see attached and advise if you need other logs.
Comment 1 Cincho 2014-02-16 20:31:19 UTC
Created attachment 94176 [details]
Comment 2 Cincho 2014-02-16 20:32:00 UTC
Created attachment 94177 [details]
Comment 3 Cincho 2014-02-16 20:34:19 UTC
I have saved Xrandr log of stable OE 3.2.4 Generic with fglrx driver it this helps.
Comment 4 jira 2014-04-28 15:08:59 UTC
I have the same issue with a RADEON HD6450. HD audio cannot be played back in 24p mode, but with 60Hz it is possible(Kernel 3.14, Openelec 3.95.6).

My receiver plays the HD audio fine using either Windows or playback over an attached Bluray player.
Comment 5 f.gorzialka 2014-05-21 05:54:08 UTC
same for me: I tried every nightly since openelec 4.0 official and had no luck, yet.
My config (in short):

AMD Kabini System, Asus AM1M-A Board, HDMI --> Pioneer SC-2022 AVR --> LG 50PZ570S TV

I can play hd-audio @60H but with massive stuttering and crackling!
everything below works right, except fpr hd-audio. For the moment I use PCM for everything, just to not lose any sound-information.
Comment 6 TRaSH 2014-09-27 10:12:25 UTC
wonder if this issue can be fixed,
looks like the best option is to kickout my amd stuff and get something that has more support

beeing locked at 60Hz is useless when you want to watch stutter/drop free blu-rays
Comment 7 Alex Deucher 2014-09-29 14:46:00 UTC
Is this still an issue with a newer kernel?  A bunch of patches to fix 24p audio went in a while ago.
Comment 8 EnzoBartoli 2014-10-02 19:21:56 UTC
Created attachment 107234 [details]
OpenELEC debug logs

I was redirected to this issue from: https://github.com/OpenELEC/OpenELEC.tv/issues/3320
This bug still seems to be a problem although I'm not sure if OpenELEC 4.2.0 has included the 24p fixes you mentioned.

I recently bought a Gigabyte Brix with an AMD A8-5545 APU (A8 was listed as supported on the OpenELEC site so felt safe to buy this one). I cannot get HD audio passthrough to work correctly in 24fps. In 24fps mode I have no audio at all. In 60fps mode I sometimes have audio with passthrough detected by the receiver but most of the time the video plays too fast, skips frames and has no audio.

I have attached OpenELEC debug logs (added drm.debug=0xe to /flash/extlinux.conf). If there are more files you need please tell me, I will provide them.
Comment 9 rob 2014-12-22 22:14:22 UTC
Still a problem for me with Ubuntu 3.16 kernel. Very occasional pops and cracking at 60P for TrueHD and DTS-HDMA and no sound at all for 24/50P. Other sources work OK.
Comment 10 Michael 2014-12-26 16:44:45 UTC
I also have the same problem with HD Audio popping and clipping.  I'm running a Denon X4100W, Xubuntu 14, ALSA, and I've tried different combinations of the following: XBMC Gotham and Kodi, kernels 3.13 and 3.16.7, Radeon OSS drivers and AMD Omega 14.12 drivers.  

I've tried different HDMI cables and disabling CEC on my Denon receiver and TV.  When I play the same videos through my Windows 7 Kodi machine and Denon receiver, I do not have any problems with HD Audio popping and clipping.  This leads me to believe there's a problem either with the Linux kernel or Kodi mainline for Linux.
Comment 11 hugo 2014-12-30 23:02:40 UTC
hi, well ME TOO ....
I have a brand new asrock qc 5000 with the A4-5000 ---» HDMI and Onkyo TX NR-626 receiver, i have slow motion picture and crack´s ( sound bug )in the sound.
Comment 12 francesco.borromini 2015-01-04 15:22:00 UTC
Created attachment 111725 [details]
Kodi 14 debug log with Dolby TrueHD/DTS-HD MA audio

Having a similar problem here, Gigabyte Brix GB-BXA8-5545 (A8 5545M APU), connected through my Yamaha RX-V1071 to a Sony KDL-52NX800. Both HDMI connections. I have two test files - one for DTS-HD MA, one for Dolby TrueHD. I can upload those as well if necessary.

Video is 23,976 Hz, audio DTS-HD MA and Dolby TrueHD. Playing those files will give no audio (amp supports both formats, but it shows 'analog' where it should show the format).

With video forced at 60 Hz refresh rate, the amp displays both formats correctly on its info screen and audio plays back correctly for both test files.

Thanks for looking into this.
Comment 13 b.gaige 2015-01-16 17:44:55 UTC
I am having the same issue with a Zotac CA320 box with AMD-APU A6-1450.  There are several others experiencing same problem, as noted in this forum post:

Comment 14 Dominique Dumont 2015-02-22 14:52:33 UTC

I have a similar issue with Kodi 14.1 on Debian/unstable with kernel 3.19 and radeon caicos.

Do you need more information to help diagnose this bug ?

Note that I'm willing to test kernel patches (or xorg patches) to help fix this problem. Feel free to ask.

All the best
Comment 15 Dominique Dumont 2015-05-15 14:57:14 UTC
Issue with HD audio is still present with kernel 4.0.2-1 on Debian unstable: HD stream is not decoded for refresh rate < 60Hz.

All the best
Comment 16 Jan 2015-10-05 21:22:28 UTC
Same issue in my case. 
I run OpenELEC 5.95.5 on a AMD 5350 CPU and Asrock AM1b-ITX mobo.
My receiver is an Onkio TX-SR508 with 7.1 speakers.
I had a Popcorn Hour Mediaplayer  before that played DTS-HD Master audio without a single problem.
With Kodi I am able to use DTS-HD passthrough only on 60Hz but with loud cracks and audio gaps.
I guess that the audio resync causes my Onkio to make the sound. The display stays shows DTS-HD-MSTR without interruption.
When I set Kodi to pass the same FrameRate (23.976Hz) there is no sound (Onkio displays PCM mode), only at 60Hz there is audio.
I tried many settings and different Kodi installations all on Linux but without success.
I hope it can be fixed so I can enjoy 7.1 sound.
Anyone more suggestions?

Regards, Jan.
Comment 17 Jan 2015-10-06 07:16:23 UTC
In addition to my previous report, the url to the Kodi log file.
Comment 18 Jan 2015-10-06 07:18:06 UTC
Comment 19 Peter Frühberger 2015-10-06 07:38:10 UTC
The kodi logfile does not help here. If something help try to boot with drm.debug=0xe and check if you get Audio / Display Sync related messages and post those.
Comment 20 Jan 2015-10-06 19:55:44 UTC
Created attachment 118720 [details]
Log File with DRM.debug=0xe

Hi Peter,
Thanks a lot for your reply.
Attached the requested log file.

Kind regards, Jan.
Comment 21 Jan 2015-10-07 20:03:21 UTC
I just tested Kodi on Wind0ws 10 on the exact same HW configuration 
and enjoyed perfect DTS-HD Master 7.1 sound without gaps and clicks and 24P video. 
I wanted to exclude the chance that my HTPC, cables receiver or TV are the troublemakers and know now these are all fine.
Wind0ws is not an option for my HTPC; I really prefer OpenELEC but hope I can contribute a little with my troubleshooting and feedback...
Regards, Jan.
Comment 22 Dominique Dumont 2015-10-09 17:54:20 UTC
I've retried with kodi 15.1 and linux 4.2.0-1 on Debian/sid amd64

There are some progress: I managed to get Dolby TrueHD somewhat working at 29.98 FPS by:
- booting with kodi set to 60 FPS
- start the movies, Dolby TrueHD plays fine
- pause kodi
- switch to 24 FPS
- resume movie. Dolby TrueHD plays with some dropouts

If my machine boots with kodi set to 24FPS, my Yamaha amp does not detect a stream until kodi is switched to 60 FPS.

I've also setup "options drm debug=0xe" in modprobe.conf to get the required debug logs. I don't think they contain anything relevant. There's no trace of Audio or sync problems.

Only a lot of lines like:
[  738.286556] [drm:radeon_crtc_page_flip] flip-ioctl() cur_rbo = ffff88012984c000, new_rbo = ffff8800c9e42000
[  738.303272] [drm:drm_mode_addfb2] [FB:57]

And some mentions of switching power states when I start and stop movies.

Feel free to contact me if you want more information.

Hope this helps
Comment 23 Dominique Dumont 2015-10-09 18:00:52 UTC
On the other hand, I may be completely wrong. xrandr does not match the FPS shown by kodi:

$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
HDMI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 16mm x 9mm
   1920x1080i    50.00 +  60.00    59.94  
   1920x1080     60.00*   50.00    59.94    24.00    23.98  
   2880x576      50.00  

Sorry about the noise.
Comment 24 Jan 2016-01-04 14:37:04 UTC
This issue is still there with the latest OpenElec version. In Windows 10 on the same HW the issue is not there, audio and video is as expected. 

Is there any chance this issue will be solved in future releases or is there anything I can do to help troubleshoot?

Please advice.
Kind regards, Jan.
Comment 25 Dominique Dumont 2016-04-24 15:41:52 UTC

Unfortunately, the issue is still present with kernel 4.5.0 (on Debian unstable with kodi 16).

Is there anything I can do to help ?

All the best
Comment 26 Alan Swanson 2017-07-21 12:54:23 UTC
Still an issue with Linux 4.12.3 and radeon driver where passthrough of Dolby TrueHD or DTS-HD MA at modes lower than 60Hz results in no audio signal reported by AV amplifiers.

While can at least decode both to raw PCM output in Kodi by disabling passthrough  it would still be nice to fix bug and offload the processing to AV amplifier.
Comment 27 Dominique Dumont 2018-02-20 18:19:17 UTC
Created attachment 137472 [details]
kernel 4.15.rc8 log with drm.debug=0xe and non-working dts-hd


Unfortunately, DTS_HD still does not owrk with kernel 4.1.5.rc8. 

I've attached a complete kernel log done with drm.debug=0xe

While playing (silently) a DTS_HD file with kodi, the kernel logged a lot of lines like:
 [drm:radeon_crtc_page_flip_target [radeon]] flip-ioctl() cur_rbo = 0000000026ca5fac, new_rbo = 00000000696c7c9c

Is this log enough to progress or do you need more logs with other debug parameters ?

All the best
Comment 28 Martin Peres 2019-11-19 08:43:04 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/amd/issues/438.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.