Bug 75076 - gedit crash when harfbuzz is compiled with graphite2
Summary: gedit crash when harfbuzz is compiled with graphite2
Status: RESOLVED FIXED
Alias: None
Product: HarfBuzz
Classification: Unclassified
Component: src (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Behdad Esfahbod
QA Contact:
URL:
Whiteboard:
Keywords:
: 77433 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-17 03:15 UTC by Parag
Modified: 2014-07-19 21:21 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
sample file that crashes gedit (227 bytes, text/plain)
2014-02-17 03:15 UTC, Parag
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Parag 2014-02-17 03:15:39 UTC
Created attachment 94183 [details]
sample file that crashes gedit

gedit crashes when loading the attached file with graphite2 support enabled.

Downstream bug is https://bugzilla.redhat.com/show_bug.cgi?id=998812
Comment 1 Behdad Esfahbod 2014-04-10 00:00:47 UTC
More context:

  https://bugzilla.gnome.org/show_bug.cgi?id=723582
Comment 2 Behdad Esfahbod 2014-05-30 21:42:31 UTC
I believe this should fix it:

commit 6ae13f257c3986517c097fa666ab9f58bdc918b5
Author: Behdad Esfahbod <behdad@behdad.org>
Date:   Fri May 30 17:38:14 2014 -0400

    [graphite2] Fix cluster mapping
    
    Patch from Martin Hosken.  I expect this to fix the following bugs:
    
    https://bugs.freedesktop.org/show_bug.cgi?id=75076
    https://bugzilla.gnome.org/show_bug.cgi?id=723582
    https://bugzilla.redhat.com/show_bug.cgi?id=998812
Comment 3 Behdad Esfahbod 2014-07-19 21:21:22 UTC
*** Bug 77433 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.