Bug 75128 - Artifacts
Summary: Artifacts
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r300 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-18 01:51 UTC by publicface
Modified: 2019-09-18 18:52 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
/var/log/Xorg.0.log (243.33 KB, text/plain)
2014-02-18 04:34 UTC, publicface
Details
output of dmesg (3.56 KB, text/plain)
2014-02-18 04:39 UTC, publicface
Details
Screenshot (192.04 KB, image/png)
2014-04-16 07:04 UTC, publicface
Details
Another screenshot (161.12 KB, image/png)
2014-04-16 07:06 UTC, publicface
Details
Third and final screenshot (192.04 KB, image/png)
2014-04-16 07:07 UTC, publicface
Details
screenshot (59.77 KB, image/png)
2014-05-25 02:09 UTC, publicface
Details
xwininfo (730 bytes, text/plain)
2014-05-25 02:10 UTC, publicface
Details
xprop (1.13 KB, text/plain)
2014-05-25 02:12 UTC, publicface
Details
output of dmesg (4.42 KB, text/plain)
2014-05-25 02:15 UTC, publicface
Details

Note You need to log in before you can comment on or make changes to this bug.
Description publicface 2014-02-18 01:51:20 UTC
Gallium 0.4 on ATI RV370

From time to time artifacts in the form of dialog boxes appear and won't go away.

Ubuntu 12.04 with kubuntu-desktop
Comment 1 Michel Dänzer 2014-02-18 03:36:07 UTC
Please provide more information about the problem, e.g. attach screenshots showing the artifacts.

As always, please attach /var/log/Xorg.0.log and the output of dmesg.
Comment 2 publicface 2014-02-18 04:34:28 UTC
Created attachment 94251 [details]
/var/log/Xorg.0.log
Comment 3 publicface 2014-02-18 04:39:48 UTC
Created attachment 94252 [details]
output of dmesg

Note that I do not have a screenprint for two reasons... 1) I've already restarted kdm as the artifacts make it impossible to read the screen and 2) for whatever reason my screenprint (ksnaphot) stopped working and I've been unable to determine why or how to fix it.
Comment 4 Michel Dänzer 2014-02-18 07:43:46 UTC
(In reply to comment #3)
> 1) I've already restarted kdm as the artifacts make it impossible to read the
> screen and 2) for whatever reason my screenprint (ksnaphot) stopped working
> and I've been unable to determine why or how to fix it.

There are many other tools for taking screenshots, or you could take a picture with a mobile phone or digital camera.

Without seeing a picture, 'artifacts in the form of dialog boxes appear and won't go away' sounds more likely to be an issue with some KDE component than with the drivers FWIW. What does xwininfo say when you click on a dialog box?
Comment 5 publicface 2014-02-18 21:52:38 UTC
I've been able to fix ksnapshot (I didn't know how to force a reinstall - now I do).  

So since as I mentioned I already restarted kdm (and by inference, the X server) this problem can't be further explored at this time, what other tools/procedures should I be prepared with next time it happens?

screenshot
/var/log/Xorg.0.log
dmesg
xwininfo

Anything else?

For the record, the reason I reported it here is due to a discussion with someone else.  And I quote: "I moved away from ATi/AMD altogether to nvidia because of the constant screen corruption issues on both the open source and proprietary drivers".

Since changing cards isn't an option at this time, reporting the problem is a bit easier.  It doesn't happen often, but it does happen every now and then.

Me personally I'm not interested in blaming anyone or anything.  I don't care where the bugs are, other than in terms of getting them fixed.  Since restarting kdm is almost as extreme as rebooting, I would like to see a way to reset the screen without having the net effect of being logged out.  I don't know if that's something that could be accomplished in the driver, or where exactly it could be done.
Comment 6 publicface 2014-04-16 07:04:47 UTC
Created attachment 97449 [details]
Screenshot

I made the switch to XFCE desktop... at least for awhile.  Now I'm back to KDE for the moment, but the artifacts occurred during xfce usage.  

Note: I stay logged in for weeks at a time.  I don't reboot - or logout, unless something forces me to do so like a system update that requires a reboot... or artifacts that obscure the window so I can no longer see what I'm doing; or some other severe problem.
Comment 7 publicface 2014-04-16 07:06:53 UTC
Created attachment 97451 [details]
Another screenshot
Comment 8 publicface 2014-04-16 07:07:37 UTC
Created attachment 97452 [details]
Third and final screenshot
Comment 9 Michel Dänzer 2014-04-16 07:15:21 UTC
Thanks for the screenshots. Please provide the output from xwininfo.
Comment 10 publicface 2014-05-25 02:09:28 UTC
Created attachment 99748 [details]
screenshot
Comment 11 publicface 2014-05-25 02:10:53 UTC
Created attachment 99749 [details]
xwininfo
Comment 12 publicface 2014-05-25 02:12:17 UTC
Created attachment 99750 [details]
xprop
Comment 13 publicface 2014-05-25 02:15:39 UTC
Created attachment 99751 [details]
output of dmesg
Comment 14 publicface 2014-05-25 02:23:08 UTC
A fresh set of files for you, for a fresh artifact.

Files include screenshot, dmesg (minus several thousand lines of output from iptables that I assume you're not interested in), Xorg.0.log, xwininfo and xprop (redacted).

The artifact occurred while trying to copy some selected/highlighted text with a right-click.  The copy window never actually appeared, other than the artifact you see in the screenshot.  Note that the artifact is "top-level" and obscures all other windows.

Please advise.

Thank you
Comment 15 publicface 2014-05-25 02:33:04 UTC
I tried to paste /var/log/Xorg.0.log here and also tried to attach it.  bugzilla barfs in both cases (I presume because of the size of it).  If you still need to see it, then please suggest an alternate method of getting it to you.

Thank you
Comment 16 Michel Dänzer 2014-05-27 03:49:59 UTC
Looks like it's a Google Chrome window. Might be an issue in Google Chrome, or possibly in kwin (e.g. if you can't close it via right-click / Alt-F4 / ...). Presumably you should be able to get rid of it with xkill though.

Either way, it's not a driver issue.
Comment 17 publicface 2014-05-27 07:59:10 UTC
That particular window was just ONE example that happened to be available at the time I was able to get the snapshot.  The fact of the matter is more than one application leaves artifacts, not just google chrome.  One of those screenshots clearly shows a dialpad - which comes from jitsi.

Therefore it is not likely to be an application issue, as at least two applications leave artifacts as can be seen from the screenshot.
Comment 18 Michel Dänzer 2014-05-27 09:57:35 UTC
Looking at your older screenshots, I agree that looks like it might be a different issue. But we'll need to see the xwininfo output for that case as well then.
Comment 19 GitLab Migration User 2019-09-18 18:52:18 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/359.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.