Bug 7591 - Mesa/DRI installed correctly, but 3D apps don't work/crash on Unichrome chipset
Mesa/DRI installed correctly, but 3D apps don't work/crash on Unichrome chipset
Status: RESOLVED DUPLICATE of bug 7169
Product: Mesa
Classification: Unclassified
Component: GLX
6.4
x86 (IA32) Linux (All)
: high normal
Assigned To: mesa-dev
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-21 15:47 UTC by christian_obst
Modified: 2006-07-24 06:57 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Output of lspci -v (5.19 KB, text/plain)
2006-07-21 15:51 UTC, christian_obst
Details
Output of glxinfo (3.65 KB, text/plain)
2006-07-21 15:52 UTC, christian_obst
Details
gzipped Xorg.0.log (8.52 KB, application/gzip)
2006-07-21 15:53 UTC, christian_obst
Details
Results of trying to run each of the mesademos (3.32 KB, text/plain)
2006-07-21 15:57 UTC, christian_obst
Details

Note You need to log in before you can comment on or make changes to this bug.
Description christian_obst 2006-07-21 15:47:50 UTC
Although glxinfo reports that Direct Rendering is enabled, several 3D apps do
not work, because they complain about DRI _not_ being enabled/software mesa
being enabled (tremulous), or simply crash and freeze the system (xscreensaver,
amoeba). However, glxgear works accelerated. I also tried the mesademos. I
attach the results along with the output of lspci -v, my /var/log/Xorg.o.log,
and the output of glxinfo. I am using the latest Openchrome driver (trunk 194)
on Debian testing. My kernel is 2.6.17.3.
Comment 1 christian_obst 2006-07-21 15:51:48 UTC
Created attachment 6297 [details]
Output of lspci -v
Comment 2 christian_obst 2006-07-21 15:52:19 UTC
Created attachment 6298 [details]
Output of glxinfo
Comment 3 christian_obst 2006-07-21 15:53:05 UTC
Created attachment 6299 [details]
gzipped Xorg.0.log
Comment 4 christian_obst 2006-07-21 15:57:26 UTC
Created attachment 6300 [details]
Results of trying to run each of the mesademos
Comment 5 Ian Romanick 2006-07-21 16:14:17 UTC
Do the failing programs work correctly if LD_PRELOAD is used to force the
correct loading of libGL?
Comment 6 christian_obst 2006-07-21 16:47:06 UTC
Actually, yes. tremulous (its an opensource 3D game) now starts up nicely and
does not complain about software mesa anymore. However, after a few minutes of
playing, it freezes. Sometimes I can switch to a console and kill it, but
sometimes I can't, and even if I can, the system stays unusable (X screen has
artefacts, system very slow, eventually freezes completely).
As for the mesademos, LD_PRELOAD does not help. But I don't think you meant
them, anyway.
Comment 7 Ian Romanick 2006-07-24 06:57:25 UTC

*** This bug has been marked as a duplicate of 7169 ***