Bug 75917 - backlight switches off when starting X - since kernel-3.13
Summary: backlight switches off when starting X - since kernel-3.13
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: Other All
: high blocker
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-08 19:17 UTC by nl
Modified: 2016-05-12 05:36 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
possible fix (1.04 KB, patch)
2014-05-19 18:11 UTC, Alex Deucher
no flags Details | Splinter Review
dmesg output before patching (and with runpm) (56.49 KB, text/plain)
2014-05-20 15:32 UTC, nl
no flags Details
possible fix v2 (1.11 KB, patch)
2014-05-20 15:44 UTC, Alex Deucher
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description nl 2014-03-08 19:17:40 UTC
After updating from linux 3.12.8 to 3.13 my display backlight 
switches off when starting X. 
The kernel doesn't  crash, it just switched off the backlight.

Hardware name: Acer Aspire 3820T/JM31_CP, BIOS V1.19 10/27/2010

This is a notebook with an intel/radeon hybrid graphics. 
I use  intel for my X. I report this as radeon problem because 
git bisect (on linux-stable tree) showed the following commit 
as the cause of my problem:

10ebc0bc09344ab6310309169efc73dfe6c23d72 is the first bad commit
commit 10ebc0bc09344ab6310309169efc73dfe6c23d72
Author: Dave Airlie <airlied at redhat.com>
Date:   Mon Sep 17 14:40:31 2012 +1000

    drm/radeon: add runtime PM support (v2)
    
    This hooks radeon up to the runtime PM system to enable
    dynamic power management for secondary GPUs in switchable
    and powerxpress laptops.
    
    v2: agd5f: clean up, add module parameter
    
    Signed-off-by: Dave Airlie <airlied at redhat.com>
    Signed-off-by: Alex Deucher <alexander.deucher at amd.com>


Please let me know if you need addititonal information.
Comment 1 Yuanjie 2014-03-14 05:39:57 UTC
I have the same problem with radeon/intel laptop:

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Madison [Mobility Radeon HD 5650/5750 / 6530M/6550M] (rev ff)
Comment 2 nl 2014-05-17 21:35:17 UTC
As the problem still exists and prevents me from using any kernel 3.13+ 
I changed the priority of this bug.

When I did the git bisect I hoped it would help to find a solution soon.

Is there anything I can do to help fixing this problem? 

I don't want to get stuck on kernel 3.12.20 :(
Comment 3 Alex Deucher 2014-05-19 02:08:22 UTC
Does disabling runpm help?  Boot with radeon.runpm=0 on the kernel command line in grub.
Comment 4 nl 2014-05-19 17:37:10 UTC
(In reply to comment #3)
> Does disabling runpm help?  Boot with radeon.runpm=0 on the kernel command
> line in grub.

yes it does :)
Comment 5 nl 2014-05-19 17:37:37 UTC
thank you
Comment 6 Alex Deucher 2014-05-19 17:44:53 UTC
Please attach your dmesg output.  Is this a muxed or muxless laptop?
Comment 7 Alex Deucher 2014-05-19 18:11:23 UTC
Created attachment 99349 [details] [review]
possible fix

Does the attached patch help?
Comment 8 nl 2014-05-20 15:32:36 UTC
Created attachment 99424 [details]
dmesg output before patching (and with runpm)
Comment 9 nl 2014-05-20 15:35:47 UTC
(In reply to comment #7)
> Does the attached patch help?

The patch works fine, however the display backlight switches off for several seconds during X init now (it didn't with kernel 2.12) but this is not really a problem, as it comes back happily :) thank you.
Comment 10 Alex Deucher 2014-05-20 15:44:20 UTC
Created attachment 99427 [details] [review]
possible fix v2

(In reply to comment #9)
> The patch works fine, however the display backlight switches off for several
> seconds during X init now (it didn't with kernel 2.12) but this is not
> really a problem, as it comes back happily :) thank you.

Does this patch work any better?
Comment 11 nl 2014-05-20 20:43:59 UTC
(In reply to comment #10)
> Created attachment 99427 [details] [review] [review]
> possible fix v2

> Does this patch work any better?

No, pretty much the same behaviour as the first version here. The backlight switches off when X starts, and comes backs ~5 seconds later. (same delay in restoring backlight after resume from suspend)
Comment 12 sfievet 2014-06-14 12:47:21 UTC
I am affected by this bug too.
I have a Acer 3820TG laptop featuring Intel IGP (Ironlake) / AMD DGP (Radeon 6550M). It kept me stucked with kernel 3.12 series until I googled for "backlight issue" rather than "Intel driver issue" and found THIS bug report. :-)

adding radeon.runpm=0 to the boot options works for me too. I haven't tested the patch yet.

FWIW, I'd like to add 2 side informations hoping it might be related :
- the backlight control only works for the Intel IGP. If the laptop goes idle when on the radeon, waking it up doesn't bring the backlight back.
- when switching from Ironlake to Radeon through VGA switcheroo, I have to use "ON -> MIGD -> DDIS" sequence as the screen goes black immediately after passing "ON".
Comment 13 sfievet 2014-06-14 14:15:06 UTC
Forgot to say : this is a muxed laptop.
Comment 14 Alex Deucher 2014-06-16 15:23:06 UTC
Fix is upstream:
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=f2bc561610962693be61425cf913778586d8f9c1
and will make it's way back to stable kernels as well.
Comment 15 sfievet 2014-06-16 19:28:45 UTC
I just applied the fixed against 3.15.0, and it does work as reported.
The 5s delay at X startup is a bit annoying but acceptable... 
In my case it actually happens twice :
- at X startup
- at session start (presumably when the XFCE power manager tool starts up)

Thank you for helping us out


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.