Bug 76039 - stuck on render ring at seemingly random moments. Hangs for a few seconds, and then continues with glitches
Summary: stuck on render ring at seemingly random moments. Hangs for a few seconds, an...
Status: RESOLVED DUPLICATE of bug 77207
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Kenneth Graunke
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-11 16:52 UTC by Robert de Jager
Modified: 2014-04-14 17:41 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Dump from /sys/class/drm/card1/error (418.12 KB, text/plain)
2014-03-11 16:52 UTC, Robert de Jager
Details
These artifacts are often visible, even before the render ring error (13.93 KB, image/png)
2014-03-16 12:42 UTC, Robert de Jager
Details
this sometimes happens to all fonts (42.02 KB, image/png)
2014-03-16 12:42 UTC, Robert de Jager
Details
This happens when I run glxspheres for the first time, the second time it's ok (452.09 KB, image/png)
2014-03-19 09:37 UTC, Robert de Jager
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert de Jager 2014-03-11 16:52:35 UTC
Created attachment 95614 [details]
Dump from /sys/class/drm/card1/error

The system hangs for a few seconds, then dmesg spews this:

[  197.405192] [drm] GPU crash dump saved to /sys/class/drm/card1/error
[  197.405193] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[  197.405194] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[  197.405195] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[  197.405196] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[  203.441104] [drm] stuck on render ring

And the system continues.

Untill reboot random glitches (mostly white bars and blacked out textboxes) appear

Also, around the time this started happening, bumblebee started rendering black windows when using Primus as a bridge. VirtualGL looks normal.

Primus can be fixed by setting environment variable PRIMUS_UPLOAD=1
Comment 1 Robert de Jager 2014-03-11 16:53:25 UTC
Acceleration method is SNA
changing to UXA seems to make it worse
Comment 2 Robert de Jager 2014-03-16 12:42:23 UTC
Created attachment 95887 [details]
These artifacts are often visible, even before the render ring error
Comment 3 Robert de Jager 2014-03-16 12:42:55 UTC
Created attachment 95888 [details]
this sometimes happens to all fonts
Comment 4 Robert de Jager 2014-03-19 09:37:51 UTC
Created attachment 96030 [details]
This happens when I run glxspheres for the first time, the second time it's ok
Comment 5 Robert de Jager 2014-03-19 09:39:46 UTC
The artifacts and glitches appear even before the render ring error. It seems to be getting worse
Comment 6 Kenneth Graunke 2014-04-13 17:27:50 UTC
Hi Robert,

Can you try running KWin with EGL and see if that makes your artifacts and GPU hangs go away?

KWIN_OPENGL_INTERFACE=egl kwin --replace &

Thanks.
Comment 7 Robert de Jager 2014-04-14 15:54:46 UTC
I have used it for a couple of hours with the KWIN_OPENGL_INTERFACE=egl export, and the artifacts seem to have gone away.
Comment 8 Robert de Jager 2014-04-14 15:55:07 UTC
Hangs also
Comment 9 Kenneth Graunke 2014-04-14 17:41:27 UTC

*** This bug has been marked as a duplicate of bug 77207 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.