Bug 76398 - [IVB/HSW] ogl-samples: gl-320-fbo-multisample-integer render error “no texture”
Summary: [IVB/HSW] ogl-samples: gl-320-fbo-multisample-integer render error “no texture”
Status: CLOSED NOTOURBUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-20 11:54 UTC by meng
Modified: 2015-05-14 01:46 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
render error png for gl-320-fbo-multisample-integer (13.56 KB, image/png)
2014-03-20 11:55 UTC, meng
Details
Patch for the test (597 bytes, patch)
2014-04-01 09:34 UTC, Iago Toral
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description meng 2014-03-20 11:54:25 UTC
System Environment:
--------------------------
Mesa:   (master)eaf9affa5ec9c5fd919e4207ab80b4677650ac67
Xserver:(master)xorg-server-1.15.99.901 Xf86_video_intel:	
Xf86_video_intel:(master)2.99.911
Kernel:	(drm-intel-nightly) git-ec45c7

Bug detailed description:
----------------------------
It’s not a regression, firstly test ogl-samples.

Pre-conditions:
 - build: https://github.com/g-truc/ogl-samples

Test-case: gl-320-fbo-multisample-integer

Expected outcome:
-----------------
https://github.com/g-truc/ogl-samples/blob/master/data/templates/reference/gl-320-fbo-multisample-integer.png

Actual outcome:
------------------------
Black instead of blue&texture. Please see error.png attached.
Comment 1 meng 2014-03-20 11:55:09 UTC
Created attachment 96098 [details]
render error png for gl-320-fbo-multisample-integer
Comment 2 Iago Toral 2014-04-01 09:30:52 UTC
Looking at the source code of the test I see it is missing the mig/mag filters for the texture used to paint the framebuffer. Adding these filters after creating the texture fixes the problem so this looks like a bug in the test code to me.
Comment 3 Iago Toral 2014-04-01 09:34:45 UTC
Created attachment 96708 [details] [review]
Patch for the test

This is a patch for the ogl-samples test adding the min/mag filters to the texture. Apply the patch to ogl-samples, then  rebuild and re-run the test. Should render proper results now.

I'll try to reach the developers and let them know about this.
Comment 4 Iago Toral 2014-04-02 06:19:30 UTC
According to the ogl-samples developers this is a bug in Mesa:

"Sampler states don't affect rendering to a texture of blitting a texture. 
The bug here is that the drivers consider the texture incomplete."
Comment 5 Iago Toral 2014-04-03 08:08:35 UTC
Actually the problem is not the blitting operation but the rendering to the main framebuffer with the blitting results. Setting the filters after the blit and before rendering to the framebuffer does fix the problem too so this may still be a bug in test code.
Comment 6 Alejandro Piñeiro (freenode IRC: apinheiro) 2015-03-13 17:10:11 UTC
Tested today with a Haswell GPU, with 10.3.2 (system), master (git-b43bbfa), and the one used when the bug was reported (git-eaf9aff).

Then I moved to check the test suite itself, and it started to work (on all those mesa versions) after this commit:
https://github.com/g-truc/ogl-samples/commit/81ad3fdd9f830ae7e27d6108a8f783065073e872

So the bug was fixed on the test side, as suggested on comment 5.

I think that this bug can be closed.
Comment 7 Alejandro Piñeiro (freenode IRC: apinheiro) 2015-03-13 17:18:34 UTC
(In reply to Alejandro Piñeiro (freenode IRC: apinheiro) from comment #6)
> Tested today with a Haswell GPU, with 10.3.2 (system), master (git-b43bbfa),
> and the one used when the bug was reported (git-eaf9aff).

Final sentence missing: "And worked on all of them."


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.