Bug 76399 - ogl-samples: gl-320-texture-integer assertion fails
Summary: ogl-samples: gl-320-texture-integer assertion fails
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL: https://cvs.khronos.org/bugzilla/show...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-20 12:07 UTC by meng
Modified: 2019-09-25 18:50 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description meng 2014-03-20 12:07:54 UTC
System Environment:
--------------------------
Mesa:   (master)eaf9affa5ec9c5fd919e4207ab80b4677650ac67
Xserver:(master)xorg-server-1.15.99.901 Xf86_video_intel:	
Xf86_video_intel:(master)2.99.911
Kernel:	(drm-intel-nightly) git-ec45c7

Bug detailed description:
----------------------------
It’s not a regression, firstly test ogl-samples.

Pre-conditions:
 - build: https://github.com/g-truc/ogl-samples

Test-case: gl-320-texture-integer

Expected outcome:
-----------------
https://github.com/g-truc/ogl-samples/blob/master/data/templates/reference/gl-320-texture-integer.png

Actual outcome:
------------------------
It’s core dump.
   -"OpenGL Error(GL_INVALID_OPERATION): initTexture"
   -ogl-samples/framework/test.cpp:412: bool test::checkError(const char*) const: Assertion `0' failed.
Comment 1 meng 2014-03-20 12:11:30 UTC
Another test case: Gl-330-texture-rect too.
Comment 2 Kenneth Graunke 2014-03-23 07:51:04 UTC
The program calls glGenerateMipmaps on a RGBA8UI texture, which Anuj disallowed in:

commit c0a78d7d7b51e125d143e693fdfc78b90f2d68cf
Author: Anuj Phogat <anuj.phogat@gmail.com>
Date:   Fri Nov 2 10:47:33 2012 -0700

    mesa: Generate invalid operation in glGenerateMipMap for integer textures
    
    Khronos has reached a conclusion and disallowed following texture formats in
    glGenerateMipMap():
     (a) ASTC textures
     (b) integer internal formats (e.g., RGBA8UI, RG16I)
     (c) textures with stencil formats (e.g., STENCIL_INDEX8)
     (d) textures with packed depth/stencil formats (e.g, DEPTH24_STENCIL8)
    
    https://cvs.khronos.org/bugzilla/show_bug.cgi?id=9471
    
    Note: This is a candidate for stable branches.
    Signed-off-by: Anuj Phogat <anuj.phogat@gmail.com>
    Reviewed-by: Brian Paul <brianp@vmware.com>

After that, the program asserts that there is no error...and dies.

Reading the Khronos bug, it sounds like the final resolution was to do what Anuj implemented.  However, I see zero text to that effect in the OpenGL 4.3 or even 4.4 specs.  It sounds like they instead adopted a "it ought to work" resolution.

Reverting Anuj's commit fixes this demo.  Ian, do you think we should clarify with Khronos, or how would you like to proceed?
Comment 3 Kenneth Graunke 2014-03-23 08:09:13 UTC
(In reply to comment #1)
> Another test case: Gl-330-texture-rect too.

That's an unrelated failure.  I've split that issue out into a new bug, #76496.

This bug remains about gl-320-texture-integer.
Comment 4 Matt Turner 2016-11-03 18:47:51 UTC
Still fails.

Mesa: User error: GL_INVALID_OPERATION in glGenerateMipmap(invalid internal format GL_RGBA8UI)

I've made a comment in the Khronos bug about this. Looks like it was forgotten.
Comment 5 GitLab Migration User 2019-09-25 18:50:30 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1422.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.