Bug 76559 - screen corruption after going from VT to X
Summary: screen corruption after going from VT to X
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: General (show other bugs)
Version: XOrg git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-24 16:31 UTC by Fabio Pedretti
Modified: 2019-10-14 13:20 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg (62.36 KB, text/plain)
2014-03-24 16:32 UTC, Fabio Pedretti
no flags Details
Xorg log after the corruption has been reproduced (X -> VT -> X) and restored changing resolution (66.99 KB, text/plain)
2014-03-24 16:33 UTC, Fabio Pedretti
no flags Details
dmesg with 3.19.0-26-generic (71.67 KB, text/plain)
2015-09-02 07:46 UTC, Fabio Pedretti
no flags Details
dmesg with 3.19.0-26-generic (68.84 KB, text/plain)
2015-09-02 13:47 UTC, Fabio Pedretti
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Pedretti 2014-03-24 16:31:37 UTC
I have a MacBook Pro with a RV530 with an external Philips 22" monitor connected (the notebook screen is disabled in X). After switching to VT and then coming back to X the screen is corrupted (like if every odd line has an offset). The same happens after suspend. A screenshot doesn't show the problem. I then usually change resolution with the Ubuntu tool (selecting a different resolution and then reapplying the previous one) and that restore the screen.

Attached dmesg and Xorg log after the X -> VT -> X cycle.
Comment 1 Fabio Pedretti 2014-03-24 16:32:09 UTC
Created attachment 96296 [details]
dmesg
Comment 2 Fabio Pedretti 2014-03-24 16:33:33 UTC
Created attachment 96297 [details]
Xorg log after the corruption has been reproduced (X -> VT -> X) and restored changing resolution
Comment 3 Fabio Pedretti 2014-04-09 13:46:02 UTC
This issue is still reproducible with Ubuntu 14.04 kernel (3.13.0-23.45), before I was using 3.11.0-18.32 (Ubuntu 13.10 kernel).

This annoying issue is possibly not specific to radeon module. The following dmesg ERROR is interesting and may be of help. Maybe it needs a monitor quirk?

[    3.398641] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 58
[    3.398646] Raw EDID:
[    3.398652]  	00 ff ff ff ff ff ff 00 06 10 56 9c 00 00 00 00
[    3.398656]  	04 10 01 03 80 22 16 78 0a 87 f5 94 57 4f 8c 27
[    3.398660]  	27 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01
[    3.398664]  	01 98 03 a2 01 01 9f 25 a0 40 51 84 0c 30 40 20
[    3.398669]  	33 00 4b cf 10 00 00 19 00 00 00 01 00 06 10 30
[    3.398673]  	00 00 00 00 00 00 00 00 0a 20 00 00 00 fe 00 4c
[    3.398677]  	54 4e 31 35 34 58 37 00 00 00 0a 20 00 00 00 fc
[    3.398681]  	00 43 6f 6c 6f 72 20 4c 43 44 0a 20 20 20 00 d5
[    3.427467] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 58
[    3.427471] Raw EDID:
[    3.427475]  	00 ff ff ff ff ff ff 00 06 10 56 9c 00 00 00 00
[    3.427479]  	04 10 01 03 80 22 16 78 0a 87 f5 94 57 4f 8c 27
[    3.427483]  	27 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01
[    3.427487]  	01 98 03 a2 01 01 9f 25 a0 40 51 84 0c 30 40 20
[    3.427491]  	33 00 4b cf 10 00 00 19 00 00 00 01 00 06 10 30
[    3.427495]  	00 00 00 00 00 00 00 00 0a 20 00 00 00 fe 00 4c
[    3.427499]  	54 4e 31 35 34 58 37 00 00 00 0a 20 00 00 00 fc
[    3.427503]  	00 43 6f 6c 6f 72 20 4c 43 44 0a 20 20 20 00 d5
[    3.456273] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 58
[    3.456278] Raw EDID:
[    3.456283]  	00 ff ff ff ff ff ff 00 06 10 56 9c 00 00 00 00
[    3.456287]  	04 10 01 03 80 22 16 78 0a 87 f5 94 57 4f 8c 27
[    3.456292]  	27 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01
[    3.456296]  	01 98 03 a2 01 01 9f 25 a0 40 51 84 0c 30 40 20
[    3.456300]  	33 00 4b cf 10 00 00 19 00 00 00 01 00 06 10 30
[    3.456304]  	00 00 00 00 00 00 00 00 0a 20 00 00 00 fe 00 4c
[    3.456308]  	54 4e 31 35 34 58 37 00 00 00 0a 20 00 00 00 fc
[    3.456312]  	00 43 6f 6c 6f 72 20 4c 43 44 0a 20 20 20 00 d5
[    3.484997] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 58
[    3.485001] Raw EDID:
[    3.485005]  	00 ff ff ff ff ff ff 00 06 10 56 9c 00 00 00 00
[    3.485009]  	04 10 01 03 80 22 16 78 0a 87 f5 94 57 4f 8c 27
[    3.485013]  	27 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01
[    3.485017]  	01 98 03 a2 01 01 9f 25 a0 40 51 84 0c 30 40 20
[    3.485021]  	33 00 4b cf 10 00 00 19 00 00 00 01 00 06 10 30
[    3.485025]  	00 00 00 00 00 00 00 00 0a 20 00 00 00 fe 00 4c
[    3.485029]  	54 4e 31 35 34 58 37 00 00 00 0a 20 00 00 00 fc
[    3.485033]  	00 43 6f 6c 6f 72 20 4c 43 44 0a 20 20 20 00 d5
[    3.485041] radeon 0000:01:00.0: LVDS-1: EDID block 0 invalid.
Comment 4 Fabio Pedretti 2015-09-02 07:46:21 UTC
Created attachment 118045 [details]
dmesg with 3.19.0-26-generic

Any news on this issue?
It is still reproducible with Ubuntu 15.04 kernel:
Linux fabio-mac 3.19.0-26-generic #28-Ubuntu SMP Tue Aug 11 14:16:45 UTC 2015 i686 i686 i686 GNU/Linux

Attached updated dmesg.

Let me know if something other is needed.
Comment 5 Alex Deucher 2015-09-02 13:34:09 UTC
this seems suspect:
[   61.916143] ------------[ cut here ]------------
[   61.916157] WARNING: CPU: 0 PID: 31 at /build/linux-eVPZfP/linux-3.19.0/arch/x86/kernel/check.c:140 check_for_bios_corruption+0x8d/0xd0()
[   61.916161] Memory corruption detected in low memory

Maybe some Mac firmware issue?
Comment 6 Fabio Pedretti 2015-09-02 13:47:15 UTC
Created attachment 118051 [details]
dmesg with 3.19.0-26-generic

> Maybe some Mac firmware issue?

Possibly, but I think that may not be related, as that doesn’t always happen and maybe be a different issue.

I attach a different dmesg where the crash doesn't happen, but the corruption problem is still present.
Comment 7 Martin Peres 2019-10-14 13:20:14 UTC
Hi,

Freedesktop's Bugzilla instance is EOLed and open bugs are about to be migrated to http://gitlab.freedesktop.org.

To avoid migrating out of date bugs, I am now closing all the bugs that did not see any activity in the past year. If the issue is still happening, please create a new bug in the relevant project at https://gitlab.freedesktop.org/drm (use misc by default).

Sorry about the noise!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.