Bug 76907 - window manager disappears
Summary: window manager disappears
Status: RESOLVED DUPLICATE of bug 77207
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Kenneth Graunke
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-01 15:27 UTC by Joaquin Garcia
Modified: 2014-04-16 04:31 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
GPU crash dump (125 bytes, text/plain)
2014-04-01 15:27 UTC, Joaquin Garcia
Details
dmesg output (49.73 KB, text/plain)
2014-04-01 15:29 UTC, Joaquin Garcia
Details
reatach file (326.65 KB, application/octet-stream)
2014-04-01 15:35 UTC, Joaquin Garcia
Details
another dump, dmesg output (50.45 KB, text/plain)
2014-04-08 07:04 UTC, Joaquin Garcia
Details
new crash dump (318.71 KB, application/octet-stream)
2014-04-08 07:07 UTC, Joaquin Garcia
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joaquin Garcia 2014-04-01 15:27:20 UTC
Created attachment 96732 [details]
GPU crash dump

[ 4352.772748] [drm] stuck on render ring
[ 4352.772753] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 4352.772754] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 4352.772755] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[ 4352.772755] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 4352.772756] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 4352.775394] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0x2463000 ctx 1) at 0x2464404
Comment 1 Joaquin Garcia 2014-04-01 15:29:39 UTC
Created attachment 96733 [details]
dmesg output
Comment 2 Chris Wilson 2014-04-01 15:31:51 UTC
Please supply the full /sys/class/drm/card0/error, the current attachment is corrupt.
Comment 3 Joaquin Garcia 2014-04-01 15:34:26 UTC
New Attach file
Comment 4 Joaquin Garcia 2014-04-01 15:35:04 UTC
Created attachment 96734 [details]
reatach file
Comment 5 Chris Wilson 2014-04-01 15:40:48 UTC
Context intact, but the wild write clobbered the batchbuffer this time.
Comment 6 Joaquin Garcia 2014-04-08 07:04:08 UTC
Created attachment 97057 [details]
another dump, dmesg output
Comment 7 Joaquin Garcia 2014-04-08 07:07:03 UTC
Created attachment 97058 [details]
new crash dump

using driver intel-linux-graphics-installer_1.0.4-0intel1_amd64.deb
Comment 8 Kenneth Graunke 2014-04-13 17:34:10 UTC
Are you using KDE?  If so, this is a duplicate of 77207.
Comment 9 Joaquin Garcia 2014-04-14 06:49:43 UTC
(In reply to comment #8)
> Are you using KDE?  If so, this is a duplicate of 77207.

That's right, it happens with KDE, from April 1 to report the bug.
Rather would duplicate the 77207 :)
Comment 10 Kenneth Graunke 2014-04-16 04:31:17 UTC
Fixed in Mesa master.  Upgrading to X server 1.15.1 or 1.14.6 will also fix this.  Setting KWIN_OPENGL_INTERFACE=egl should also work around the problem without having to upgrade any software.

*** This bug has been marked as a duplicate of bug 77207 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.