Bug 76939 - [BDW] GPU hang when running “Metro:Last Light “ /“Crusader Kings II”
Summary: [BDW] GPU hang when running “Metro:Last Light “ /“Crusader Kings II”
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: All Linux (All)
: high critical
Assignee: Kenneth Graunke
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 77038 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-04-02 09:35 UTC by zhoujian
Modified: 2014-05-28 03:24 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (19.27 KB, text/plain)
2014-04-02 09:38 UTC, zhoujian
Details
output.log (40.70 KB, text/plain)
2014-04-02 09:39 UTC, zhoujian
Details
i915_error_state.log (2.82 MB, text/plain)
2014-04-04 07:56 UTC, zhoujian
Details
dmesg.log (37.15 KB, text/plain)
2014-04-04 07:57 UTC, zhoujian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zhoujian 2014-04-02 09:35:24 UTC
Platform: BDW
Libdrm: (master)libdrm-2.4.52-10-g1cb5fc706cf5913d9dee33c939f65a23ecea17a5
Mesa: (master)db414c468609764c2394b4472900e7878f4ddfaa
Xserver: (master)xorg-server-1.15.99.901-162-g8468e24430988058b150dc1daef3
Xf86_video_intel: (master)2.99.911-24-g5c0623b5f36cd1a1a2e3280ab2bea35
Cairo: (master)bb17403622e9ea474017e0039af8ee48b2b285db
Libva: (staging)708ec2979b52647ce4744d181d964c413e98cc11
Libva_intel_driver:(staging)150f67c67bd92cd201b75a92388fe3a
Kernel:(drm-intel-nightly)git-19f629

Bug detailed description:
----------------------------------------------
Metro:Last Light crash after prompting “PRESS ANY KEY TO CONTINUE” on BDW, It’s only exist on BDW, The problem exist both on gnome-sesssion and Raw X. Please see Xorg.o.log and output log.
It’s not a regression, the game firstly is run on the BDW.

Reproduce steps:
---------------------------------------------
1, xinit
2, start steam
3. run Metro:Last Light 
4, After prompting “PRESS ANY KEY TO CONTINUE”, it crash
Comment 1 zhoujian 2014-04-02 09:38:51 UTC
Created attachment 96771 [details]
Xorg.0.log
Comment 2 zhoujian 2014-04-02 09:39:39 UTC
Created attachment 96772 [details]
output.log
Comment 3 Samuel Iglesias Gonsálvez 2014-04-02 14:25:36 UTC
I don't know if it is related to your issue or not, but according to the output.log file you need to install libgl1-mesa-dri:i386 (or mesa-dri-drivers for i386 on Fedora) as it is failing finding i965_dri.so for 32 bits.

Looking at your comment, it seems that you need to compile the 32 version (it seems you are using dri drivers from git).
Comment 4 zhoujian 2014-04-04 07:49:08 UTC
(In reply to comment #3)
> I don't know if it is related to your issue or not, but according to the
> output.log file you need to install libgl1-mesa-dri:i386 (or
> mesa-dri-drivers for i386 on Fedora) as it is failing finding i965_dri.so
> for 32 bits.
> 
> Looking at your comment, it seems that you need to compile the 32 version
> (it seems you are using dri drivers from git).
it using this library(/opt/X11R7.unstable.2014-03-31/lib32/dri/i965_dri.so)when runing game, however, with output.log used this library (/opt/X11R7/lib/dri/i965_dri.so),so it's "i965_dri.so failed“ nothing to do with this bug.
Comment 5 zhoujian 2014-04-04 07:54:17 UTC
*** Bug 77038 has been marked as a duplicate of this bug. ***
Comment 6 zhoujian 2014-04-04 07:56:34 UTC
Created attachment 96887 [details]
i915_error_state.log
Comment 7 zhoujian 2014-04-04 07:57:13 UTC
Created attachment 96888 [details]
dmesg.log
Comment 8 zhoujian 2014-04-04 08:06:42 UTC
Retest this "Metro:Last Ligh" game,found Gpu hang problem at first,after it crashes, so this issue with same bug77308.
Comment 9 zhoujian 2014-04-11 01:44:26 UTC
Update bug number,this issue with same bug77038.
Comment 10 wendy.wang 2014-04-18 01:31:03 UTC
Hi
Comment 11 wendy.wang 2014-04-18 01:35:44 UTC
Hi Ian,
Would you pls take a look at this bug, thanks!
Comment 12 Kenneth Graunke 2014-04-18 21:30:04 UTC
I was able to reproduce this with MetroLL.  Not sure what to do about it.
Comment 13 Kenneth Graunke 2014-04-29 01:01:58 UTC
I suspect this may be related to bug #75478, but I'd have to do a bunch of analysis to figure that out.  Jordan's been looking into that bug.
Comment 14 Kenneth Graunke 2014-05-08 23:45:34 UTC
I believe the GPU hangs should be fixed with:
http://article.gmane.org/gmane.comp.video.mesa3d.devel/77713

However, Metro seems to be crashing for me, so we'll have to look into it further.
Comment 15 Kenneth Graunke 2014-05-09 21:53:32 UTC
Hangs should be fixed by this commit on Mesa master:

commit 9584959123b0453cf5313722357e3abb9f736aa7
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Thu May 8 16:44:37 2014 -0700

    i965: Fix GPU hangs on Broadwell in shaders with some control flow.
    
    According to the documentation, we need to set the source 0 register
    type to IMM for flow control instructions that have both JIP and UIP.
    
    Fixes GPU hangs in approximately 10 Piglit tests, 5 es3conform tests,
    Unigine Crypt, a WebGL raytracer demo, and several Steam titles.

zhoujian, could you please retest?  Thanks!
Comment 16 zhoujian 2014-05-12 02:06:43 UTC
(In reply to comment #15)
With above the commit(git-9584959),i have reset,the “Serious Sam 3 BFE” game have fixed;but there are two games(“Metro:Last Light “ /“Crusader Kings II”)have still existent GPU hang problem.
Comment 17 jinliangx.wang 2014-05-16 01:30:10 UTC
On Mesa-10.2-rc2 testing, found there is one game -- Crusader Kings II  still has this GPU hang issue on BDW.
Serious Sam 3 BFE & Metro Last Light were played well, no hang issue again.
Comment 18 zhoujian 2014-05-28 03:24:44 UTC
The issue has been fixed in upstream.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.