Bug 773 - i810 lockup with DRI
Summary: i810 lockup with DRI
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i810 (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2004-06-20 17:23 UTC by Daniel Pereda
Modified: 2004-06-23 00:22 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Daniel Pereda 2004-06-20 17:23:11 UTC
i get a X reboot, when i use programs like tuxracer, or screensaver that need 3d
aceleration. locking in the log, i get the folowing..:
space: 65520 wanted 65528
(II) I810(0): [drm] removed 1 reserved context for kernel
(II) I810(0): [drm] unmapping 8192 bytes of SAREA 0x228b0000 at 0xf6f4d000
Fatal server error:

i test tuxracer, freedroid, and quake and always has the same result. I'm using
Fedora 2, with xorg 6.7. and i have a i810 onboard video card. I use these 
configuration with Fedora 1(Redhat9, Madrake 9,...), with great result and great
acceleration, i don't know what is the problem... Something interesting was that
workink in 640x480 resolution the X server not reboot testing tuxracer. but i
has a horrible acceleration..

Daniel Pereda
Comment 1 Adam Jackson 2004-06-23 08:42:13 UTC
have you tried using the DRI drivers from CVS?
Comment 2 Daniel Pereda 2004-06-23 12:03:34 UTC
THANKS! using the last in the CVS i don't have de lockup, but the acceleration
is more poor, i get a good value using glxgear(320 FPS) but when i test with
tuxracer for example i have a slow motion... very slow than Fedora 1 or
others...i don't know why.. but the big problems are solve!  good job DRI
Daniel Pereda
Comment 3 Daniel Pereda 2004-06-23 12:17:49 UTC
hi, doing more test, i saw that tuxracer put these message in console:

[driAllocateTexture:577] unable to allocate texture,

several times during the game... i test quake, and the same happened, maybe this
is the reason from the slowly acceleration. 

any hint are welcome
Daniel Pereda
Comment 4 Dave Airlie 2004-06-23 16:03:04 UTC
Give more Video ram to the card in your XF86Config

Add a line

Videoram 16384 

to the Device section for the i810...

at least or Videoram 32768 is what I use on occasion..

Comment 5 Daniel Pereda 2004-06-23 17:22:13 UTC
hi Dave, thx for reply, adding this line fix my problem and all works
excellent.. and i have a better acceleration than older verions of DRI, EXCELLENT!
Thx for all!!

Daniel Pereda

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.