Bug 77372 - Performance regression on Gen4 Intel GM45 GMA4500MHD
Performance regression on Gen4 Intel GM45 GMA4500MHD
Status: RESOLVED INVALID
Product: DRI
Classification: Unclassified
Component: DRM/Intel
unspecified
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: Paulo Zanoni
Intel GFX Bugs mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-12 19:17 UTC by rimbotede
Modified: 2014-09-17 19:06 UTC (History)
3 users (show)

See Also:


Attachments
system info lspci glxinfo (12.76 KB, text/plain)
2014-04-12 19:17 UTC, rimbotede
no flags Details
system info for another system for comment #10 (2.75 KB, text/plain)
2014-05-30 08:55 UTC, rimbotede
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description rimbotede 2014-04-12 19:17:04 UTC
Created attachment 97263 [details]
system info lspci glxinfo

System info:
Gnome shell 3.10
Thinkpad T500 with dual graphics (BIOS: integrated mode, OS dual-graphics detection disable)
single built-in notebook display, 1680x1050 native
no other displays connected, ever


My system suffers from a serious performance regression since Fedora 18 ~ February 2013. Neither version of xorg, intel driver or gnome shell released since then restored the previous buttery-smooth performance.


Steps to reproduce:
1. Boot into Gnome Shell
2. Open 3-4 Nautilus windows
3. Enter/exit the Activities (overview) few times. (other animations are not smooth but in Activities it's easiest to observe).


Expected result:
Smooth animations.


Actual result:
Clunky animations. Below 15 FPS. Tends to get worse after few Activities in/out. Further worsens after launching any web browser and loading a website. When it worsens it never gets better, even after leaving just two Nautilus windows open. 


What I have already tried:
1. Lowering resolution to 800x600. The performance drop is much less severe.
2. Disabling gpu powersaving https://bugzilla.redhat.com/show_bug.cgi?id=977391#c12 / No change.
3. CLUTTER_PAINT=disable-clipped-redraws:disable-culling / Doesn't restore the previous performance; Makes all animations significantly smoother.
4. MUTTER_DISABLE_MIPMAPS=1 gnome-shell --replace / No change.
5. UXA/SNA/Glamor acceleration methods / No change.
6. Virtually all possible parameter combinations in /etc/X11/xorg.conf.d/20-intel.conf


# pacman -Q | egrep '^mesa|intel|clutter '
clutter 1.16.4-3
intel-dri-git 62265.a22d944-1
lib32-intel-dri 10.1.0-4
mesa-git 62265.a22d944-1
mesa-libgl-git 62265.a22d944-1
xf86-video-intel-dri3-git 7820.6caf295-1


Recently tested on Arch.
Comment 1 rimbotede 2014-04-12 19:20:12 UTC
Video recording showing the behavior. One recorded with my discrete ATI and one with integrated Intel GM45. Please disregard the inherent limitations of such recording and rather focus your attention on the difference, especially when exiting Activities is shown.
https://onedrive.live.com/redir?resid=66CF2646234394FC!2536&authkey=!APhX4WS4a7HN1zE&ithint=folder%2c.mp4
Comment 2 Chris Wilson 2014-04-13 06:23:59 UTC
This suggests that the rendering in gnome-shell changed (or that mesa changed) and is likely hitting a fallback/readback in the animation.
Comment 3 rimbotede 2014-04-13 12:02:43 UTC
(In reply to comment #2)
> This suggests that the rendering in gnome-shell changed (or that mesa
> changed) and is likely hitting a fallback/readback in the animation.
Where does this leave us? Please consider that I am not even an intermediate linux user. I have no idea what and how I could test to disect the problem.
Comment 4 Daniel Vetter 2014-04-14 06:38:29 UTC
First step is to figure out which package introduced the regression. I'd start with downgrading gfx packages (kernel is also relevant for gfx). Which means you first need to figure out again which versions actually worked.

Arch user forums/irc should be able to help you with that.

Note that like Chris said it might be a change in gnome too.

Once we know the offending package we can do more.

Plan B would be to analyze the slowness with profilers, but for that you essentialy need to have some development experience with these tools.
Comment 5 rimbotede 2014-05-07 06:27:57 UTC
I've been told that downgrading to such old package versions (Fedora 18 times) would be extremely troublesome. Especially that many components come into play.

I've requested assistance on Fedora devel mailing list with updated troubleshooting info (pointing at Gnome as the culprit). Updated summary of the regression I posted:

1. Introduced between Fedora 18 and Fedora 19 releases. Clean Fedora 18 showing no performance problems, clean Fedora 19 being affected by the regression.
2. A system install (e.g. Fedora 19) affected by the regression shows no performance problems under KDE. The difference in desktop animation smoothness is striking. No need for telemetry.
3. A Gnome Shell developer (drago01) could not reproduce the bug on his Intel GM45 system.
I've done some F18 vs F19 vs Arch benchmarking / Gnome vs LXDE using Xonotic in windowed mode but the results were nowhere near as conclusive as #2.

Link to the thread:
https://lists.fedoraproject.org/pipermail/devel/2014-May/198981.html
Comment 6 Daniel Vetter 2014-05-15 21:48:17 UTC
Well without more information we can't really do much here unfortunately. Please reopen once you've dug out what caused the regression.
Comment 7 rimbotede 2014-05-27 19:30:20 UTC
No one on fedora mailing lists nor at archlinux forums has answered me so I could at least try some debugging options. Can anyone point me to an article on clutter debugging parameters? I've only found this one https://developer.gnome.org/clutter/1.9/running-clutter.html but it doesn't even mention e.g. 'culling' or 'clipped'.

I've posted on performance-list@gnome.org but it seems it's dead.
Comment 8 Steffen Weber 2014-05-29 15:45:51 UTC
I've been able to workaround the stuttering by enabling the "TearFree" option in /etc/X11/xorg.conf.d/20-intel.conf:

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TearFree"    "true"
EndSection

HP EliteBook 840 G1 with Intel HD Graphics 4400, Linux 3.14.4, X.Org 1.15.1, xf86-video-intel 2.99.911, GNOME 3.10

(This is a new notebook. Therefore I don't know if this problem has been introduced recently.)
Comment 9 rimbotede 2014-05-29 16:54:50 UTC
(In reply to comment #8)
It's only a workaround.

Also, you should definitely report the bug you're experiencing on your hardware. You shouldn't be needing any workarounds.
Comment 10 rimbotede 2014-05-30 08:54:19 UTC
Is providing 'occurs on laptop X, doesn't occur on laptop Y' any helpful? Yesterday I got my hands on a Thinkpad R61 (mine is newer T500). The bug manifested in exactly same way as on my T500.

The R61 display resolution was 1280x800 (mine is 1680x1050). I've attached a more detailed system info for the R61.
Comment 11 rimbotede 2014-05-30 08:55:41 UTC
Created attachment 100151 [details]
system info for another system for comment #10
Comment 12 Steffen Weber 2014-06-10 20:00:32 UTC
I've just upgraded xf86-video-intel from version 2.99.911 to 2.99.912 and the stuttering has improved a lot.
Comment 13 rimbotede 2014-09-17 19:06:13 UTC
Still present with http://download-ib01.fedoraproject.org/pub/alt/stage/21_Alpha_TC7/Workstation/x86_64/iso/
I won't be looking into this anymore as I sold my T500.