Bug 77391 - KWin triggers a crash inside brw_get_graphics_reset_status on i965
Summary: KWin triggers a crash inside brw_get_graphics_reset_status on i965
Status: RESOLVED DUPLICATE of bug 75723
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 10.1
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-13 09:39 UTC by Alexander E. Patrakov
Modified: 2014-04-13 10:26 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander E. Patrakov 2014-04-13 09:39:51 UTC
Graphics hardware:

00:02.0 VGA compatible controller [0300]: Intel Corporation 82G965 Integrated Graphics Controller [8086:29a2] (rev 02)
00:02.1 Display controller [0380]: Intel Corporation 82G965 Integrated Graphics Controller [8086:29a3] (rev 02)

When I enable effects in KWin, it crashes inside Mesa. Here is a traceback:

Application: KWin (kwin), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f12cf978800 (LWP 15170))]

Thread 3 (Thread 0x7f12add8b700 (LWP 15185)):
#0  0x00007f12c9ba27de in pthread_cond_timedwait () from /lib64/libpthread.so.0
#1  0x00007f12c9e2e014 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007f12c9e21795 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#3  0x00007f12c9e2db5f in ?? () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f12c9b9e201 in start_thread () from /lib64/libpthread.so.0
#5  0x00007f12cf1a658d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f12acabe700 (LWP 15186)):
#0  0x00007f12c9ba27de in pthread_cond_timedwait () from /lib64/libpthread.so.0
#1  0x00007f12c9e2e014 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007f12c9e21795 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#3  0x00007f12c9e2db5f in ?? () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f12c9b9e201 in start_thread () from /lib64/libpthread.so.0
#5  0x00007f12cf1a658d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f12cf978800 (LWP 15170)):
[KCrash Handler]
#5  0x00007f12cf0f32a9 in raise () from /lib64/libc.so.6
#6  0x00007f12cf0f46a8 in abort () from /lib64/libc.so.6
#7  0x00007f12cf0ec3c6 in __assert_fail_base () from /lib64/libc.so.6
#8  0x00007f12cf0ec472 in __assert_fail () from /lib64/libc.so.6
#9  0x00007f12a73c1935 in brw_get_graphics_reset_status () from /usr/lib64/dri/i965_dri.so
#10 0x00007f12a7149f70 in _mesa_GetGraphicsResetStatusARB () from /usr/lib64/dri/i965_dri.so
#11 0x00007f12cf53b309 in KWin::SceneOpenGL::paint(QRegion, QList<KWin::Toplevel*>) () from /usr/lib64/libkdeinit4_kwin.so
#12 0x00007f12cf520223 in KWin::Compositor::performCompositing() () from /usr/lib64/libkdeinit4_kwin.so
#13 0x00007f12cf5214e9 in KWin::Compositor::slotCompositingOptionsInitialized() () from /usr/lib64/libkdeinit4_kwin.so
#14 0x00007f12cf4aa865 in KWin::Compositor::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) [clone .part.122] () from /usr/lib64/libkdeinit4_kwin.so
#15 0x00007f12c9f40cb8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/qt4/libQtCore.so.4
#16 0x00007f12c9e1e9b8 in QFutureWatcherBase::event(QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#17 0x00007f12c90b747c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#18 0x00007f12c90bda40 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#19 0x00007f12cddeba6a in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#20 0x00007f12c9f2d14d in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#21 0x00007f12c9f3019f in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/qt4/libQtCore.so.4
#22 0x00007f12c9154109 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#23 0x00007f12c9f2bdaf in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#24 0x00007f12c9f2c0a5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#25 0x00007f12c9f311bb in QCoreApplication::exec() () from /usr/lib64/qt4/libQtCore.so.4
#26 0x00007f12cf4da2c6 in kdemain () from /usr/lib64/libkdeinit4_kwin.so
#27 0x00007f12cf0dfa65 in __libc_start_main () from /lib64/libc.so.6
#28 0x000000000040077e in _start ()

The crash didn't happen in Mesa 9.x.
Comment 1 Alexander E. Patrakov 2014-04-13 10:26:31 UTC
Sorry for the duplicate. https://bugs.freedesktop.org/attachment.cgi?id=96838 helps.

*** This bug has been marked as a duplicate of bug 75723 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.