Bug 77405 - Disappearing characters with big fonts and disabled antialiasing
Summary: Disappearing characters with big fonts and disabled antialiasing
Status: RESOLVED MOVED
Alias: None
Product: cairo
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Chris Wilson
QA Contact: cairo-bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-13 18:54 UTC by Jan Janecek
Modified: 2018-08-25 13:44 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Janecek 2014-04-13 18:54:41 UTC
This bug has been also reported on Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=674532

I found out that the bug was caused by this huge commit:
http://cgit.freedesktop.org/cairo/commit/?id=af9fbd176b145f042408ef5391eef2a51d7531f8

Versions before the commit don't have the bug, every version after the commit has this bug.
Comment 1 Uli Schlachter 2014-04-14 19:40:50 UTC
So the debian bug report says that "gxmessage -fn 'DejaVu Sans Mono 100' 1.2.3.4.5" is supposed to be broken. However, that works for me.

It also says a bit about some stuff in ~/.fonts.conf. Since I don't know much about .fonts.conf, I asked google for some input and came up with the following:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
 <match target="font" >
  <edit mode="assign" name="antialias" >
   <bool>false</bool>
  </edit>
 </match>
</fontconfig>

Still no problem with gxmessage.

What am I doing wrong?

(P.S.: This works for me both with latest git and with debian's 1.12.16-2)
Comment 2 Jan Janecek 2014-04-15 12:55:57 UTC
This is weird. Now I am on my laptop and I can't reproduce the bug either.
I am sure the bug happens on my home PC as I described, however I won't have acces to the PC for next few days.
Looks like the bug is affected by something else (I guess it can be anything from gpu drivers to libpango and gtk2 version). On home PC I use nouveau, on laptop I have radeon. But if I remember correctly, the bug was happening on my laptop too some time ago. I don't remember exact versions of most of the libraries, so you'll have to wait for that information until I'll be back home.

Do you have any ideas what specific libraries could affect this bug?
Comment 3 Jan Janecek 2014-04-18 23:03:03 UTC
Ok, it is indeed releated to graphic drivers. This bug stopped occouring on my home PC (with nouveau) when I disabled 2D acceleration globally in xorg.conf.
On radeon drivers it doesn't seem to happen at all.
Now is this a nouveau bug or a cairo bug?
Comment 4 Jan Janecek 2014-04-28 16:36:56 UTC
Correction: I was using proprietary fglrx drivers on the laptop (where the bug was NOT happening). Now I use opensource radeon drivers (on the same laptop) and the bug IS occuring.

So, the summary is: This bug occurs with nouveau and radeon oupensource drivers (with 2D acceleration enabled). It does not occur with fglrx drivers. I have not tested nvidia proprietary drivers.
Comment 5 GitLab Migration User 2018-08-25 13:44:48 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/cairo/cairo/issues/175.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.