Bug 77408 - libva 1.3.0 makes xine subtitles rendered wrongly
libva 1.3.0 makes xine subtitles rendered wrongly
Status: RESOLVED NOTOURBUG
Product: libva
Classification: Unclassified
Component: intel
unspecified
x86-64 (AMD64) Linux (All)
: medium critical
Assigned To: haihao
Sean V Kelley
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-13 19:41 UTC by Alexandre
Modified: 2014-05-04 18:13 UTC (History)
0 users

See Also:


Attachments
screenshot of a xine window with weird subtitles. (38.12 KB, image/jpeg)
2014-04-21 21:09 UTC, Alexandre
Details
vainfo (828 bytes, text/plain)
2014-05-01 00:13 UTC, Alexandre
Details
Xorg.log (34.59 KB, text/x-log)
2014-05-01 00:13 UTC, Alexandre
Details
a patch for your reference to how to fill the subpicture in xine-lib-vaapi (1.45 KB, patch)
2014-05-04 01:41 UTC, haihao
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre 2014-04-13 19:41:21 UTC
After upgrading libva from 1.2.1 to 1.3.0 xine (w/ libva video driver) started displaying garbage when rendering subtitles.
Comment 1 haihao 2014-04-14 07:31:51 UTC
Maybe libva 1.3.0 exposes a bug in xserver/glx, see the comment #18  at  https://bugs.freedesktop.org/show_bug.cgi?id=76755. Could you try with xserver 1.15.1 or 1.15.99.902 (1.16.0 RC 2)  ?
Comment 2 Alexandre 2014-04-14 14:29:32 UTC
Thanks! It seems like my debian system is a bit outdated and I can't get xorg to compile for some dependency reason. As soon as either debian provides an updated xorg on any branch, or I managed to compile it, I'll come back with results.
Comment 3 Alexandre 2014-04-17 22:26:34 UTC
Tried with 1.15.1; Same behavior.
Comment 4 haihao 2014-04-18 02:26:12 UTC
Do you upgrade the whole graphics stack ?  Does it work for you if downgrading libva from 1.3.0 to 1.2.1 ?
Comment 5 Alexandre 2014-04-21 21:08:32 UTC
If by the whole graphics stack you mean xorg libraries, I didn't upgrade them at that time. I have done it now, but didn't have any change on (mis)behavior.

I'll see if I can get libva 1.2.1 to compile.

Meanwhile, I'm attaching a screenshot of xine so that you can see what happens to subtitles when I use -V vaapi.

I'm falling back to xv rendering on the meanwhile, xine cpu usage rises from avg 17% to 64% respectively when going from vaapi to xv.
Comment 6 Alexandre 2014-04-21 21:09:19 UTC
Created attachment 97707 [details]
screenshot of a xine window with weird subtitles.
Comment 7 zhenxiang.li 2014-04-25 02:42:03 UTC
I retested with the latest libva/intel-driver on manster branch. No reproduce.
Env:
-------------
Libva:          (master)0d60132599318695dd1af8d51d2b160623ac4406
Libva_intel_driver:             (master)0d3462360f624750233d77771d55f48bc00039e5
Xserver:                (server-1.15-branch)xorg-server-1.15.1-1-g7b3aa3f0be8d1334dbf23bd04258a8856a4329c7
Comment 8 zhenxiang.li 2014-04-25 03:07:08 UTC
Besides, the test command line is: 
mplayer -vo vaapi -va vaapi *.mp4 -sub *.srt;
The srt file I use is downloaded from the web.
Comment 9 Alexandre 2014-04-25 17:08:10 UTC
I reported this against xine, not mplayer. The mplayer compilations I have access to lacks support to libva.
Comment 10 haihao 2014-04-28 03:24:58 UTC
We are trying to narrow down the root cause and check whether the issue can be reproduced with other media player. Which platform are you using ?
Comment 11 Alexandre 2014-04-28 03:39:45 UTC
x86_64

On 4/28/14, bugzilla-daemon@freedesktop.org
<bugzilla-daemon@freedesktop.org> wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=77408
>
> --- Comment #10 from haihao <haihao.xiang@intel.com> ---
> We are trying to narrow down the root cause and check whether the issue can
> be
> reproduced with other media player. Which platform are you using ?
>
> --
> You are receiving this mail because:
> You reported the bug.
>
Comment 12 haihao 2014-04-28 04:55:26 UTC
Could you attach your xorg.0.log and the ouput of vainfo ?
Comment 13 Alexandre 2014-05-01 00:13:02 UTC
Created attachment 98269 [details]
vainfo
Comment 14 Alexandre 2014-05-01 00:13:35 UTC
Created attachment 98270 [details]
Xorg.log

as requested, Xorg.log output
Comment 15 haihao 2014-05-04 01:39:26 UTC
The commit f26114aef700d28730f6586a71d9f2526f5083f5 in the driver exposes a bug in xine-lib-vaapi. I will attach a patch for your reference.
Comment 16 haihao 2014-05-04 01:41:34 UTC
Created attachment 98392 [details] [review]
a patch for your reference to how to fill the subpicture in xine-lib-vaapi
Comment 17 Alexandre 2014-05-04 18:13:35 UTC
Tested, works for me. Forwared to xine team at https://bugs.xine-project.org/show_bug.cgi?id=514

Thanks!