Bug 77556 - [SteamOS][HSW GT3e] VT-switch causes “no responsive” on graph interface by 3-6 times
Summary: [SteamOS][HSW GT3e] VT-switch causes “no responsive” on graph interface by 3-...
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Ext/DRI (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium major
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-17 05:12 UTC by meng
Modified: 2018-12-13 18:32 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
demsg.log (124.20 KB, text/plain)
2014-04-17 05:12 UTC, meng
no flags Details
Xorg.0.log (19.94 KB, text/plain)
2014-04-17 05:13 UTC, meng
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description meng 2014-04-17 05:12:14 UTC
System Environment:
--------------------------
Mesa:     (master)ee2bcf38a4c8930d8f9cecfac580030a45c41dae
Xserver:  (master)xorg-server-1.15.99.902-2-g3028ae6c9aa37168e249e0d8
Xf86_video_intel:  (master)2.99.911-58-gf9a279b2dc8417b6504478ac96514125d6136523 Kernel:	(drm-intel-nightly)git-cf8c74 

Bug detailed description:
----------------------------
VT-switch may cause “no responsive” on graph interface by 3-6 times.
“no responsive”is that screen seems to be frozen, mouse and keyboard can’t work. In the meantime, console is OK. Please see dmesg log and Xorg.0.log.

Reproduce steps:
-------------------------
1. start system 
2. VT-switch by 3-6 times
Comment 1 meng 2014-04-17 05:12:42 UTC
Created attachment 97489 [details]
demsg.log
Comment 2 meng 2014-04-17 05:13:56 UTC
Created attachment 97490 [details]
Xorg.0.log
Comment 3 meng 2014-04-17 05:16:03 UTC
The problem exists SteamOS
Comment 4 Kaveh 2014-08-04 18:46:36 UTC
Please confirm that this happens on a production release or update of a major distro (Ubuntu, Fedora, etc) in addition to Steam OS.
Comment 5 Pierre-Loup A. Griffais 2014-08-04 22:48:10 UTC
Hi meng,

Can you try stopping acpid as suggested by Aaron there?

https://github.com/ValveSoftware/SteamOS/issues/147

If that works it's a dupe of a known acpid issue in SteamOS that will be fixed sometime soon.

Thanks!
Comment 6 meng 2014-08-07 04:22:29 UTC
(In reply to comment #4)
> Please confirm that this happens on a production release or update of a
> major distro (Ubuntu, Fedora, etc) in addition to Steam OS.
The SteamOS version is "SteamOS GNU/Linux 1 \n \1" and it is http://repo.steampowered.com/download/.
Comment 7 meng 2014-08-07 04:23:59 UTC
(In reply to comment #5)
> Hi meng,
> 
> Can you try stopping acpid as suggested by Aaron there?
> 
> https://github.com/ValveSoftware/SteamOS/issues/147
> 
> If that works it's a dupe of a known acpid issue in SteamOS that will be
> fixed sometime soon.
> 
> Thanks!

Ater replicated the issue, stopping acpid doesn't fix the issue.
Comment 8 Eero Tamminen 2014-12-29 16:05:34 UTC
Is this still reproducible?

VT switch doesn't really involve Mesa (and neither does input handling), just kernel & X server. -> moving first to X.
Comment 9 GitLab Migration User 2018-12-13 18:32:01 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/xserver/issues/202.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.