Bug 77705 - [SNB/IVB/HSW/BYT/BDW Bisected]Ogles3conform GL3Tests/packed_pixels/packed_pixels_pixelstore.test segfault
Summary: [SNB/IVB/HSW/BYT/BDW Bisected]Ogles3conform GL3Tests/packed_pixels/packed_pix...
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: high major
Assignee: Kenneth Graunke
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-21 02:21 UTC by lu hua
Modified: 2014-05-20 02:03 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lu hua 2014-04-21 02:21:53 UTC
System Environment:
--------------------------
Platform: Ivybridge
Libdrm:		(master)libdrm-2.4.53-6-gd4083dc762a2974c35ecd16be995272bbb6d57b4
Mesa:		(master)ba6dcb3c2b8f516b120f591144bf6c3751f0e3f9
Xserver:	(master)xorg-server-1.15.99.902-20-gc7011249d2abe6cc7af82ee4b79d8f6873444707
Xf86_video_intel:(master)2.99.911-89-g08e71e1820d6fcb6829b4ebd360beadc1f250295
Libva:		(staging)5e10a246287fa2dd3fae2bf756a5b33087cc097c
Libva_intel_driver:(staging)782b8afdda14f000874d8acf51c3e8c490d55773
Kernel:	(drm-intel-nightly)1e771b84e47085ef9b6efea1321e7cb5a8b2c06

Bug detailed description:
-----------------------------
It fails on SNB/IVB/HSW/BYT/BDW platforms with mesa master branch, and works well on 10.1 branch.
Bisect shows:d1b6f6711095cd94e80372e7488aa0189e328d88 is the first bad commit.
commit d1b6f6711095cd94e80372e7488aa0189e328d88
Author:     Chris Forbes <chrisf@ijw.co.nz>
AuthorDate: Wed Apr 16 14:15:27 2014 +1200
Commit:     Chris Forbes <chrisf@ijw.co.nz>
CommitDate: Thu Apr 17 18:11:24 2014 +1200

    meta: Clip src/dest rects in BlitFramebuffer, using the scissor

    Fixes piglit's fbo-blit-stretch test on drivers which use the meta path.
    (i965: should fix Broadwell, but also fixes Sandybridge/Ivybridge/Haswell
    since this test falls off the blorp path now due to format conversion)

    V2: Use scissor instead of just mangling the rects, to avoid texcoord
    rounding problems. (Thanks Marek)

    V3: Rebase on Eric's CTSI meta changes; re-add _mesa_update_state in the
    CTSI path so that _mesa_clip_blit sees the correct bounds.

    Signed-off-by: Chris Forbes <chrisf@ijw.co.nz>
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=77414
    Reviewed-by: Anuj Phogat <anuj.phogat@gmail.com>
    Tested-by: Anuj Phogat <anuj.phogat@gmail.com>

output:
Running GTF (Graphics Test Framework)
egl_vendor: Mesa Project
egl_version: 1.4
ConfigID: 14 RGBA bits( 8, 8, 8, 8) Depth bits: 0 Stencil bits: 0
gtf_version: 3.0
mode: egl
arg: /GFX/Test/Ogles3conform/ogles3conform/GTF_ES/glsl/GTF/GTF -width=64 -height=64 -run=/GFX/Test/Ogles3conform/ogles3conform/GTF_ES/glsl/GTF/GL3Tests/packed_pixels/packed_pixels_pixelstore.test
gl_renderer: Mesa DRI Intel(R) Sandybridge Desktop
gl_shading_language_version: OpenGL ES GLSL ES 3.0
gl_version: OpenGL ES 3.0 Mesa 10.2.0-devel (git-ba6dcb3)
gl_vendor: Intel Open Source Technology Center
gl_extensions: GL_EXT_blend_minmax GL_EXT_multi_draw_arrays GL_EXT_texture_filter_anisotropic GL_EXT_texture_compression_dxt1 GL_EXT_texture_format_BGRA8888 GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth24 GL_OES_element_index_uint GL_OES_fbo_render_mipmap GL_OES_mapbuffer GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_stencil8 GL_OES_texture_3D GL_OES_texture_npot GL_OES_EGL_image GL_OES_depth_texture GL_OES_packed_depth_stencil GL_EXT_texture_type_2_10_10_10_REV GL_OES_get_program_binary GL_APPLE_texture_max_level GL_EXT_discard_framebuffer GL_EXT_read_format_bgra GL_NV_fbo_color_attachments GL_OES_EGL_image_external GL_OES_vertex_array_object GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_EXT_texture_rg GL_EXT_unpack_subimage GL_NV_draw_buffers GL_NV_read_buffer GL_EXT_map_buffer_range GL_OES_depth_texture_cube_map GL_OES_surfaceless_context GL_EXT_color_buffer_float GL_EXT_shader_integer_mix
stamp: 20140421231125
Zero epsilon: 0.000122, RGBA epsilon: ( 0.004044, 0.004044, 0.004044, 0.004044)
packed_pixels: Start
Segmentation fault (core dumped)

Reproduce steps:
---------------------------- 
1. xinit
2. ./GTF -width=64 -height=64 -run=GL3Tests/packed_pixels/packed_pixels_pixelstore.test
Comment 1 lu hua 2014-05-09 01:55:12 UTC
It also fails on Mesa 10.2 branch.
Comment 3 lu hua 2014-05-20 02:02:54 UTC
Fixed by commit 3171da34029337b6665d22b02c9db806b381daf7
commit 3171da34029337b6665d22b02c9db806b381daf7
Author: Kenneth Graunke 
Date: Sun May 11 17:20:08 2014 -0700

i965: Don't _swrast_BlitFramebuffer when doing CopyTexSubImage.

The point of copytexsubimage_using_blit_framebuffer is to use a hardware
accelerated BlitFramebuffer path. If that fails, we shouldn't do a
swrast blit---we should try our CTSI fallback code.

This is especially important for i965 and GLES, where we don't even
create a swrast context.

Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=77705
Signed-off-by: Kenneth Graunke
Comment 4 lu hua 2014-05-20 02:03:09 UTC
Verified.Fixed.


bug/show.html.tmpl processed on Feb 25, 2017 at 20:35:59.
(provided by the Example extension).