Bug 78042 - Bad PDF rendering: invalid font scale
Summary: Bad PDF rendering: invalid font scale
Status: RESOLVED FIXED
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
: 83155 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-04-28 18:22 UTC by Davide Capodaglio
Modified: 2015-10-13 15:13 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
easyjet boarding pass not rendered correctly (222.96 KB, text/plain)
2014-04-28 18:22 UTC, Davide Capodaglio
Details
cairo: don't render text when matrix is not invertable (2.50 KB, patch)
2014-10-07 11:03 UTC, Adrian Johnson
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Davide Capodaglio 2014-04-28 18:22:15 UTC
Created attachment 98133 [details]
easyjet boarding pass not rendered correctly

Hello, the attached PDF (easyjet boarding pass) is not correctly rendered under poppler (evince).
I am using Ubuntu 14.04 amd64, so evince 3.10.3 and poppler 0.24.5.

Evince prints a lot of messages like:
Syntax Warning: font matrix not invertible<0a>

while ghostscript renders the PDF correctly, but prints lots of:
   **** Warning: Invalid 0.0 font scale given for Tf ****
   **** Warning: /BBox has zero width or height, which is not allowed.

so I suspect the PDF is defective, but poppler should be made more "fault tolerant" as ghostscript does.
Otherwise, no boarding pass print anymore :-(

I can fix the PDF with
gs -q -dNOPAUSE -dBATCH -dSAFER -sDEVICE=pdfwrite -sOutputFile=out.pdf in.pdf
Comment 1 Albert Astals Cid 2014-04-28 18:32:26 UTC
Looks good in okular so it must be a cairo backend bug.
Comment 2 Davide Capodaglio 2014-04-28 19:38:55 UTC
(In reply to comment #1)
> Looks good in okular so it must be a cairo backend bug.

Yeah also for me in okular is ok. And no log messages on stdout at all.
Comment 3 Martin McDowell 2014-09-21 11:04:10 UTC
I am seeing the same problem using the Document Viewer 3.10.3 on Ubuntu 14.04 64-bit
Comment 4 Adrian Johnson 2014-10-07 11:03:20 UTC
Created attachment 107478 [details] [review]
cairo: don't render text when matrix is not invertable
Comment 5 Carlos Garcia Campos 2014-10-07 16:04:29 UTC
Comment on attachment 107478 [details] [review]
cairo: don't render text when matrix is not invertable

Review of attachment 107478 [details] [review]:
-----------------------------------------------------------------

LGTM, thanks!
Comment 6 Adrian Johnson 2014-10-07 20:17:20 UTC
Pushed.
Comment 7 Neil Roberts 2014-10-14 15:40:46 UTC
*** Bug 83155 has been marked as a duplicate of this bug. ***
Comment 8 Martin McDowell 2015-10-11 14:51:08 UTC
It has been a year since a last post of this bug but I am still getting this problem in October 2015. I have Ubuntu 14.04. The PDF is viewed in the default Evince document viewer 3.10.3
Comment 9 Adrian Johnson 2015-10-11 21:25:17 UTC
(In reply to Martin McDowell from comment #8)
> It has been a year since a last post of this bug but I am still getting this
> problem in October 2015. I have Ubuntu 14.04. The PDF is viewed in the
> default Evince document viewer 3.10.3

The fix is in poppler 0.28 released in Nov 2014.
Comment 10 Sebastien Bacher 2015-10-13 15:13:30 UTC
I'm doing a SRU to 14.04 for that change


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.