Bug 78368 - GNUInstallDirs build error with cmake < 2.8.5
Summary: GNUInstallDirs build error with cmake < 2.8.5
Alias: None
Product: piglit
Classification: Unclassified
Component: infrastructure (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) All
: medium blocker
Assignee: Eric Anholt
QA Contact: Eric Anholt
Keywords: regression
Depends on:
Reported: 2014-05-07 03:49 UTC by Vinson Lee
Modified: 2014-05-09 20:29 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Description Vinson Lee 2014-05-07 03:49:43 UTC
piglit: d18077aa8a7de01bfd9b1538e12246af7d1954ad (master)

GNUInstallDirs is not available with cmake < 2.8.5.

CMake Error at CMakeLists.txt:5 (INCLUDE):
  include could not find load file:


commit dd1d13182bf61f1036c29ef7b4c244d3dae297a1
Author: Jordan Justen <jordan.l.justen@intel.com>
Date:   Wed Apr 30 09:23:08 2014 -0700

    cmake: Install under separate piglit directory
    Install paths updated:
    * $PREFIX/share/doc => $PREFIX/share/doc/piglit
    * $PREFIX/lib => $PREFIX/lib/piglit/lib
    * $PREFIX/bin => $PREFIX/lib/piglit/bin
    * etc...
    Signed-off-by: Jordan Justen <jordan.l.justen@intel.com>
    Reviewed-by: Dylan Baker <baker.dylan.c@gmail.com>
Comment 1 Dylan Baker 2014-05-07 04:11:27 UTC
I see two options to resolve this:

1. we can bump the version of cmake we require. Debian stable ships 2.8.9[2], so as far as I can tell the only distro that we'd break is EL6 (there are 2.8 versions in external repos, but it looks like they ship 2.6 in their main repository)

2. CMake is 3-clause bsd licensed. We could copy the GNUINstallDirs.cmake into piglit's cmake directory.

I think that we should just bump the version requirement personally. 2.8.5 was released in July 2011[1], 2.8.9 is in Debian stable, At this point supporting older versions doesn't buy us anything, and going to >= 2.8.5 does buy us something. I'm also generally okay with asking piglit users to install updated versions of software, its a developer tool, asking developers to use reasonably up to date versions of other software should be unreasonable.

just my 2 cents.

Comment 2 Dylan Baker 2014-05-07 04:14:07 UTC
(In reply to comment #1)
> asking developers to use reasonably up to date versions of other software
> should be unreasonable.

Sorry, should be: "asking developers to use reasonably up to date versions of other software shouldn't be unreasonable"
Comment 3 Vinson Lee 2014-05-07 04:30:55 UTC
I think bumping the minimum required minimum CMake version to 2.8.5 is reasonable.

I hit this build error on CentOS 6. I tried cmake28 from the EPEL 6 repo and the build passes.
Comment 4 Dylan Baker 2014-05-07 04:40:49 UTC
I have posted a patch to the list to resolve this issue.

Comment 5 Dylan Baker 2014-05-09 20:29:26 UTC
fixed by commit 100368e475a37fb3508603969eb940983e3adbd5

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.