piglit: d18077aa8a7de01bfd9b1538e12246af7d1954ad (master)
GNUInstallDirs is not available with cmake < 2.8.5.
CMake Error at CMakeLists.txt:5 (INCLUDE):
include could not find load file:
Author: Jordan Justen <email@example.com>
Date: Wed Apr 30 09:23:08 2014 -0700
cmake: Install under separate piglit directory
Install paths updated:
* $PREFIX/share/doc => $PREFIX/share/doc/piglit
* $PREFIX/lib => $PREFIX/lib/piglit/lib
* $PREFIX/bin => $PREFIX/lib/piglit/bin
Signed-off-by: Jordan Justen <firstname.lastname@example.org>
Reviewed-by: Dylan Baker <email@example.com>
I see two options to resolve this:
1. we can bump the version of cmake we require. Debian stable ships 2.8.9, so as far as I can tell the only distro that we'd break is EL6 (there are 2.8 versions in external repos, but it looks like they ship 2.6 in their main repository)
2. CMake is 3-clause bsd licensed. We could copy the GNUINstallDirs.cmake into piglit's cmake directory.
I think that we should just bump the version requirement personally. 2.8.5 was released in July 2011, 2.8.9 is in Debian stable, At this point supporting older versions doesn't buy us anything, and going to >= 2.8.5 does buy us something. I'm also generally okay with asking piglit users to install updated versions of software, its a developer tool, asking developers to use reasonably up to date versions of other software should be unreasonable.
just my 2 cents.
(In reply to comment #1)
> asking developers to use reasonably up to date versions of other software
> should be unreasonable.
Sorry, should be: "asking developers to use reasonably up to date versions of other software shouldn't be unreasonable"
I think bumping the minimum required minimum CMake version to 2.8.5 is reasonable.
I hit this build error on CentOS 6. I tried cmake28 from the EPEL 6 repo and the build passes.
I have posted a patch to the list to resolve this issue.
fixed by commit 100368e475a37fb3508603969eb940983e3adbd5