Bug 78483 - GM965 GPU lockup reliably produced by Chrome stable
Summary: GM965 GPU lockup reliably produced by Chrome stable
Status: RESOLVED DUPLICATE of bug 80568
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-09 11:05 UTC by Mark Wilkinson
Modified: 2014-11-14 19:46 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
/sys/class/drm/card0/error (845.23 KB, text/plain)
2014-05-09 11:05 UTC, Mark Wilkinson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Wilkinson 2014-05-09 11:05:21 UTC
Created attachment 98746 [details]
/sys/class/drm/card0/error

I'm getting a reliable GPU lockup triggered by a specific action within Chrome (clicking on the Delicious extension button, which opens a little popover). As with similar reports, the screen goes blank but the machine is still running. I can log in over ssh and shut things down cleanly, or poke around to see what's gone wrong.

I've figured out that I can avoid the issue by running Chrome with the '--disable-gpu-compositing' flag. Without that flag I can reliably reproduce the crash.

Here's the relevant part of the system log:

May  9 11:21:56 sputnik kernel: [   76.820034] [drm] stuck on render ring
May  9 11:21:56 sputnik kernel: [   76.820043] [drm] GPU crash dump saved to /sys/class/drm/card0/error
May  9 11:21:56 sputnik kernel: [   76.820046] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
May  9 11:21:56 sputnik kernel: [   76.820049] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
May  9 11:21:56 sputnik kernel: [   76.820052] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
May  9 11:21:56 sputnik kernel: [   76.820055] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
May  9 11:21:56 sputnik kernel: [   76.820995] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0x4726000 ctx 0) at 0x4726344
May  9 11:21:56 sputnik kernel: [   76.880940] [UFW BLOCK] IN=eth0 OUT= MAC=01:00:5e:00:00:01:00:88:65:42:ed:fa:08:00 SRC=192.168.1.76 DST=224.0.0.1 LEN=44 TOS=0x00 PREC=0x00 TTL=1 ID=33012 PROTO=UDP SPT=63819 DPT=8612 LEN=24 
May  9 11:21:56 sputnik kernel: [   76.900083] [drm] GMBUS [i915 gmbus vga] timed out, falling back to bit banging on pin 2
May  9 11:21:57 sputnik kernel: [   77.332068] [drm:i915_reset] *ERROR* Failed to reset chip.
May  9 11:21:57 sputnik gnome-session[2699]: WARNING: App 'compiz.desktop' exited with code 1
May  9 11:21:57 sputnik gnome-session[2699]: WARNING: App 'compiz.desktop' respawning too quickly
May  9 11:21:57 sputnik gnome-session[2699]: CRITICAL: We failed, but the fail whale is dead. Sorry....
May  9 11:21:57 sputnik kernel: [   78.131431] ------------[ cut here ]------------
May  9 11:21:57 sputnik kernel: [   78.131480] WARNING: CPU: 0 PID: 1388 at /build/buildd/linux-3.13.0/drivers/gpu/drm/i915/intel_display.c:922 assert_pll+0x68/0x70 [i915]()
May  9 11:21:57 sputnik kernel: [   78.131483] PLL state assertion failure (expected on, current off)
May  9 11:21:57 sputnik kernel: [   78.131485] Modules linked in: ctr ccm pci_stub vboxpci(OF) vboxnetadp(OF) vboxnetflt(OF) vboxdrv(OF) snd_hda_codec_analog joydev coretemp kvm_intel kvm ip6t_REJECT snd_hda_intel snd_hda_codec snd_hwdep xt_hl ip6t_rt psmouse serio_raw arc4 nf_conntrack_ipv6 nf_defrag_ipv6 ipt_REJECT pcmcia thinkpad_acpi nvram xt_LOG snd_pcm iwl4965 xt_limit snd_page_alloc xt_tcpudp iwlegacy snd_seq_midi mac80211 btusb xt_addrtype snd_seq_midi_event r852 sm_common nf_conntrack_ipv4 nand nf_defrag_ipv4 nand_ecc snd_rawmidi yenta_socket lpc_ich xt_conntrack nand_bch bch r592 nand_ids pcmcia_rsrc ip6table_filter ip6_tables nf_conntrack_netbios_ns nf_conntrack_broadcast mtd memstick pcmcia_core cfg80211 nf_nat_ftp snd_seq nf_nat nf_conntrack_ftp nf_conntrack iptable_filter rfcomm ip_tables x_tables bnep wmi bluetooth snd_seq_device snd_timer i915 drm_kms_helper snd drm video soundcore i2c_algo_bit mac_hid parport_pc ppdev binfmt_misc lp parport nfsd auth_rpcgss nfs_acl nfs lockd sunrpc fscache hid_logitech_dj usbhid hid firewire_ohci sdhci_pci firewire_core ahci crc_itu_t sdhci libahci e1000e ptp pps_core
May  9 11:21:57 sputnik kernel: [   78.131570] CPU: 0 PID: 1388 Comm: Xorg Tainted: GF          O 3.13.0-24-generic #47-Ubuntu
May  9 11:21:57 sputnik kernel: [   78.131572] Hardware name: LENOVO 6465CTO/6465CTO, BIOS 7LETC9WW (2.29 ) 03/18/2011
May  9 11:21:57 sputnik kernel: [   78.131575]  0000000000000009 ffff8800b57afc68 ffffffff81715ac4 ffff8800b57afcb0
May  9 11:21:57 sputnik kernel: [   78.131579]  ffff8800b57afca0 ffffffff810676bd 0000000000000001 ffff880036244000
May  9 11:21:57 sputnik kernel: [   78.131583]  ffff88003625c000 0000000000000000 0000000000000000 ffff8800b57afd00
May  9 11:21:57 sputnik kernel: [   78.131587] Call Trace:
May  9 11:21:57 sputnik kernel: [   78.131594]  [<ffffffff81715ac4>] dump_stack+0x45/0x56
May  9 11:21:57 sputnik kernel: [   78.131599]  [<ffffffff810676bd>] warn_slowpath_common+0x7d/0xa0
May  9 11:21:57 sputnik kernel: [   78.131602]  [<ffffffff8106772c>] warn_slowpath_fmt+0x4c/0x50
May  9 11:21:57 sputnik kernel: [   78.131624]  [<ffffffffa03227bc>] ? gen4_read32+0x3c/0xb0 [i915]
May  9 11:21:57 sputnik kernel: [   78.131643]  [<ffffffffa02e3c38>] assert_pll+0x68/0x70 [i915]
May  9 11:21:57 sputnik kernel: [   78.131660]  [<ffffffffa02e9a50>] intel_crtc_load_lut+0x1b0/0x1d0 [i915]
May  9 11:21:57 sputnik kernel: [   78.131664]  [<ffffffff8171c302>] ? mutex_lock+0x12/0x2f
May  9 11:21:57 sputnik kernel: [   78.131681]  [<ffffffffa02eaeb3>] intel_crtc_gamma_set+0x63/0x70 [i915]
May  9 11:21:57 sputnik kernel: [   78.131706]  [<ffffffffa0237a52>] drm_mode_gamma_set_ioctl+0x132/0x140 [drm]
May  9 11:21:57 sputnik kernel: [   78.131717]  [<ffffffffa0226c22>] drm_ioctl+0x502/0x630 [drm]
May  9 11:21:57 sputnik kernel: [   78.131724]  [<ffffffff8101b763>] ? native_sched_clock+0x13/0x80
May  9 11:21:57 sputnik kernel: [   78.131728]  [<ffffffff8101b7d9>] ? sched_clock+0x9/0x10
May  9 11:21:57 sputnik kernel: [   78.131732]  [<ffffffff8109d13d>] ? sched_clock_local+0x1d/0x80
May  9 11:21:57 sputnik kernel: [   78.131738]  [<ffffffff811cc6e0>] do_vfs_ioctl+0x2e0/0x4c0
May  9 11:21:57 sputnik kernel: [   78.131741]  [<ffffffff8109dd84>] ? vtime_account_user+0x54/0x60
May  9 11:21:57 sputnik kernel: [   78.131745]  [<ffffffff811cc941>] SyS_ioctl+0x81/0xa0
May  9 11:21:57 sputnik kernel: [   78.131749]  [<ffffffff817266bf>] tracesys+0xe1/0xe6
May  9 11:21:57 sputnik kernel: [   78.131751] ---[ end trace 84d33adbb1453d20 ]---
May  9 11:21:58 sputnik gnome-session[2699]: WARNING: App 'compiz.desktop' respawning too quickly
May  9 11:21:58 sputnik gnome-session[2699]: WARNING: App 'compiz.desktop' exited with code 1
May  9 11:21:58 sputnik gnome-session[2699]: WARNING: App 'compiz.desktop' respawning too quickly

And from Xorg.0.log:

[    77.357] (EE) intel(0): Detected a hung GPU, disabling acceleration.
[    77.357] (EE) intel(0): When reporting this, please include /sys/class/drm/card0/error and the full dmesg.

I have the full log files if they are relevant. The content of /sys/class/drm/card0/error is attached.

This is on an up-to-date Ubuntu 14.04 install with the following packages installed:
linux-image-3.13.0-24-generic - 3.13.0-24.47
xserver-xorg-video-intel - 2:2.99.910-0ubuntu1
libgl1-mesa-dri:amd64 - 10.1.0-4ubuntu5
Comment 1 Matt Turner 2014-11-14 19:46:02 UTC
I should have marked all of the other bugs as a duplicate of this one, since yours appears to be the earliest but I didn't spot it. (Was searching for 'gen4' rather than gm965).

*** This bug has been marked as a duplicate of bug 80568 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.