Bug 78537 - no anisotropic filtering in a native Half-Life 2
no anisotropic filtering in a native Half-Life 2
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi
unspecified
x86-64 (AMD64) Linux (All)
: medium minor
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-10 17:57 UTC by Damian Nowak
Modified: 2014-05-14 14:24 UTC (History)
1 user (show)

See Also:


Attachments
Bring radeonsi anisotropic filtering setup in line with r600g (2.82 KB, patch)
2014-05-13 04:32 UTC, Michel Dänzer
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Damian Nowak 2014-05-10 17:57:35 UTC
Setting the anisotropic filtering in a native Half-Life 2 doesn't have any effect. Only bilinear and trilinear filtering work. Just have a look at the screenshot, it's perfectly visible the texture on the ground lacks some nice filtering. http://upload.nowaker.net/nwkr/1399744500_hl2-aniso.jpg

I'm playing on Radeon 7870 with mesa 10.1.3 (Gallium/Glamor) and Arch Linux (rolling release, always up to date with the upstream).

Please consider this issue a feature request (if there is no anisotropic filtering implemented yet) or a bug (if it is implemented but doesn't work for me).
Comment 1 Michel Dänzer 2014-05-13 04:32:26 UTC
Created attachment 98957 [details] [review]
Bring radeonsi anisotropic filtering setup in line with r600g

Does this patch help?
Comment 2 Grigori Goronzy 2014-05-13 20:12:51 UTC
Anisotropic filtering is also broken for me in other applications, it looks like it's broken with radeonsi overall. Your patch seems to fix it, Michel. I didn't  really verify correctness, but 16x anisotropic doesn't look like a blurry mess anymore. :)
Comment 3 Damian Nowak 2014-05-13 20:15:29 UTC
Hey, I will give it a try. Can you point me to the git repo with the sources I should patch?
Comment 5 Marek Olšák 2014-05-13 22:32:26 UTC
The fix will certainly look like a performance regression when Michael tests radeonsi next time. Be ready for the shocking news on Phoronix. :)
Comment 6 Michel Dänzer 2014-05-14 14:24:33 UTC
Commit: c5828b0599a5c00ebab488b795c63a21f1dc53cd
URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=c5828b0599a5c00ebab488b795c63a21f1dc53cd

Author: Michel Dänzer <michel.daenzer@amd.com>
Date:   Wed May 14 16:30:33 2014 +0900

radeonsi: Fix anisotropic filtering state setup