Bug 78575 - [PNV Bisected]Some Piglit/Ogles1conform/Ogles2conform cases fail
Summary: [PNV Bisected]Some Piglit/Ogles1conform/Ogles2conform cases fail
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium major
Assignee: Kenneth Graunke
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 79039
  Show dependency treegraph
 
Reported: 2014-05-12 05:41 UTC by lu hua
Modified: 2014-08-05 05:32 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lu hua 2014-05-12 05:41:11 UTC
System Environment:
--------------------------
Platform: Pineview
Kernel:	(drm-intel-nightly) 
Libdrm:		(master)libdrm-2.4.54
Mesa:		(master)d9e102b220701c15730329290daa0176751af09a
Xserver:	(master)xorg-server-1.15.99.902-80-ga5b9757142a2ab471ca26651dce9cc5f5e351f3d
Xf86_video_intel:(master)2.99.911-156-gad01e1c8700caeaf0288b72450646d7ebe7cce93
Libva:		(staging)29fa9ec0bd5ac396fb8ce7de07747314ca1dd12e
Libva_intel_driver:(staging)1c4d3468229797e787f4b99b0729baf90a115a1d
Kernel:	(drm-intel-nightly)ed60c2747e0be176f28dc3dadba564949d90d821

Bug detailed description:
---------------------------
Following Piglit/Ogles1conform/Ogles2conform cases fail on Pineview with mesa master and 10.2 branch.

glean_stencil2
glean_vertProg1-ABS_test
glean_vertProg1-ADD_test
glean_vertProg1-ARL_test
glean_vertProg1-Divide_by_zero_test
glean_vertProg1-DP3_test
glean_vertProg1-DP4_test
glean_vertProg1-DPH_test
glean_vertProg1-DST_test
glean_vertProg1-EX2_test
glean_vertProg1-EXP_test
glean_vertProg1-FLR_test
glean_vertProg1-FRC_test
glean_vertProg1-Infinity_and_nan_test
glean_vertProg1-LG2_test
glean_vertProg1-LIT_test_1
glean_vertProg1-LIT_test_2_(degenerate_case:_0_^_0_->_1)
glean_vertProg1-LIT_test_3_(case_x_<_0)
glean_vertProg1-LOG_test
glean_vertProg1-MAD_test
glean_vertProg1-MAX_test
glean_vertProg1-MIN_test
glean_vertProg1-MOV_test_(with_swizzle)
glean_vertProg1-MUL_test_(with_swizzle_and_masking)
glean_vertProg1-Position_write_test_(compute_position_from_texcoord)
glean_vertProg1-POW_test_(exponentiation)
glean_vertProg1-RCP_test_(reciprocal)
glean_vertProg1-RSQ_test_1_(reciprocal_square_root)
glean_vertProg1-RSQ_test_2_(reciprocal_square_root_of_negative_value)
glean_vertProg1-SGE_test
glean_vertProg1-SLT_test
glean_vertProg1-State_reference_test_1_(material_ambient)
glean_vertProg1-State_reference_test_2_(light_products)
glean_vertProg1-State_reference_test_3_(fog_params)
glean_vertProg1-SUB_test_(with_swizzle)
glean_vertProg1-SWZ_test_1
glean_vertProg1-SWZ_test_2
glean_vertProg1-SWZ_test_3
glean_vertProg1-SWZ_test_4
glean_vertProg1-SWZ_test_5
glean_vertProg1-XPD_test_1
glean_vertProg1-XPD_test_2_(same_src_and_dst_arg)
glean_vertProg1-Z-write_test
hiz_hiz-depth-read-fbo-d24-s0
hiz_hiz-depth-read-fbo-d24s8
hiz_hiz-depth-stencil-test-fbo-d0-s8
hiz_hiz-depth-stencil-test-fbo-d24-s0
hiz_hiz-depth-stencil-test-fbo-d24s8
hiz_hiz-depth-test-fbo-d24-s0
hiz_hiz-depth-test-fbo-d24s8
hiz_hiz-stencil-read-fbo-d0-s8
hiz_hiz-stencil-read-fbo-d24s8
hiz_hiz-stencil-read-window-depth0
hiz_hiz-stencil-read-window-depth1
hiz_hiz-stencil-test-fbo-d0-s8
hiz_hiz-stencil-test-fbo-d24s8
hiz_hiz-stencil-test-window-depth0
hiz_hiz-stencil-test-window-depth1
spec_EXT_framebuffer_object_fbo-depth-sample-compare
spec_EXT_packed_depth_stencil_fbo-blit-d24s8

mask.c
mustpass.c
spclear.c
spcorner.c
spfunc.c
spop.c
zbclear.c

GL2ExtensionTests_depth_texture_depth_texture.test
GL2ExtensionTests_packed_depth_stencil_packed_depth_stencil.test
GL2FixedTests_buffer_objects_buffer_objects.test
GL2FixedTests_depth_buffer_clear_depth_buffer_clear.test
GL2FixedTests_depth_buffer_functions_depth_buffer_functions.test
GL2FixedTests_stencil_plane_clear_stencil_plane_clear.test
GL2FixedTests_triangle_rasterization_triangle_rasterization.test
GL2Tests_framebuffer_objects_framebuffer_objects.test

Bisect shows: 9701c6984d8d6570d90a15f86872b16bdba117f2 is the first bad commit.
commit 9701c6984d8d6570d90a15f86872b16bdba117f2
Author:     Kenneth Graunke <kenneth@whitecape.org>
AuthorDate: Fri May 2 01:10:17 2014 -0700
Commit:     Kenneth Graunke <kenneth@whitecape.org>
CommitDate: Tue May 6 11:31:31 2014 -0700

    meta: Only clear the requested color buffers.

    This path is used to implement both glClear and glClearBuffer; the
    latter is only supposed to clear particular buffers.  Core Mesa provides
    us that information in the buffers bitmask; we must only clear buffers
    mentioned there.

    To accomplish this, we save/restore the color draw buffers state, and
    use glDrawBuffers to restrict drawing to the relevant buffers.

    Fixes Piglit's spec/!OpenGL 3.0/clearbuffer-mixed-formats and
    spec/ARB_framebuffer_object/fbo-drawbuffers-none glClearBuffer tests
    for drivers using meta clears (such as Broadwell).

    Cc: "10.2" <mesa-stable@lists.freedesktop.org>
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=77852
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=77856
    Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>
    Reviewed-by: Anuj Phogat <anuj.phogat@gmail.com>
    Reviewed-by: Eric Anholt <eric@anholt.net>

Run  bin/hiz-depth-read-fbo-d24-s0 -auto
output:
Unexpected GL error: GL_INVALID_VALUE 0x501
(Error at /GFX/Test/Piglit/piglit/tests/hiz/hiz-util.c:184)
PIGLIT: {'result': 'fail' }

Reproduce steps:
-------------------------
1. xinit
2. bin/hiz-depth-read-fbo-d24-s0 -auto
Comment 1 lu hua 2014-06-26 06:46:40 UTC
It works well on 10.2.2.
I am not sure it works well on master branch due to bug 79662 causes X fail.
Comment 2 Kaveh 2014-08-05 01:05:46 UTC
Please confirm that this is seen on an SNB or newer platform.
Comment 3 lu hua 2014-08-05 05:31:53 UTC
It has been fixed.
Comment 4 lu hua 2014-08-05 05:32:09 UTC
Fixed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.