Bug 78771 - egl not works on 10.0.x and 10.1.x with black screen
Summary: egl not works on 10.0.x and 10.1.x with black screen
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: EGL/Wayland (show other bugs)
Version: 10.1
Hardware: x86 (IA32) Linux (All)
: highest blocker
Assignee: Wayland bug list
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-16 06:26 UTC by qwang13
Modified: 2014-05-21 02:18 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
it is the blackscreen window. Generally it should be a colorful triangle (8.67 KB, image/png)
2014-05-16 06:26 UTC, qwang13
Details
black window for application (7.64 KB, image/png)
2014-05-16 09:18 UTC, qwang13
Details
weston-1.4.0 mesa-10.1.2 (6.03 KB, text/plain)
2014-05-18 03:34 UTC, qwang13
Details
configure log of mesa building (128.72 KB, text/plain)
2014-05-19 05:21 UTC, qwang13
Details

Note You need to log in before you can comment on or make changes to this bug.
Description qwang13 2014-05-16 06:26:08 UTC
Created attachment 99139 [details]
it is the blackscreen window. Generally it should be a colorful triangle

platform: vtc1010(valleyview) and sandybridge (automotive)

os: tzivi-20140506
compositor: wayland/weston

weston-simple-egl will start with black screen. this application will use egl to create the surface and rendering.

9.2.x works fine. But turns to 10.0.x and 10.1.x, it doesn't work.
Comment 1 qwang13 2014-05-16 09:18:45 UTC
Created attachment 99150 [details]
black window for application

It will show a black window when you run weston-simple-egl or others apps which use egl interface.
Comment 2 qwang13 2014-05-16 09:21:18 UTC
This will block many more apps who use egl/gles2 if they want to use egl interface to rendering. Therefore I set it to the highest.
Comment 3 U. Artie Eoff 2014-05-16 18:11:32 UTC
(In reply to comment #1)
> Created attachment 99150 [details]
> black window for application
> 
> It will show a black window when you run weston-simple-egl or others apps
> which use egl interface.

The attached image doesn't look black to me... nonetheless, I'm running weston-simple-egl on this s/w stack without issue:

wayland (1.4) heads/1.4-0-gbab7f46
drm (master) libdrm-2.4.52-0-g46d451c
mesa (10.1) heads/10.1-0-g13b142a
libva (master) libva-1.2.1-0-g88ed1eb
intel-driver (master) 1.2.2-0-g121e70d
cairo (1.12) heads/1.12-0-g59e2a93
weston (1.4) heads/1.4-0-g07ec588
Comment 4 U. Artie Eoff 2014-05-16 18:38:43 UTC
(In reply to comment #3)
> (In reply to comment #1)
> > Created attachment 99150 [details]
> > black window for application
> > 
> > It will show a black window when you run weston-simple-egl or others apps
> > which use egl interface.
> 
> The attached image doesn't look black to me... nonetheless, I'm running
> weston-simple-egl on this s/w stack without issue:
> 
> wayland (1.4) heads/1.4-0-gbab7f46
> drm (master) libdrm-2.4.52-0-g46d451c
> mesa (10.1) heads/10.1-0-g13b142a
> libva (master) libva-1.2.1-0-g88ed1eb
> intel-driver (master) 1.2.2-0-g121e70d
> cairo (1.12) heads/1.12-0-g59e2a93
> weston (1.4) heads/1.4-0-g07ec588

And configured Mesa like:

--enable-gles2 --disable-gallium-egl --with-egl-platforms=x11,wayland,drm --enable-gbm --enable-shared-glapi --with-dri-drivers=i915,i965,swrast --with-gallium-drivers=swrast --disable-dri3
Comment 5 U. Artie Eoff 2014-05-16 23:13:51 UTC
Can you attach your weston log please.  Does it indicate whether egl loaded and does it list the config details?

I have a sneaking suspicion that your mesa 10.x is trying to load an old (9.2.x) i965_dri.so and fails.
Comment 6 U. Artie Eoff 2014-05-16 23:44:51 UTC
(In reply to comment #5)

> I have a sneaking suspicion that your mesa 10.x is trying to load an old
> (9.2.x) i965_dri.so and fails.

Ok, I might be wrong about that... but upload log anyway.
Comment 7 qwang13 2014-05-18 03:26:49 UTC
no, i965_dri.so is fine to be loaded.

I will upload the weston.log.

./configure --build=i686-tizen-linux-gnu --host=i686-tizen-linux-gnu --program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc      --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com --mandir=/usr/share/man --infodir=/usr/share/in     fo --enable-gles1 --enable-gles2 --with-egl-platforms=drm,wayland --disable-glx --enable-shared-glapi --enable-texture-float --enable-gbm --with-dri-searchpath=/usr/lib/dri --enable-gall     ium-llvm --with-dri-drivers=i915,i965,swrast --with-gallium-drivers=swrast,svga 'CFLAGS=-O2 -g -m32 -march=i686 -mtune=i686 -fmessage-length=0 -D_FORTIFY_SOURCE=2 -fstack-protector -funw     ind-tables -fasynchronous-unwind-tables -DNDEBUG

By the way, this is the configure for mesa.
Comment 8 qwang13 2014-05-18 03:34:12 UTC
Created attachment 99256 [details]
weston-1.4.0 mesa-10.1.2
Comment 9 qwang13 2014-05-19 05:21:21 UTC
Created attachment 99295 [details]
configure log of mesa building

This is the configure log for mesa building.
Comment 10 U. Artie Eoff 2014-05-19 18:54:53 UTC
Works for me...

wayland (1.4) 1.4.0-0-g4b4cd00
  --disable-documentation
  --disable-static
drm (master) libdrm-2.4.52-0-g46d451c
  --enable-static=yes --enable-udev --enable-libkms
  --disable-nouveau-experimental-api --disable-radeon
  --disable-nouveau --enable-exynos-experimental-api
mesa (10.1) mesa-10.1.2-0-gbde3135
  --enable-gles1 --enable-gles2 --with-egl-platforms=drm,wayland
  --disable-glx --enable-shared-glapi --enable-texture-float
  --enable-gbm --enable-gallium-llvm
  --with-dri-drivers=i915,i965,swrast
  --with-gallium-drivers=swrast,svga
cairo (1.12) 1.12.16-0-g8e11a42
  --with-pic --enable-fc --enable-ft --enable-egl --enable-glesv2
  --enable-ps --enable-pdf --enable-script --enable-svg
  --enable-tee --disable-xlib --disable-xcb --disable-gtk-doc
  --disable-static
weston (1.4) 1.4.0-0-g1811312
  --disable-static --disable-setuid-install --enable-simple-clients
  --enable-clients
  --disable-libunwind --disable-xwayland --disable-xwayland-test
  --disable-x11-compositor --disable-rpi-compositor
  --enable-demo-clients-install

...I tested 32-bit on the NDiS-166, yet, I still don't see any issues.  Perhaps your issue is caused by one of the custom IVI patches... which is beyond scope here.
Comment 11 qwang13 2014-05-21 02:18:24 UTC
Thanks U. Artie Eoff's checking.

Currently we found the root cause is miss installing latest libgbm package.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.