Bug 78775 - [BDW regression]white screen when change Half Life 1 resolution
Summary: [BDW regression]white screen when change Half Life 1 resolution
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other Linux (All)
: high major
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 79039
  Show dependency treegraph
 
Reported: 2014-05-16 08:54 UTC by jinliangx.wang
Modified: 2014-12-24 04:55 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jinliangx.wang 2014-05-16 08:54:24 UTC
Platform: BDW
Mesa: mesa-10.2-rc2(git-0b3126b)         
Kernel:drm-intel-fixes_05adaf_20140511       
Xf86_video_intel:     (master)2.99.911-156-gad01e1c8700caeaf0288b72450646d7ebe7cce93   
Libdrm:    (master)libdrm-2.4.54    
Xserver:   (server-1.15-branch)xorg-server-1.15.1-1-g7b3aa3f0be8d1334dbf23bd04258a8856a4329c7    
Cairo:       (master)55608e4fd6947f26789557ffc757affc509b141b
Libva:        (master)0337703ffedc8562299c2d65acfae76c380043c6      
Libva_intel_driver:  (master)b48ba793b83096be87cc4a1258be80737f26fb3b


Bug detailed description:
---------------------------------------
White screen when change Half Life 1 resolution on BDW.
Play Steam--Half Life 1, after change resolution to highest, the whole screen change to white, and would not response any controls both from keyboard and mouse.
Even press ctrl + c, it still cannot back to desktop.

It's a regression issue.
Comment 1 Kristian Høgsberg 2014-05-21 17:20:18 UTC
Is this specific to BDW?  Did we bisect down to the commit that causes the regression?
Comment 2 jinliangx.wang 2014-05-22 00:37:26 UTC
Yes, it's specific to BDW.
The bisect is ongoing.
Comment 3 Eero Tamminen 2014-10-23 15:55:04 UTC
This sounds potentially like Intel X driver bug, not necessarily Mesa one.

(In reply to jinliangx.wang from comment #0)
> White screen when change Half Life 1 resolution on BDW.
> Play Steam--Half Life 1, after change resolution to highest, the whole
> screen change to white, and would not response any controls both from
> keyboard and mouse.
> Even press ctrl + c, it still cannot back to desktop.

Does the same happen both in windowed and fullscreen mode?

If the whole screen is white, did you verify that the game is still running e.g. with "ps ax" from ssh console?

If it's still running, and you kill it from e.g. ssh console (kill -9 <PID>), does that help?

Does dmesg contain any GPU specific warnings/errors?
Comment 4 jinliangx.wang 2014-10-28 03:54:03 UTC
With Steam auto updated, it can't connect to the steam server because currently in our lab, there's no external net can be connected directly.
So I didn't run the case again.

But some infomation I remeber is: 
When bug happen, the Half life game is still running.
If kill it in process list through ssh console, white screen will be keep, can't back to mormal desktop.

Sorry for I can't provide dmesg current.
Comment 5 Eero Tamminen 2014-10-28 14:21:16 UTC
Rest of the information is still needed (dmesg).  Also information about whether after killing the program, GPU reset helps:
  echo 1 > /sys/kernel/debug/dri/0/i915_wedged


> It's a regression issue.

When this worked on BDW?
Comment 6 jinliangx.wang 2014-10-29 03:32:47 UTC
We are requesting the use right of external net to IT department.
We should do the case until they approve.
Comment 7 Eero Tamminen 2014-10-29 11:14:34 UTC
Please don't change the status from NEEDINFO to something else until you actually have the needed info!


(In reply to jinliangx.wang from comment #6)
> We are requesting the use right of external net to IT department.

You don't need external network connection for this game.

You can run Steam in offline mode (it asks you on startup whether you want to start in offline mode when network isn't available), and HL1 works fine in offline mode.
Comment 8 jinliangx.wang 2014-10-30 01:12:28 UTC
With Steam has some updated, we need enter username and password to re-login, this time it should connent steam server and need external net.
Comment 9 jinliangx.wang 2014-10-30 01:15:01 UTC
If username and password has not been remembered by steam client, we can't start it offline.
Comment 10 Gordon Jin 2014-11-26 02:15:21 UTC
While it's not convenient for QA to run it, could any developer try reproducing it?
Comment 11 fangxun 2014-12-24 04:55:02 UTC
The issue disappears on mesa-10.4.0.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.