Bug 78788 - [Radeon\VCE] Performance regression after using VCE
Summary: [Radeon\VCE] Performance regression after using VCE
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-16 16:50 UTC by Iaroslav Andrusyak
Modified: 2014-10-04 13:41 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg (61.81 KB, text/plain)
2014-05-17 05:23 UTC, Iaroslav Andrusyak
no flags Details
Xorg.0.log (38.24 KB, text/plain)
2014-05-17 05:24 UTC, Iaroslav Andrusyak
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Iaroslav Andrusyak 2014-05-16 16:50:28 UTC
Linux drm-next 3.15rc3
Radeon hd 7790

After using VCE video encoding, 3d performance slow down up to 3-4 times

I made short video with this problem
http://www.youtube.com/watch?v=YfPXHTHzO6s

dmesg after vce

[  415.097591] switching from power state:
[  415.097595]  ui class: performance
[  415.097596]  internal class: none
[  415.097598]  caps: 
[  415.097611]  uvd    vclk: 0 dclk: 0
[  415.097612]          power level 0    sclk: 30000 mclk: 15000 pcie gen: 3 pcie lanes: 16
[  415.097613]          power level 1    sclk: 105000 mclk: 150000 pcie gen: 3 pcie lanes: 16
[  415.097614]  status: c r 
[  415.097615] switching to power state:
[  415.097615]  ui class: performance
[  415.097616]  internal class: none
[  415.097617]  caps: 
[  415.097618]  uvd    vclk: 0 dclk: 0
[  415.097618]          power level 0    sclk: 30000 mclk: 15000 pcie gen: 3 pcie lanes: 16
[  415.097619]          power level 1    sclk: 105000 mclk: 150000 pcie gen: 3 pcie lanes: 16
[  415.097620]  status: c r 
[  441.772194] switching from power state:
[  441.772198]  ui class: performance
[  441.772199]  internal class: none
[  441.772200]  caps: 
[  441.772201]  uvd    vclk: 0 dclk: 0
[  441.772202]          power level 0    sclk: 30000 mclk: 15000 pcie gen: 3 pcie lanes: 16
[  441.772203]          power level 1    sclk: 105000 mclk: 150000 pcie gen: 3 pcie lanes: 16
[  441.772204]  status: c r 
[  441.772205] switching to power state:
[  441.772205]  ui class: performance
[  441.772206]  internal class: none
[  441.772207]  caps: 
[  441.772207]  uvd    vclk: 0 dclk: 0
[  441.772208]          power level 0    sclk: 30000 mclk: 15000 pcie gen: 3 pcie lanes: 16
[  441.772209]          power level 1    sclk: 105000 mclk: 150000 pcie gen: 3 pcie lanes: 16
[  441.772210]  status: c r
Comment 1 Alex Deucher 2014-05-16 22:14:34 UTC
Please attach your xorg log and dmesg output.
Comment 2 Iaroslav Andrusyak 2014-05-17 05:23:34 UTC
Created attachment 99200 [details]
dmesg
Comment 3 Iaroslav Andrusyak 2014-05-17 05:24:14 UTC
Created attachment 99201 [details]
Xorg.0.log
Comment 4 Iaroslav Andrusyak 2014-07-26 14:24:43 UTC
Mesa-git  git-54a84d9
http://cgit.freedesktop.org/~agd5f/linux/log/?h=drm-next-3.17-wip
New firmware

Same problem, slow 3d after using VCE
Comment 5 Iaroslav Andrusyak 2014-10-04 13:41:39 UTC
with kernel 3.17.0-rc7 all works fine.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.