Bug 7880 - The newest mesa does not work with compiz on Xgl
Summary: The newest mesa does not work with compiz on Xgl
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/R100 (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: high critical
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-14 23:18 UTC by Ruijiang Li
Modified: 2010-12-02 06:36 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ruijiang Li 2006-08-14 23:18:51 UTC
I am using IBM T42 with graphic card Mobility Radeon 7500 32M

I checked out Mesa code from cvs on 13 june,2006, then "make linux-dri && make
install". the library worked with compiz 0.0.12 correctly.

Yesterday, I checked out Mesa code from cvs again, but this time, the screen is
not drawn correctly: It seems that the window is not redrawn in time, and
sometimes, some rectangle is filled with one color. Some plugins of compiz also
worked too slow such as minimize a window.(This time I also upgrade compiz to
0.0.13).

So I switched to mesa cvs 20060613, and compiz works. There are still
someproblem:some area does not refresh immediately occasionally, but it turns
right after another operation.
Comment 1 Michel Dänzer 2006-08-14 23:40:08 UTC
Please try and isolate the commit that caused this.
Comment 2 Benjamin Close 2008-01-11 02:36:43 UTC
Bugzilla Upgrade Mass Bug Change

NEEDSINFO state was removed in Bugzilla 3.x, reopening any bugs previously listed as NEEDSINFO.

  - benjsc
    fd.o Wrangler
Comment 3 Adam Jackson 2009-08-24 12:24:07 UTC
Mass version move, cvs -> git
Comment 4 Matt Turner 2010-12-02 06:36:37 UTC
Closing after 4 years of inactivity. Reopen if this is not fixed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.