Bug 79325 - Mesa 10.2.0rc4 crashes Xorg when launching Steam
Summary: Mesa 10.2.0rc4 crashes Xorg when launching Steam
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Acceleration/glamor (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Zhigang Gong
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-27 17:24 UTC by Marti Raudsepp
Modified: 2014-06-06 22:56 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marti Raudsepp 2014-05-27 17:24:34 UTC
I'm using Arch Linux testing repositories, which recently updated to mesa 10.2.0rc4. After this update, launching the native Linux version of Steam causes Xorg to crash.

When I downgrade mesa and related packages to 10.1.3, this issue does not occur.

ati-dri 10.2.0rc4
mesa 10.2.0rc4
xorg-server 1.15.1
kernel 3.14.4
xf86-video-ati 7.3.0

May 27 20:14:29 newn steam.desktop[19800]: Running Steam on arch  64-bit
May 27 20:14:29 newn steam.desktop[19800]: STEAM_RUNTIME is enabled automatically
May 27 20:14:29 newn steam.desktop[19800]: Installing breakpad exception handler for appid(steam)/version(1400690891_client)
May 27 20:14:29 newn steam.desktop[19800]: libGL error: dlopen /usr/lib32/xorg/modules/dri/radeonsi_dri.so failed (/home/marti/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1: version `GCC_4.7.0' not found (required by /usr/lib32/xorg/modules/dri/radeonsi_dri.so))
May 27 20:14:29 newn steam.desktop[19800]: libGL error: unable to load driver: radeonsi_dri.so
May 27 20:14:29 newn steam.desktop[19800]: libGL error: driver pointer missing
May 27 20:14:29 newn steam.desktop[19800]: libGL error: failed to load driver: radeonsi
May 27 20:14:29 newn steam.desktop[19800]: libGL error: dlopen /usr/lib32/xorg/modules/dri/swrast_dri.so failed (/home/marti/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1: version `GCC_4.7.0' not found (required by /usr/lib32/xorg/modules/dri/swrast_dri.so))
May 27 20:14:29 newn steam.desktop[19800]: libGL error: unable to load driver: swrast_dri.so
May 27 20:14:29 newn steam.desktop[19800]: libGL error: failed to load driver: swrast
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE)
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) Backtrace:
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 0: /usr/bin/Xorg (xorg_backtrace+0x48) [0x584b08]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 1: /usr/bin/Xorg (0x400000+0x1887f9) [0x5887f9]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 2: /usr/lib/libpthread.so.0 (0x7f4789308000+0xf4b0) [0x7f47893174b0]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 3: /usr/lib/xorg/modules/dri/radeonsi_dri.so (0x7f4781809000+0x67218) [0x7f4781870218]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 4: /usr/lib/xorg/modules/dri/radeonsi_dri.so (0x7f4781809000+0x65fb2) [0x7f478186efb2]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 5: /usr/lib/xorg/modules/dri/radeonsi_dri.so (0x7f4781809000+0x1c0ced) [0x7f47819c9ced]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 6: /usr/lib/xorg/modules/dri/radeonsi_dri.so (0x7f4781809000+0x19ecb6) [0x7f47819a7cb6]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 7: /usr/lib/xorg/modules/dri/radeonsi_dri.so (0x7f4781809000+0x13ce33) [0x7f4781945e33]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 8: /usr/lib/xorg/modules/libglamoregl.so (0x7f478623b000+0x1a08) [0x7f478623ca08]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 9: /usr/lib/xorg/modules/libglamoregl.so (glamor_egl_create_argb8888_based_texture+0x83) [0x7f478623ccf3]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 10: /usr/lib/libglamor.so.0 (0x7f4785bd1000+0x26bdc) [0x7f4785bf7bdc]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 11: /usr/lib/libglamor.so.0 (0x7f4785bd1000+0x27386) [0x7f4785bf8386]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 12: /usr/lib/libglamor.so.0 (glamor_create_pixmap+0x298) [0x7f4785bd57b8]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 13: /usr/lib/xorg/modules/drivers/radeon_drv.so (0x7f4782aa5000+0x4bce3) [0x7f4782af0ce3]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 14: /usr/bin/Xorg (0x400000+0x31be7) [0x431be7]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 15: /usr/bin/Xorg (0x400000+0x35c8e) [0x435c8e]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 16: /usr/bin/Xorg (0x400000+0x39aaa) [0x439aaa]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 17: /usr/lib/libc.so.6 (__libc_start_main+0xf0) [0x7f4787f75000]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) 18: /usr/bin/Xorg (0x400000+0x2507e) [0x42507e]
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE)
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) Segmentation fault at address 0x10
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE)
May 27 20:14:30 newn gdm-Xorg-:0[19097]: Fatal server error:
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) Caught signal 11 (Segmentation fault). Server aborting
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE)
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE)
May 27 20:14:30 newn gdm-Xorg-:0[19097]: Please consult the The X.Org Foundation support
May 27 20:14:30 newn gdm-Xorg-:0[19097]: at http://wiki.x.org
May 27 20:14:30 newn gdm-Xorg-:0[19097]: for help.
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) Please also check the log file at "/dev/null" for additional information.
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE)
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (II) AIGLX: Suspending AIGLX clients for VT switch
May 27 20:14:30 newn gdm-Xorg-:0[19097]: (EE) Server terminated with error (1). Closing log file.
May 27 20:14:30 newn systemd-coredump[19896]: Process 19097 (Xorg) dumped core.
Comment 1 Marti Raudsepp 2014-05-27 17:53:24 UTC
Note that similar dlopen and "unable to load driver" errors also occur with old mesa 10.1.3, so I don't think that's the direct cause of the crash.

Here's Steam output with 10.1.3:

libGL error: dlopen /usr/lib32/xorg/modules/dri/radeonsi_dri.so failed (/home/marti/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib32/libLLVM-3.4.so))
libGL error: unable to load driver: radeonsi_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: radeonsi
libGL error: dlopen /usr/lib32/xorg/modules/dri/swrast_dri.so failed (/home/marti/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib32/libLLVM-3.4.so))
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

After running for a while with old mesa, I ran into the same symptoms described here: https://bugs.freedesktop.org/show_bug.cgi?id=74420
Comment 2 Laurent carlier 2014-05-27 21:11:07 UTC

*** This bug has been marked as a duplicate of bug 78604 ***
Comment 3 Michel Dänzer 2014-05-29 07:19:56 UTC
Actually, this doesn't look like the same crash as bug 78604.

This glamor crash should be fixed in http://cgit.freedesktop.org/xorg/driver/glamor/commit/?id=cccfea4454949e3e376be42bb230603848997195 .

You may still run into bug 78604 though, and Steam games will probably only be playable if you sort out the Steam runtime issues anyway.
Comment 4 Marti Raudsepp 2014-06-06 22:56:51 UTC
(In reply to comment #3)
> This glamor crash should be fixed in
> http://cgit.freedesktop.org/xorg/driver/glamor/commit/?id=cccfea4454949e3e376be42bb230603848997195

Fix confirmed, after rebuilding glamor-egl with the linked patch, Steam starts successfully.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.