Bug 79386 - [IVB regression] Intermittent flickering on KMS, constant flickering on X11
Summary: [IVB regression] Intermittent flickering on KMS, constant flickering on X11
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg 6.7.0
Hardware: x86-64 (AMD64) Linux (All)
: highest major
Assignee: Jani Nikula
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
: 81647 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-28 19:28 UTC by Narthana Epa
Modified: 2017-07-24 22:54 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
flickering (1.17 MB, video/mp4)
2014-05-28 19:50 UTC, Narthana Epa
no flags Details
intel_reg_dumper output: 3600836585e3fdef0a1410d63fe5ce4015007aac (17.46 KB, text/plain)
2014-05-28 19:53 UTC, Narthana Epa
no flags Details
intel_reg_dumper output: 4e53c2e010e531b4a014692199e978482d471c7e (17.46 KB, text/plain)
2014-05-28 19:54 UTC, Narthana Epa
no flags Details
dmesg output: 3600836585e3fdef0a1410d63fe5ce4015007aac (78.23 KB, text/plain)
2014-06-02 15:28 UTC, Narthana Epa
no flags Details
Patch to fix the flickering (1.15 KB, text/plain)
2014-10-25 18:35 UTC, Narthana Epa
no flags Details
Arch linux PKGBUILD that builds a fixed kernel (11.96 KB, text/plain)
2014-10-25 18:36 UTC, Narthana Epa
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Narthana Epa 2014-05-28 19:28:27 UTC
The laptop's display will flicker intermittently when booted with KMS enabled. It will flicker constantly in X11 (see the attached videos). The hardware is an Acer Aspire TimelineU M5-581TG-6666, with a Intel Core i5 3317U. It also has a nVidia 640M, but this happens whether bumblebee is enabled or not.

It is possible that this issue is the same as Bug 78161 because it appears to have been caused by the same commit: http://cgit.freedesktop.org/drm-intel/commit/?h=drm-intel-next&id=3600836585e3fdef0a1410d63fe5ce4015007aac whereas http://cgit.freedesktop.org/drm-intel/commit/?h=drm-intel-next&id=4e53c2e010e531b4a014692199e978482d471c7e is good.

However, the video of the flickering looks different and it is claimed that the lastest nightlies fix Bug 78162, but this is not the case with this issue.
Comment 1 Narthana Epa 2014-05-28 19:50:39 UTC
Created attachment 100045 [details]
flickering
Comment 2 Narthana Epa 2014-05-28 19:53:52 UTC
Created attachment 100046 [details]
intel_reg_dumper output: 3600836585e3fdef0a1410d63fe5ce4015007aac
Comment 3 Narthana Epa 2014-05-28 19:54:50 UTC
Created attachment 100047 [details]
intel_reg_dumper output: 4e53c2e010e531b4a014692199e978482d471c7e
Comment 4 Paulo Zanoni 2014-06-02 13:26:03 UTC
Hi

Can you please boot your machine with "drm.debug=0xe" Kernel parameter, reproduce the bug, then attach the output of the  "dmesg" command here?

Thanks,
Paulo
Comment 5 Narthana Epa 2014-06-02 15:28:44 UTC
Created attachment 100318 [details]
dmesg output: 3600836585e3fdef0a1410d63fe5ce4015007aac
Comment 6 Thomas 2014-06-28 00:21:26 UTC
i have this too.
did some youtube: https://www.youtube.com/watch?v=PLEw_pkaLks

what can i do to help with that (i am not that pro but i will try it).
things i have tried so fare:
works well with any kernel 3.8
problems starts with kernel 3.9
also latest 3.15 have this problem.
i also have asus timeline U M5 Laptop.
Comment 7 Chris Wilson 2014-07-19 10:39:41 UTC
I guess it is a WM issue. Double check that Ville hasn't already fixed it in drm-intel-nightly and if it is still broken, please bisect where the breakage was introduced between 3.8 and 3.9.
Comment 8 Narthana Epa 2014-07-20 19:29:00 UTC
I do not think its is purely a WM (I am assuming this means window manager) issue. As I have mentioned before, the flicker occurs whether X is started or not. It is true that there is dramatically less flickering when X is not started, but on kernels that work, there is no flickering in either case. This leads me to believe that if the flickering without a WM is eliminated, then the flickering with one will be as well, though obviously this it not certain.

As for bisection, I find that the problem occurs between 3.9 and 3.10 and not 3.8 and 3.9 as Thomas claims. I bisected it to be introduced by commit 3600836585e3fdef0a1410d63fe5ce4015007aac.
Comment 9 Thomas 2014-08-08 14:14:08 UTC
yes thats what you wrote in your first post.
is this so difficult to fix?
I realy think this is a show stopper! I cant use new kernels at all.
Comment 10 Chris Wilson 2014-08-08 14:19:24 UTC
(In reply to comment #8)
> I do not think its is purely a WM (I am assuming this means window manager)
> issue.

WM == watermarks on the display fifo. If we set those incorrectly, the display is liable to flicker or show other corruption and possibly hang the machine.
Comment 11 Thomas 2014-08-21 21:44:37 UTC
so what can we do to get this bug resolved?
how can i check it is a watermarks bug?
Comment 12 Thomas 2014-08-22 09:28:03 UTC
(In reply to comment #11)
> so what can we do to get this bug resolved?
> how can i check it is a watermarks bug?

checked with http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-nightly/current/linux-image-3.17.0-994-generic_3.17.0-994.201408200253_amd64.deb
Comment 13 Thomas 2014-08-22 09:29:35 UTC
(In reply to comment #8)
> I do not think its is purely a WM (I am assuming this means window manager)
> issue. As I have mentioned before, the flicker occurs whether X is started
> or not. It is true that there is dramatically less flickering when X is not
> started, but on kernels that work, there is no flickering in either case.
> This leads me to believe that if the flickering without a WM is eliminated,
> then the flickering with one will be as well, though obviously this it not
> certain.
> 
> As for bisection, I find that the problem occurs between 3.9 and 3.10 and
> not 3.8 and 3.9 as Thomas claims. I bisected it to be introduced by commit
> 3600836585e3fdef0a1410d63fe5ce4015007aac.

well i cant use Kernel 3.9! it is only working for me with Kernel 3.8
Comment 14 Jani Nikula 2014-09-02 12:35:01 UTC
Please try current upstream or drm-intel-nightly branch of [1] first. We're pretty far from 3.8 or 3.10 by now.

If that doesn't help, well, just a hunch, please try the patch from [2] on top.

[1] http://cgit.freedesktop.org/drm-intel

[2] https://bugs.freedesktop.org/show_bug.cgi?id=81647#c5
Comment 15 Narthana Epa 2014-09-02 16:19:17 UTC
(In reply to comment #14)
> Please try current upstream or drm-intel-nightly branch of [1] first. We're
> pretty far from 3.8 or 3.10 by now.
> 
> If that doesn't help, well, just a hunch, please try the patch from [2] on
> top.
> 
> [1] http://cgit.freedesktop.org/drm-intel
> 
> [2] https://bugs.freedesktop.org/show_bug.cgi?id=81647#c5

The patch in [2] works. Thank you very much!
Comment 16 Jani Nikula 2014-09-15 10:04:16 UTC
commit 39fde1cdcc5df26bd65a2b9b765ae5b741ca6d13
Author: Jani Nikula <jani.nikula@intel.com>
Date:   Tue Sep 9 11:25:13 2014 +0300

    drm/i915/edp: use lane count and link rate from DPCD for eDP
Comment 17 Gordon Jin 2014-10-10 04:36:41 UTC
*** Bug 81647 has been marked as a duplicate of this bug. ***
Comment 18 Thomas 2014-10-25 09:50:06 UTC
How can i Test if this works for me too with ubuntu 14.04 (or 14.10)?
Comment 19 Narthana Epa 2014-10-25 18:35:08 UTC
Created attachment 108410 [details]
Patch to fix the flickering
Comment 20 Narthana Epa 2014-10-25 18:36:22 UTC
Created attachment 108411 [details]
Arch linux PKGBUILD that builds a fixed kernel
Comment 21 Narthana Epa 2014-10-25 18:42:33 UTC
(In reply to Thomas from comment #18)
> How can i Test if this works for me too with ubuntu 14.04 (or 14.10)?

You need to compile a custom kernel for ubuntu. I'm not really sure how to do that but you can probably do a google search. You need to apply the attached patch before you compile. There are probably some patches that ubuntu applies to the kernel as well, so its probably best to apply this patch before all of them in the script that builds the kernel.dpkg. You can refer to my modified archlinux pkgbuild for some guidance on how to apply the patch.

I've tested the patch against the official archlinux 3.17 kernel and it patches successfully, but its possible that the ubuntu patches may conflict with this patch. In that case, it's will be very difficult for someone without knowledge of C programming and the structure of this part of the kernel's code to resolve the issue. If memory serves me correctly, ubuntu also provide a vanilla kernel with minimal patches, so it may be better to try modify the build script for that.

Failing that you can post a bug against the ubuntu kernel package and ask them to include this patch in their release.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.