Bug 79711 - Crash bug still exists in glx libs, 2 years after I sent you a patch to fix it.
Summary: Crash bug still exists in glx libs, 2 years after I sent you a patch to fix it.
Status: RESOLVED DUPLICATE of bug 54372
Alias: None
Product: Mesa
Classification: Unclassified
Component: GLX (show other bugs)
Version: 10.1
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-06 04:12 UTC by danmanj
Modified: 2014-06-08 16:15 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description danmanj 2014-06-06 04:12:18 UTC
Observe the saga of 
https://bugs.freedesktop.org/show_bug.cgi?id=54372

Mesa libglx has a NULL pointer dereference bug, discovered by app developer.

App developer debugs into libglx, understands problem, prepares patch.

App developer sends patch to fix NULL pointer dereference to debian x-strike-force, and freedesktop.org.

Nobody at debian or freedsektop.org ever fixes libglx, nobody ever even responds to the patch.

App developer pings every 3 months for year, before giving up.

A year after giving up App developer tries latest mesa glx, finds the same TWO YEAR OLD bug still exists.

Seriously? WTF? How many years until you apply the patch?
Comment 1 danmanj 2014-06-08 16:15:28 UTC

*** This bug has been marked as a duplicate of bug 54372 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.