Bug 7983 - bugs in symbols/inet for cymotionlinux keyboard
Summary: bugs in symbols/inet for cymotionlinux keyboard
Status: RESOLVED FIXED
Alias: None
Product: xkeyboard-config
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: xkb
QA Contact: xkb
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-24 07:39 UTC by Andreas Sahlbach
Modified: 2007-09-24 05:06 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sahlbach 2006-08-24 07:39:18 UTC
There are several wrong keys defined in the current definition for the
cymotionlinux in xorg/xc/programs/xkbcomp/symbols/inet. I am using currently the
following definition instead and can confirm, that every key with this
definition is working. I am not sure about the correctness of the symbols of the
keys, but they make sense for me this way. With the original definition a number
of keys (Redo and Paste at least) were not working. I am using a cherry cymotion
master linux with US keyboard layout
(http://www.cherrycorp.com/english/cymotion-line/cymotion-line_master_linux.htm)

partial alphanumeric_keys
xkb_symbols "cymotionlinux" {
    name[Group1]= "Cherry CyMotion Master Linux";

    key <FK17>  {       [ XF86Search            ]       };
    key <XFER>  {       [ XF86AudioMedia        ]       };
    key <I02>   {       [ XF86HomePage          ]       };
    key <I05>   {       [ Redo                  ]       };
    key <I07>   {       [ Undo                  ]       };
    key <I10>   {       [ XF86AudioPrev         ]       };
    key <I17>   {       [ XF86Launch1           ]       };
    key <I19>   {       [ XF86AudioNext         ]       };
    key <I1F>   {       [ XF86Launch0           ]       };
    key <I20>   {       [ XF86AudioMute         ]       };
    key <I21>   {       [ XF86Calculator        ]       };
    key <I22>   {       [ XF86AudioPlay, XF86AudioPause ] };
    key <I24>   {       [ XF86AudioStop         ]       };
    key <I28>   {       [ Multi_key             ]       };
    key <I2B>   {       [ XF86Launch2           ]       };
    key <I2E>   {       [ XF86AudioLowerVolume  ]       };
    key <I30>   {       [ XF86AudioRaiseVolume  ]       };
    key <I47>   {       [ XF86PowerOff          ]       };
    key <K6C>   {       [ XF86Eject             ]       };
    key <I67>   {       [ XF86Reload            ]       };
    key <I68>   {       [ XF86Stop              ]       };
    key <I69>   {       [ XF86Forward           ]       };
    key <I6A>   {       [ XF86Back              ]       };
    key <I6C>   {       [ XF86Mail              ]       };
    key <K75>   {       [ XF86ScrollUp          ]       };
    key <I0F>   {       [ XF86ScrollDown        ]       };
    key <I3C>   {       [ XF86Cut               ]       };
    key <K65>   {       [ XF86Paste             ]       };
    key <I78>   {       [ XF86Copy              ]       };
};
Comment 1 Andreas Sahlbach 2006-09-12 02:57:35 UTC
Darn, I actually forgot the Power On / Off Key in my table. Here is my working
corrected table, where I defined Power On / Off as XF86Sleep and XF86PowerDown.

partial alphanumeric_keys
xkb_symbols "cymotionlinux" {
    name[Group1]= "Cherry CyMotion Master Linux";

    key <FK17>  {       [ XF86Search            ]       };
    key <XFER>  {       [ XF86AudioMedia        ]       };
    key <I02>   {       [ XF86HomePage          ]       };
    key <I05>   {       [ Redo                  ]       };
    key <I0F>   {       [ Undo                  ]       };
    key <I10>   {       [ XF86AudioPrev         ]       };
    key <I17>   {       [ XF86Launch1           ]       };
    key <I19>   {       [ XF86AudioNext         ]       };
    key <I1F>   {       [ XF86Launch0           ]       };
    key <I20>   {       [ XF86AudioMute         ]       };
    key <I21>   {       [ XF86Calculator        ]       };
    key <I22>   {       [ XF86AudioPlay, XF86AudioPause ] };
    key <I24>   {       [ XF86AudioStop         ]       };
    key <I28>   {       [ Multi_key             ]       };
    key <I2B>   {       [ XF86Launch2           ]       };
    key <I2E>   {       [ XF86AudioLowerVolume  ]       };
    key <I30>   {       [ XF86AudioRaiseVolume  ]       };
    key <I47>   {       [ XF86PowerOff          ]       };
    key <K6C>   {       [ XF86Eject             ]       };
    key <I67>   {       [ XF86Reload            ]       };
    key <I68>   {       [ XF86Stop              ]       };
    key <I69>   {       [ XF86Forward           ]       };
    key <I6A>   {       [ XF86Back              ]       };
    key <I6C>   {       [ XF86Mail              ]       };
    key <K75>   {       [ XF86ScrollUp          ]       };
    key <I0F>   {       [ XF86ScrollDown        ]       };
    key <I3C>   {       [ XF86Cut               ]       };
    key <K65>   {       [ XF86Paste             ]       };
    key <I78>   {       [ XF86Copy              ]       };
    key <K68>	{	[ XF86Sleep             ]	};
    key <I63>	{	[ XF86PowerDown         ]	};
};
Comment 2 Daniel Stone 2007-02-27 01:33:19 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 3 Sergey V. Udaltsov 2007-09-14 14:18:48 UTC
Andreas, I changed essential keys. Could you please check? The sequence of launch keys in the current version starts from 1 (not from 0, as in your version). I think it is ok. Also, XF86WWW is used instead of XF86HomePage. I hope it is not a major issue for you.
Comment 4 Andreas Sahlbach 2007-09-14 14:56:44 UTC
Your changes are prolly ok. I will test it next monday, because I am using the keyboard only at work.
Comment 5 Andreas Sahlbach 2007-09-17 03:54:53 UTC
(In reply to comment #3)
> Andreas, I changed essential keys. Could you please check? The sequence of
> launch keys in the current version starts from 1 (not from 0, as in your
> version). I think it is ok. Also, XF86WWW is used instead of XF86HomePage. I
> hope it is not a major issue for you.

Have you checked this in, somewhere? Sounds ok for me but for testing I need a checked in version or a pointer to the changes. 

Comment 6 Sergey V. Udaltsov 2007-09-17 04:06:29 UTC
Yes I checked it in. The CVS is on fd.o. For details, see here:

http://www.freedesktop.org/wiki/Software/XKeyboardConfig/Development
Comment 7 Andreas Sahlbach 2007-09-17 08:16:04 UTC
Ok, first to clarify what I did: I recompiled xkeyboard-config from HEAD and then recompiled my xorg-server which is currently at 1.3.0.0 (just to be sure).
I've noticed the following:
1) The "ON" Key does not work. The XF86Standby key is working. When I press the "ON" key within xev, I get: 
KeyPress event, serial 32, synthetic NO, window 0x3600001,
    root 0xa3, subw 0x0, time 335764427, (164,-16), root:(1101,134),
    state 0x10, keycode 199 (keysym 0x0, NoSymbol), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False
2) The keys for XF86ScrollUp and XF86ScrollDown have alternate symbols for XF86ScrollRight and XF86ScrollLeft, but I am not able to activate those symbols.

The rest of the keys seems to work pretty well. Good job mate!
Comment 8 Sergey V. Udaltsov 2007-09-17 08:39:58 UTC
> 1) The "ON" Key does not work. The XF86Standby key is working. When I press the
> "ON" key within xev, I get: 
> KeyPress event, serial 32, synthetic NO, window 0x3600001,
>     root 0xa3, subw 0x0, time 335764427, (164,-16), root:(1101,134),
>     state 0x10, keycode 199 (keysym 0x0, NoSymbol), same_screen YES,
>     XLookupString gives 0 bytes:
>     XmbLookupString gives 0 bytes:
>     XFilterEvent returns: False
OK, I'll add <K68> mapping

> 2) The keys for XF86ScrollUp and XF86ScrollDown have alternate symbols for
> XF86ScrollRight and XF86ScrollLeft, but I am not able to activate those
> symbols.
Sorry, I do not see these alternate symbols in your mapping.
Comment 9 Sergey V. Udaltsov 2007-09-24 05:06:25 UTC
Andreas confirmed it is fixed


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.