Bug 80689 - hif: Empty offline update results, redux
Summary: hif: Empty offline update results, redux
Status: RESOLVED FIXED
Alias: None
Product: PackageKit
Classification: Unclassified
Component: backend-yum (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-29 19:59 UTC by Kalev Lember
Modified: 2014-06-30 19:21 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Fix a mixup of HifStateAction and HifPackageInfo (8.50 KB, patch)
2014-06-29 20:03 UTC, Kalev Lember
Details | Splinter Review
Improve rpm callback handling for packages in the cleanup state (2.69 KB, patch)
2014-06-29 20:04 UTC, Kalev Lember
Details | Splinter Review
hif: Fix up a signature mismatch with a libhif signal handler (2.64 KB, patch)
2014-06-29 20:06 UTC, Kalev Lember
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kalev Lember 2014-06-29 19:59:44 UTC
I was testing offline updates today with the new libhif-based PackageKit 0.9.3, and ended up with an empty Packages= line again.

After a debugging session, it turned out that this time too (similar to https://bugs.freedesktop.org/show_bug.cgi?id=79791) PK thought all those packages were in the CLEANUP state, and because of that didn't write them out to the offline-update-competed file.

The root cause turned out to be an enum mixup in libhif. I've got 2 libhif patches and a PK patch; I'm attaching them all here to make it easier to review them at one place.
Comment 1 Kalev Lember 2014-06-29 20:03:58 UTC
Created attachment 101983 [details] [review]
Fix a mixup of HifStateAction and HifPackageInfo
Comment 2 Kalev Lember 2014-06-29 20:04:35 UTC
Created attachment 101984 [details] [review]
Improve rpm callback handling for packages in the cleanup state
Comment 3 Kalev Lember 2014-06-29 20:06:10 UTC
Created attachment 101985 [details] [review]
hif: Fix up a signature mismatch with a libhif signal handler
Comment 4 Kalev Lember 2014-06-30 19:21:13 UTC
Pushed after IRC review.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.