Bug 80782 - [Bisected]Piglit spec_ATI_envmap_bumpmap_ati_envmap_bumpmap-bump skips
Summary: [Bisected]Piglit spec_ATI_envmap_bumpmap_ati_envmap_bumpmap-bump skips
Status: CLOSED NOTABUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: high normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-02 03:38 UTC by lu hua
Modified: 2014-10-10 04:42 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lu hua 2014-07-02 03:38:27 UTC
System Environment:
--------------------------
Platform: Haswell
Libdrm:		(master)libdrm-2.4.54-17-ge8c3c1358ecaf4e90f7d43762357ae6f8e2022b6
Mesa:		(master)1bfc0a11027449ae7ab7c28eb695f26de530eccf
Xserver:(master)xorg-server-1.15.99.902-121-g2f5cf9ff9a0f713b7e038636484c77f113a5f10a
Xf86_video_intel:(master)2.99.912-200-ge6e5330857097eb2caafa89d571d12e4bb15f539
Libva:		(master)c61d8c6ce9ffc27320e9e177c1e1123d5f1b5014
Libva_intel_driver:(master)c5cb17ea86f0065a939d3636dd26651c93d497c8
Kernel:	(drm-intel-nightly)a7665faa31dbbbae25e376508a9b3781e25d09e2

Bug detailed description:
-----------------------------
It fails on all platforms with mesa master branch due to "Remove the ATI_envmap_bumpmap extension" .It passes on 10.2 branch.

Bisect shows: 4000c0112a49c28793844f454278b50e00943173 is the first bad commit.
commit 4000c0112a49c28793844f454278b50e00943173
Author:     Jason Ekstrand <jason.ekstrand@intel.com>
AuthorDate: Fri Jun 27 09:40:10 2014 -0700
Commit:     Jason Ekstrand <jason.ekstrand@intel.com>
CommitDate: Mon Jun 30 12:02:25 2014 -0700

    Remove the ATI_envmap_bumpmap extension

    As far as I can tell, the Intel mesa driver is the only driver in the world
    still supporting this legacy extension.  If someone wants to do bump
    mapping, they can use shaders.

    Signed-off-by: Jason Ekstrand <jason.ekstrand@intel.com>
    Reviewed-by: Kenneth Graunke <kenneth@whitecape.org> [v1]
    Reviewed-by: Chris Forbes <chrisf@ijw.co.nz> [v2]
    Reviewed-by: Ian Romanick <idr@freedesktop.org> [v3]

output:
Test requires GL_ATI_envmap_bumpmap
PIGLIT: {'result': 'skip' }

Reproduce steps:
----------------------------
1. xinit
2. bin/ati_envmap_bumpmap-bump -auto
Comment 1 Ian Romanick 2014-07-02 06:38:19 UTC
The functionality was removed, AS THE COMMIT MESSAGES SAYS, so the test CORRECTLY does not run.
Comment 2 Gordon Jin 2014-10-10 04:42:14 UTC
good to know we don't care this.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.