Bug 80787 - Rendering completely botched with current git version. Oibaf PPA.
Summary: Rendering completely botched with current git version. Oibaf PPA.
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-02 05:26 UTC by Aaron B
Modified: 2014-07-03 03:04 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg output (69.29 KB, text/plain)
2014-07-02 05:26 UTC, Aaron B
no flags Details
Screen, looks the same each time. (1.04 MB, image/png)
2014-07-02 05:26 UTC, Aaron B
no flags Details
My hardware and system info. (27.75 KB, text/plain)
2014-07-02 05:27 UTC, Aaron B
no flags Details
Screenshot of my screen on boot. (1.04 MB, image/png)
2014-07-02 05:31 UTC, Aaron B
no flags Details
Packages installed before rendering problems. (21.65 KB, text/plain)
2014-07-02 15:06 UTC, Aaron B
no flags Details
Xorg log (64.53 KB, text/plain)
2014-07-02 15:07 UTC, Aaron B
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron B 2014-07-02 05:26:09 UTC
Created attachment 102104 [details]
dmesg output

R9 270X card, just updated my software. When restart happened, with a few kernels tried, the screen is corrupt the same every time, and is buggy rendering absolutely everything. Pretty easy to spot. :)
Comment 1 Aaron B 2014-07-02 05:26:41 UTC
Created attachment 102105 [details]
Screen, looks the same each time.
Comment 2 Aaron B 2014-07-02 05:27:30 UTC
Created attachment 102106 [details]
My hardware and system info.
Comment 3 Aaron B 2014-07-02 05:31:18 UTC
Created attachment 102107 [details]
Screenshot of my screen on boot.
Comment 4 Alex Deucher 2014-07-02 14:56:14 UTC
What components did you update?  kernel?  glamor?  llvm?  mesa?  Please attach your xorg log as well.
Comment 5 Aaron B 2014-07-02 15:06:34 UTC
Created attachment 102138 [details]
Packages installed before rendering problems.
Comment 6 Aaron B 2014-07-02 15:07:32 UTC
Created attachment 102139 [details]
Xorg log

(In reply to comment #4)
> What components did you update?  kernel?  glamor?  llvm?  mesa?  Please
> attach your xorg log as well.
Comment 7 Alex Deucher 2014-07-02 17:26:44 UTC
Can you narrow down what component caused the regression?
Comment 8 Aaron B 2014-07-02 18:53:23 UTC
(In reply to comment #7)
> Can you narrow down what component caused the regression?

I'm honestly not too sure, I believe it was the radeon xorg-xserver updates, but can't say for 100% sure at all. I'm checking Mesa's git and updates like always, and it seems the build system was fixed for all modules into one module, this could have updated in the middle of all that for my card. But yet, it doesn't have any errors in xorg and everything seems to have loaded and executed fine, so I sadly can't really pin point one exact component to why this has broken my rendering. My best guess is xorg, but there's not many updates and such there for radeon. So I'm basically stumped as to what is really broken, honestly.
Comment 9 Alex Deucher 2014-07-02 20:35:07 UTC
Does reverting 5d5c20920e0e570742a497aa047e99a2fa3c04f2 from mesa help?
Comment 10 Aaron B 2014-07-02 22:38:30 UTC
(In reply to comment #9)
> Does reverting 5d5c20920e0e570742a497aa047e99a2fa3c04f2 from mesa help?

Well, I tried to test it, but with no luck. Mesa failed to install correctly. Directories were completely wrong (Putting all of them in /usr/local/? HUH?), so they weren't loaded on the DE start. Now my desktop is in fall back because I tried xorg edgers, but their radeon is basically not supported anymore so I'm in fall back. Oh well. If someone else could test, that'd be great. Maybe later I can try to test it, I'll probably reinstall tonight in about...5 hours or so. Sorry about that.
Comment 11 Michel Dänzer 2014-07-03 03:04:26 UTC
It was most likely commit 5d5c20920e0e570742a497aa047e99a2fa3c04f2, which I've now reverted. Please reopen if the problem persists with the revert.

Module: Mesa
Branch: master
Commit: 370184e813b25b463ad3dc9ca814231c98b95864
URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=370184e813b25b463ad3dc9ca814231c98b95864

Author: Michel Dänzer <michel.daenzer@amd.com>
Date:   Thu Jul  3 10:58:57 2014 +0900

Revert "radeonsi: Use dma_copy when possible for si_blit."


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.