Bug 80896 - [BDW Regression]dmesg error "<3>[ 1.954836] [drm:gen8_irq_handler] *ERROR* The master control interrupt lied (SDE)!" after boot
Summary: [BDW Regression]dmesg error "<3>[ 1.954836] [drm:gen8_irq_handler] *ERROR*...
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: Other All
: low major
Assignee: Dima Ryazanov
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords: bisected
: 90058 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-07-04 06:45 UTC by Guo Jinxian
Modified: 2017-07-24 22:53 UTC (History)
10 users (show)

See Also:
i915 platform: BDW
i915 features: display/Other


Attachments
dmesg (82.41 KB, text/plain)
2014-07-04 06:45 UTC, Guo Jinxian
no flags Details
dmesg (103.74 KB, text/plain)
2014-07-14 01:40 UTC, Guo Jinxian
no flags Details
dmesg(14bf99) (71.22 KB, text/plain)
2014-08-12 08:30 UTC, lu hua
no flags Details
dmesg (162.67 KB, text/plain)
2015-05-19 20:33 UTC, Dima Ryazanov
no flags Details
dmesg output, post event (63.77 KB, text/plain)
2015-05-28 19:26 UTC, Tobias Gerschner
no flags Details
master control interrupt lied event (66.36 KB, text/plain)
2015-08-22 10:09 UTC, M.B.
no flags Details
The master control interrupt lied (109.06 KB, text/plain)
2015-10-12 10:22 UTC, Kim Carlsen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guo Jinxian 2014-07-04 06:45:35 UTC
Created attachment 102239 [details]
dmesg

==System Environment==
--------------------------
Regression: Yes. 
Good commit on -next-queued: b6fdd0f2b990006daba19eec676b632faa523fc8

Non-working platforms: BDW

==kernel==
--------------------------
origin/drm-intel-nightly: eb638c7fabe97a9df752aeb2f59a9463ce4aed8e(fails)
    drm-intel-nightly: 2014y-07m-03d-14h-50m-16s integration manifest
origin/drm-intel-next-queued: 5e59f7175f96550ede91f58d267d2b551cb6fbba(fails)
    drm/i915: Try harder to get FBC  
origin/drm-intel-fixes: 5549d25f642a7e6cfb8744d0031a9da404f696d6(works)
    drm/i915: Drop early VLV WA to fix Voltage not getting dropped to Vmin

==Bug detailed description==
dmesg error "<3>[    1.954836] [drm:gen8_irq_handler] *ERROR* The master control interrupt lied (SDE)!" after boot.

Output:
[root@x-bdw01 ~]# dmesg -r | egrep "<[1-3]>" |grep drm
<3>[ 1.955683] [drm:gen8_irq_handler] *ERROR* The master control interrupt lied (SDE)!
<3>[ 1.955848] [drm:gen8_irq_handler] *ERROR* The master control interrupt lied (SDE)!
<3>[ 3.683649] [drm:gen8_irq_handler] *ERROR* The master control interrupt lied (SDE)!
<3>[ 3.686870] [drm:gen8_irq_handler] *ERROR* The master control interrupt lied (SDE)!


==Reproduce steps==
---------------------------- 
1.  boot
2.  dmesg -r | egrep "<[1-3]>" |grep drm
Comment 1 Paulo Zanoni 2014-07-04 12:09:10 UTC
Can you please bisect this? Which one is the bad commit?
Comment 2 Damien Lespiau 2014-07-04 15:43:29 UTC
No need to bisect, the error message was introduced by Oscar in

commit 38cc46d73ed99dd7002f1406002e52d7975d16cc
Author: Oscar Mateo <oscar.mateo@intel.com>
Date:   Mon Jun 16 16:10:59 2014 +0100

    drm/i915/bdw: Ack interrupts before handling them (GEN8)

And for those reason bit 23 of master ctl is set and the SDE IIR is 0.
Comment 3 Guo Jinxian 2014-07-14 01:40:02 UTC
Created attachment 102730 [details]
dmesg

(In reply to comment #2)
> No need to bisect, the error message was introduced by Oscar in
> 
> commit 38cc46d73ed99dd7002f1406002e52d7975d16cc
> Author: Oscar Mateo <oscar.mateo@intel.com>
> Date:   Mon Jun 16 16:10:59 2014 +0100
> 
>     drm/i915/bdw: Ack interrupts before handling them (GEN8)
> 
> And for those reason bit 23 of master ctl is set and the SDE IIR is 0.
Revert this commit on latest -next-queued,error "<3>[ 1.955683] [drm:gen8_irq_handler] *ERROR* The master control interrupt lied (SDE)!" unable to reproduce, but here has another error. Please check the output below. Need we report a new bug for this?

Output:
[root@x-bdw01 ~]# dmesg -r | egrep "<[1-3]>" |grep drm
<3>[    2.753243] [drm:intel_dp_start_link_train] *ERROR* failed to enable link training
<3>[    2.768133] [drm:intel_dp_start_link_train] *ERROR* failed to enable link training
<3>[    2.780219] [drm:intel_dp_start_link_train] *ERROR* failed to enable link training
<3>[    2.792092] [drm:intel_dp_start_link_train] *ERROR* failed to enable link training
<3>[    2.804271] [drm:intel_dp_start_link_train] *ERROR* failed to enable link training
<3>[    2.813306] [drm:intel_dp_start_link_train] *ERROR* failed to enable link training
<3>[    2.831054] [drm:intel_dp_start_link_train] *ERROR* failed to update link training
<3>[    2.832254] [drm:intel_dp_complete_link_train] *ERROR* failed to train DP, aborting
Comment 4 Paulo Zanoni 2014-08-11 18:32:37 UTC
Hi

It seems you're booting with eDP+HDMI. I can't reproduce this with eDP+HDMI or just eDP. Can you please confirm whether this only happens when you boot with DP (or DP+something) attached?

Thanks,
Paulo
Comment 5 Paulo Zanoni 2014-08-11 18:37:42 UTC
(In reply to comment #4)
> Hi
> 
> It seems you're booting with eDP+HDMI. I can't reproduce this with eDP+HDMI

What I wanted to say was: "It seems you're booting with eDP+DP."

> or just eDP. Can you please confirm whether this only happens when you boot
> with DP (or DP+something) attached?
> 
> Thanks,
> Paulo
Comment 6 lu hua 2014-08-12 08:30:06 UTC
Created attachment 104474 [details]
dmesg(14bf99)

It doesn't happen on latest -queued and -nightly kernel.I guess someone fixed it.
Comment 7 Paulo Zanoni 2014-08-12 12:37:49 UTC
(In reply to comment #6)
> Created attachment 104474 [details]
> dmesg(14bf99)
> 
> It doesn't happen on latest -queued and -nightly kernel.I guess someone
> fixed it.

Closing bug then. If it still happens, please reopen.
Comment 8 Guo Jinxian 2014-08-13 06:11:22 UTC
Verified on latest -nightly(723dbbfb6ce02b5662c0c4cac9be3bcdfbb11d35)

[root@x-bdw01 ~]# dmesg -r | egrep "<[1-3]>" |grep drm
[root@x-bdw01 ~]#
Comment 9 Dima Ryazanov 2015-05-19 20:33:49 UTC
Created attachment 115902 [details]
dmesg

I just saw this error while running the 4.0.3 kernel (4.0.3-300.fc22.x86_64).
Comment 10 Tobias Gerschner 2015-05-28 19:26:45 UTC
Created attachment 116126 [details]
dmesg output, post event
Comment 11 Tobias Gerschner 2015-05-28 19:30:33 UTC
Comment on attachment 116126 [details]
dmesg output, post event

This happens on a new NUC, with

CPU0: Intel(R) Core(TM) i7-5557U CPU @ 3.10GHz (fam: 06, model: 3d, stepping: 04)

I'm running a 4K display off the miniDP port.

It happens almost every single time I walk away from the computer within 10-15 minutes.
Comment 12 Jani Nikula 2015-08-18 14:18:51 UTC
*** Bug 90058 has been marked as a duplicate of this bug. ***
Comment 13 M.B. 2015-08-22 10:09:42 UTC
Created attachment 117855 [details]
master control  interrupt lied event

Not exactly sure what I'm looking at here. Using live infrastructure (libdrm, mesa, xorg-server, xf86-video-intel, all -9999) on gentoo.

Linux hatshepsut 4.1.6-gentoo #1 SMP Thu Aug 20 13:12:11 CEST 2015 x86_64 Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz GenuineIntel GNU/Linux

If you need additional info, please let me know.
Comment 14 Kim Carlsen 2015-10-12 10:22:37 UTC
Created attachment 118836 [details]
The master control interrupt lied

kernel output on a 
Lenovo X1 Carbon (3rd gen) connected to a lenovo onelink pro dock
Comment 15 Kim Carlsen 2015-10-12 10:28:29 UTC
(In reply to Kim Carlsen from comment #14)
> Created attachment 118836 [details]
> The master control interrupt lied
> 
> kernel output on a 
> Lenovo X1 Carbon (3rd gen) connected to a lenovo onelink pro dock

Outputting 2560x1440@60 works fine, outputting 3840x2160@60 produces no picture on external monitor. 

When removing the onelink prodock and connecting the dp cable directly to the laptop then all resolutions works (3840x2160@60).

Whenever running xrandr it adds 36 lines to kernel log of 'The master control interrupt lied'
Comment 16 Kim Carlsen 2015-10-12 10:32:51 UTC
When 4k resolution is working, these error message is still present in kernel.log. Maybe resolution issue is unrelated to IRQ issue
Comment 17 Jani Nikula 2015-10-12 14:24:58 UTC
(In reply to Kim Carlsen from comment #16)
> When 4k resolution is working, these error message is still present in
> kernel.log. Maybe resolution issue is unrelated to IRQ issue

Please file that as a separate bug to not conflate this one, thanks.
Comment 18 Daniel Vetter 2015-10-23 13:27:39 UTC
commit 97e5ed1111dcc5300a0f59a55248cd243937a8ab
Author: Daniel Vetter <daniel.vetter@ffwll.ch>
Date:   Fri Oct 23 10:56:12 2015 +0200

    drm/i915: shut up gen8+ SDE irq dmesg noise


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.