Bug 80922 - XCOM :Enemy Unknown will crash and kill the output after some time.
Summary: XCOM :Enemy Unknown will crash and kill the output after some time.
Status: RESOLVED DUPLICATE of bug 80419
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-04 17:46 UTC by Will H
Modified: 2015-08-02 12:38 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
glxinfo (58.12 KB, text/plain)
2014-07-04 17:46 UTC, Will H
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Will H 2014-07-04 17:46:41 UTC
Created attachment 102280 [details]
glxinfo

Wish I could describe it better but there is no better words. The game will lock up the card and the monitor output will go blank, although once I got lucky and it crashed to the terminal spewing errors about radeon. Due to the fact that the system crashes the only. This crash usually happens during a gameplay sequence and has not happened in a menu as of yet. The crash also will usually recover the first time after loosing visual output for 10 seconds but then will cut out a second (or rarely a third) and not return to the game.

Due to it crashing randomly (no specific scene causing it) and always requiring about a hour of play, would it make sense to be a memory issue?

It did not occur to me that I would need Dmesg output, if its needed then remind me and I will reproduce another crash with the log file.

I also have a apitrace, but it totals 23GB and I do not know which bit would need trimming.


System Specs:

AMD PhenomII X6 T55
AMD RadeonHD 7950
Mesa 10.3.0-devel (git-370184e)
LLVM 3.5.0 (svn)
Comment 1 Marek Olšák 2015-08-02 10:38:03 UTC
Does Mesa git still crash?
Comment 2 Kai 2015-08-02 11:57:36 UTC
(In reply to Marek Olšák from comment #1)
> Does Mesa git still crash?

I've seen this crash as well and can't seem to reproduce it right now. Though it might be a bit too early to call it fixed just yet, because as Will wrote, there wasn't really a fixed time after which the game crashed. Sometimes I had been able to play several hours other times I barely was able to get more than 15 minutes. (Most of the time, though, the game started crashing about an hour in.)
It also didn't matter whether I had the INI-File modifications for better visuals active or not.

Anyway, within 1.5 hours, the game didn't crash with the stack detailed below.

My current stack (Debian testing as a base):
GPU: Hawaii PRO [Radeon R9 290] (ChipID = 0x67b1)
Mesa: Git:master/5d29eaef85
libdrm: 2.4.62-1
LLVM: SVN:trunk/r243678 (3.8 devel)
X.Org: 2:1.17.1-2
Linux: 4.1.3
Firmware: <https://secure.freedesktop.org/~agd5f/radeon_ucode/hawaii/>
> 286640da3d90d7b51bdb038b65addc47  hawaii_ce.bin
> 161105a73f7dfb2fca513327491c32d6  hawaii_mc.bin
> d6195059ea724981c9acd3abd6ee5166  hawaii_me.bin
> ad511d31a4fe3147c8d80b8f6770b8d5  hawaii_mec.bin
> 63eae3f33c77aadbc6ed1a09a2aed81e  hawaii_pfp.bin
> 5b72c73acf0cbd0cbb639302f65bc7dc  hawaii_rlc.bin
> f00de91c24b3520197e1ddb85d99c34a  hawaii_sdma1.bin
> 8e16f749d62b150d0d1f580d71bc4348  hawaii_sdma.bin
> 7b6ca5302b56bd35bf52804919d57e63  hawaii_smc.bin
> 9f2ba7e720e2af4d7605a9a4fd903513  hawaii_uvd.bin
> b0f2a043e72fbf265b2f858b8ddbdb09  hawaii_vce.bin
libclc: Git:master/7958b0202b
DDX: Git:master/b6d871bf29
Comment 3 Marek Olšák 2015-08-02 12:38:30 UTC
This looks like a duplicate of bug 80419.

*** This bug has been marked as a duplicate of bug 80419 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.