Bug 80928 - chrome crashing the gpu on sandybridge
Summary: chrome crashing the gpu on sandybridge
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 84719 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-07-04 20:40 UTC by Andi Kleen
Modified: 2018-02-06 08:39 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
crash dump (68.86 KB, text/plain)
2014-07-04 20:40 UTC, Andi Kleen
Details
card0 error dump (2.21 MB, application/octet-stream)
2014-08-25 22:27 UTC, exi+freedesktop
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andi Kleen 2014-07-04 20:40:12 UTC
[First I reported this problem over a week ago on the intel-gfx mailing list, but I got neither a bounce nor did the email ever appear. If you plan to run your mailing list for some private cabal only please mark them so that people do not waste time with them. Thanks]


The current version of chrome reproducibly hangs the GPU on my
sandy bridge system when using google maps. The GUI freezes
and I have to kill chrome from a console to recover.

Known problem? Crash dump is attached.

Kernel 3.15.1 (opensuse version)

google-chrome-stable-35.0.1916.153-1.x86_64

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Desktop
OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.2.3
OpenGL core profile shading language version string: 1.40


522626.356259] [drm] stuck on render ring
[522626.357015] [drm] GPU HANG: ecode 0:0x85fffff9, reason: Ring hung,
action: reset
[522626.357015] [drm] GPU hangs can indicate a bug anywhere in the
entire gfx stack, including userspace.
[522626.357016] [drm] Please file a _new_ bug report on
bugs.freedesktop.org against DRI -> DRM/Intel
[522626.357016] [drm] drm/i915 developers can then reassign to the right
component if it's not a kernel issue.
[522626.357016] [drm] The gpu crash dump is required to analyze gpu
hangs, so please always attach it.
[522626.357016] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[522628.356424] [drm] Enabling RC6 states: RC6 on, RC6p off, RC6pp off
[522638.368877] Watchdog[1565]: segfault at 0 ip 00007f6992e78b4e sp
00007f6981fe7670 error 6 in chrome[7f698ee87000+4f39000]
[522712.515146] Watchdog[1776]: segfault at 0 ip 00007f2963b4bb4e sp
00007f2952cba670 error 6 in chrome[7f295fb5a000+4f39000]
[522724.558268] Watchdog[1930]: segfault at 0 ip 00007f43334a9b4e sp
00007f4322618670 error 6 in chrome[7f432f4b8000+4f39000]
[522728.389633] [drm] stuck on render ring
[522728.390330] [drm] GPU HANG: ecode 0:0x85fffff9, reason: Ring hung,
action: reset
[522730.389771] [drm] Enabling RC6 states: RC6 on, RC6p off, RC6pp off
Comment 1 Andi Kleen 2014-07-04 20:40:56 UTC
Created attachment 102285 [details]
crash dump
Comment 2 exi+freedesktop 2014-08-25 22:27:26 UTC
Created attachment 105256 [details]
card0 error dump

output from /sys/class/drm/card0/error
Comment 3 exi+freedesktop 2014-08-25 22:31:58 UTC
I am also experiencing this bug.
Running anything with OpenGL, for example glxspheres64 or Steam crashes the X server.

My specs:
Arch linux
Linux 3.16.1-1-ARCH #1 SMP PREEMPT x86_64 GNU/Linux
Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz

driver:
extra/xf86-video-intel 2.99.914-4 (xorg-drivers xorg)

lspci:
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Lenovo Device 21f5
        Flags: bus master, fast devsel, latency 0, IRQ 45
        Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 6000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [a4] PCI Advanced Features
        Kernel driver in use: i915
        Kernel modules: i915


dmesg output:
[   30.344269] [drm] stuck on render ring
[   30.344724] [drm] GPU HANG: ecode 0:0x84fffffc, in glxspheres64 [910], reason: Ring hung, action: reset
[   30.344725] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[   30.344726] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[   30.344726] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[   30.344727] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[   30.344728] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[   32.345962] [drm] Enabling RC6 states: RC6 on, RC6p on, RC6pp off
[   36.329389] [drm] stuck on render ring
[   36.329887] [drm] GPU HANG: ecode 0:0x85fffff9, in glxspheres64 [910], reason: Ring hung, action: reset
[   38.331332] [drm] Enabling RC6 states: RC6 on, RC6p on, RC6pp off
Comment 4 exi+freedesktop 2014-08-25 22:35:22 UTC
More Info for mesa:
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.2.6
OpenGL core profile shading language version string: 3.30
Comment 5 Kenneth Graunke 2014-08-31 08:52:44 UTC
(In reply to comment #4)
> More Info for mesa:
> OpenGL vendor string: Intel Open Source Technology Center
> OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
> OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.2.6
> OpenGL core profile shading language version string: 3.30

Please file a separate bug.  Not all crashes are the same, and given that you're running a different application on a different platform...it's almost certainly not the same bug.  Thanks.
Comment 6 Eero Tamminen 2015-01-12 10:30:06 UTC
(In reply to Andi Kleen from comment #0)
> Kernel 3.15.1 (opensuse version)
> 
> google-chrome-stable-35.0.1916.153-1.x86_64
> 
> OpenGL vendor string: Intel Open Source Technology Center
> OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Desktop
> OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.2.3

Hangs are more likely due to Mesa than kernel and especially your Mesa version is really old.  Does the issue happen with latest Mesa release?

(As to application being able to hang the system with GPU operations, there have been some improvements on that area in recent kernel versions.)
Comment 7 Andi Kleen 2015-01-12 20:05:27 UTC
With newer Mesa and/or newer chrome the problem seems to be gone.
Comment 8 Andi Kleen 2015-01-12 20:06:06 UTC
Mesa-10.4.0-100.1.x86_64
google-chrome-stable-39.0.2171.95-1.x86_64
Comment 9 Eero Tamminen 2015-01-13 08:57:26 UTC
Thanks, I'm marking this as fixed.

If you can reproduce similar issue also with latest Mesa, please file a new bug, this one is against too old version.  Before filing hang bugs, it would be good if you could also test latest kernel release, preferably also latest X intel driver (version which is compatible with your X server DDX ABI).
Comment 10 Tapani Pälli 2018-02-06 08:39:43 UTC
*** Bug 84719 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.