Bug 80936 - "Stalling on GPU for mapping a busy buffer object" message
Summary: "Stalling on GPU for mapping a busy buffer object" message
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 10.2
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-05 06:16 UTC by Cedric Sodhi
Modified: 2019-09-25 18:51 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cedric Sodhi 2014-07-05 06:16:59 UTC
I get this message on every call of DrawElements, although I do not map a single buffer throughout the course of the program. The code (not a testcase, but small program) is located here

https://github.com/ManDay/iod/commit/cc99a3a71704368fa95beed5ffc7b444e9d2be5d

(depends on CMake, GLFW, Version overrides 3.3/330)

The message is caused by iod/planet.c:660.
Comment 1 Cedric Sodhi 2014-07-05 06:56:56 UTC
RadeonHD 4890 does not emit any such warning.
Comment 2 Matt Turner 2014-08-11 03:01:35 UTC
(In reply to comment #1)
> RadeonHD 4890 does not emit any such warning.

Yeah, it's coming from perf_debug() in i965, which is supposed to alert application developers to performance problems in their applications.

Your application has now changed significantly since this was filed, so I can't even be sure there's still a problem.

I tried to run your program, but it asserts, presumably not able to find the shaders. Unclear to me how I'm supposed to run it.
Comment 3 Cedric Sodhi 2014-08-11 05:24:34 UTC
Practically it might not be a problem, but I assume it may become one at any time again. In order for it to find the shaders, you have to `make install`:

mkdir build
cd build
cmake -D CMAKE_INSTALL_PREFIX=../install ..
Comment 4 GitLab Migration User 2019-09-25 18:51:41 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1445.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.