Bug 81025 - [IVB/BYT Bisected]Piglit spec_ARB_draw_indirect_arb_draw_indirect-draw-elements-prim-restart-ugly fails
Summary: [IVB/BYT Bisected]Piglit spec_ARB_draw_indirect_arb_draw_indirect-draw-elemen...
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: high major
Assignee: Kenneth Graunke
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-08 03:05 UTC by lu hua
Modified: 2015-05-06 20:38 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lu hua 2014-07-08 03:05:08 UTC
System Environment:
--------------------------
Platform: Ivybridge
Libdrm:	(master)libdrm-2.4.54-17-ge8c3c1358ecaf4e90f7d43762357ae6f8e2022b6	
Mesa:	(master)f6db414f3ca2d692f262e3f5a38d4fcedbdf4f4f	
Xserver:(master)xorg-server-1.15.99.902-121-g2f5cf9ff9a0f713b7e038636484c77f113a5f10a
Xf86_video_intel:(master)2.99.912-224-g8fa22964f69d3ec8700f177dd7cb3cbc396a9f35
Libva:	(master)c61d8c6ce9ffc27320e9e177c1e1123d5f1b5014	
Libva_intel_driver: (master)c5cb17ea86f0065a939d3636dd26651c93d497c8
Kernel:	(drm-intel-nightly) 026bdf385dec2e1ade18eab75d0eed3997b88e9c

Bug detailed description:
-----------------------------
It fails on Ivybridge and Baytrail with mesa master and 10.2 branch.
Bisect shows:35cf3831d71770211f29da6608313dc1f6213d7b is the first bad commit.
commit 35cf3831d71770211f29da6608313dc1f6213d7b
Author:     Thomas Hellstrom <thellstrom@vmware.com>
AuthorDate: Thu Jul 3 02:07:36 2014 -0700
Commit:     Thomas Hellstrom <thellstrom@vmware.com>
CommitDate: Thu Jul 3 02:55:00 2014 -0700

    st/xa: Don't close the drm fd on failure v2

    If XA fails to initialize with pipe_loader enabled, the pipe_loader's
    cleanup function will close the drm file descriptor. That's pretty bad
    because the file descriptor will probably be the X server driver's only
    connection to drm. Temporarily solve this by dup()'ing the file descriptor
    before handing it over to the pipe loader.

    This fixes freedesktop.org bugzilla bug #80645.

    v2: Fix CC addresses.

    Cc: "10.2" <mesa-stable@lists.freedesktop.org>
    Signed-off-by: Thomas Hellstrom <thellstrom@vmware.com>
    Reviewed-by: Jakob Bornecrantz <jakob@vmware.com>

output:
Probe color at (96,96)
  Expected: 0.000000 0.000000 1.000000
  Observed: 1.000000 0.000000 0.000000
PIGLIT: {'result': 'fail' }

Reproduce steps:
---------------------------- 
1. xinit
2. bin/arb_draw_indirect-draw-elements-prim-restart-ugly -fbo -auto
Comment 1 Matt Turner 2014-07-08 04:51:46 UTC
The bisected commit isn't related to i965. It can't have caused i965 a problem.
Comment 2 lu hua 2014-07-08 05:14:16 UTC
(In reply to comment #1)
> The bisected commit isn't related to i965. It can't have caused i965 a
> problem.

I will bisect it again. Thanks.
Comment 3 lu hua 2014-07-14 06:26:57 UTC
Try to bisect it again.
Nightly testing, This case pass on commit e1432489c0c1b5bcf7f4a68c6ddf847a4c99973c, but I can't reproduce the pass. Replace /opt/X11R7/lib/dri/i965_dri.so, it also pass.
Comment 4 Kenneth Graunke 2014-07-24 23:30:09 UTC
Well, I can't reproduce this, and it sounds like hua can't reproduce it anymore either.  So...closing.
Comment 5 Mark Janes 2015-04-10 18:42:48 UTC
This bug began reproducing on the jenkins system when we began compiling mesa with -O2.

Ken, can you repro with an optimized mesa?
Comment 6 Mark Janes 2015-04-11 00:18:16 UTC
I tried to bisect this, and found the revision where Ian 10.2 commit which changed buildsupport to not override the user's -O2 setting.  Ugh.

I have to update the buildsystem to add build dependencies for builds older than 10.2 (libxml2) before I can bisect older builds.
Comment 7 Kenneth Graunke 2015-04-11 09:25:14 UTC
Don't bother - I can indeed reproduce the problem with optimized builds, and will have a patch on the list shortly.
Comment 8 Kenneth Graunke 2015-04-11 09:46:51 UTC
Patch on mailing list:
http://lists.freedesktop.org/archives/mesa-dev/2015-April/081641.html


bug/show.html.tmpl processed on Jan 18, 2017 at 01:47:29.
(provided by the Example extension).