Bug 81281 - arora window resizing causes window border to occasionally tear.
Summary: arora window resizing causes window border to occasionally tear.
Status: RESOLVED MOVED
Alias: None
Product: Wayland
Classification: Unclassified
Component: XWayland (show other bugs)
Version: 1.5.0
Hardware: Other All
: medium normal
Assignee: Wayland bug list
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 81282 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-07-13 06:55 UTC by Andrew Engelbrecht
Modified: 2019-05-10 15:52 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Engelbrecht 2014-07-13 06:55:48 UTC
in upstream xwayland 1.15.99.904 and master, window resizing is very good. however, when quickly resizing the window of arora by continuously swirling the bottom right corner, one can see the window border blink every once in a while.

this is most noticeable in the title area. it flashes out of appearance very briefly.

when resizing the right hand side along the horizontal dimension only, i noticed that the left hand side had this same issue, but a tearing effect was also more noticeable.

i did not see this in weston-terminal or xman.
Comment 1 Daniel Stone 2014-10-03 17:59:37 UTC
Yeah, this is very hard to fix, as it essentially involves blocking in the X server. :\
Comment 2 Daniel Stone 2014-10-03 17:59:53 UTC
*** Bug 81282 has been marked as a duplicate of this bug. ***
Comment 3 GitLab Migration User 2019-05-10 15:52:22 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/xserver/issues/693.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.