Bug 81394 - [gen4] GPU Hangs - Chrome (Adobe Flash Player)
Summary: [gen4] GPU Hangs - Chrome (Adobe Flash Player)
Status: RESOLVED DUPLICATE of bug 80568
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86 (IA32) All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-15 17:38 UTC by Tom
Modified: 2014-11-14 19:28 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Contents of kern.log and Xorg.0. (494.59 KB, text/plain)
2014-07-15 17:38 UTC, Tom
Details
Content /sys/class/drm/card0/error (no file /sys/class/card0/error on Ubuntu) (850.03 KB, text/plain)
2014-07-16 17:07 UTC, Tom
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tom 2014-07-15 17:38:16 UTC
Created attachment 102866 [details]
Contents of kern.log and Xorg.0.

On some sites with flash banners GPU hangs. Attaching: kern.log, Xorg.log.0.old dmesg 

johny@Dell-LD830:~$ uname -a
Linux Dell-LD830 3.13.0-30-generic #54-Ubuntu SMP Mon Jun 9 22:47:59 UTC 2014 i686 i686 i686 GNU/Linux

johny@Dell-LD830:~$ sudo cat /sys/class/drm/card0/error 
no error state collected

johny@Dell-LD830:~$ dmesg |grep -i Intel
[    0.000000]   Intel GenuineIntel
[    0.064764] smpboot: CPU0: Intel(R) Core(TM)2 Duo CPU     T7100  @ 1.80GHz (fam: 06, model: 0f, stepping: 0d)
[    0.068000] Performance Events: PEBS fmt0+, 4-deep LBR, Core2 events, Intel PMU driver.
[    0.068000] perf_event_intel: PEBS disabled due to CPU errata
[    0.959689] intel_idle: does not run on family 6 model 15
[    0.985394] agpgart-intel 0000:00:00.0: Intel 965GM Chipset
[    0.985444] agpgart-intel 0000:00:00.0: detected gtt size: 524288K total, 262144K mappable
[    0.985962] agpgart-intel 0000:00:00.0: detected 8192K stolen memory
[    0.988161] agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0xe0000000
[   18.389356] fb: conflicting fb hw usage inteldrmfb vs VESA VGA - removing generic driver
[   18.465366] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s
[   18.465371] iwl3945: Copyright(c) 2003-2011 Intel Corporation
[   18.529795] iwl3945 0000:0c:00.0: Detected Intel Wireless WiFi Link 3945ABG
[   18.871557] fbcon: inteldrmfb (fb0) is primary device
[   19.760295] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[   19.817536] snd_hda_intel 0000:00:1b.0: irq 46 for MSI/MSI-X
[   19.922716] input: HDA Intel Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input10
[   19.922906] input: HDA Intel Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input9


johny@Dell-LD830:~$ google-chrome --version
Google Chrome 34.0.1847.116 

johny@Dell-LD830:~$ sudo dpkg -l|grep -i Xorg
ii  python3-xkit                               0.5.0ubuntu2                               all          library for the manipulation of xorg.conf files (Python 3)
ii  xorg                                       1:7.7+1ubuntu8                             i386         X.Org X Window System
ii  xorg-docs-core                             1:1.7-1                                    all          Core documentation for the X.org X Window System
ii  xorg-sgml-doctools                         1:1.11-1                                   all          Common tools for building X.Org SGML documentation
ii  xserver-xorg                               1:7.7+1ubuntu8                             i386         X.Org X server
ii  xserver-xorg-core                          2:1.15.1-0ubuntu2                          i386         Xorg X server - core server
ii  xserver-xorg-input-all                     1:7.7+1ubuntu8                             i386         X.Org X server -- input driver metapackage
ii  xserver-xorg-input-evdev                   1:2.8.2-1ubuntu2                           i386         X.Org X server -- evdev input driver
ii  xserver-xorg-input-mouse                   1:1.9.0-1build1                            i386         X.Org X server -- mouse input driver
ii  xserver-xorg-input-synaptics               1.7.4-0ubuntu1                             i386         Synaptics TouchPad driver for X.Org server
ii  xserver-xorg-input-vmmouse                 1:13.0.0-1build1                           i386         X.Org X server -- VMMouse input driver to use with VMWare
ii  xserver-xorg-input-wacom                   1:0.23.0-0ubuntu2                          i386         X.Org X server -- Wacom input driver
ii  xserver-xorg-video-all                     1:7.7+1ubuntu8                             i386         X.Org X server -- output driver metapackage
ii  xserver-xorg-video-ati                     1:7.3.0-1ubuntu3.1                         i386         X.Org X server -- AMD/ATI display driver wrapper
ii  xserver-xorg-video-cirrus                  1:1.5.2-1build1                            i386         X.Org X server -- Cirrus display driver
ii  xserver-xorg-video-fbdev                   1:0.4.4-1build1                            i386         X.Org X server -- fbdev display driver
ii  xserver-xorg-video-glamoregl               0.6.0-0ubuntu4                             i386         X.Org X server -- graphics acceleration module based on OpenGL
ii  xserver-xorg-video-intel                   2:2.99.910-0ubuntu1                        i386         X.Org X server -- Intel i8xx, i9xx display driver
ii  xserver-xorg-video-mach64                  6.9.4-1build1                              i386         X.Org X server -- ATI Mach64 display driver
ii  xserver-xorg-video-mga                     1:1.6.3-1build1                            i386         X.Org X server -- MGA display driver
ii  xserver-xorg-video-modesetting             0.8.1-1build1                              i386         X.Org X server -- Generic modesetting driver
ii  xserver-xorg-video-neomagic                1:1.2.8-1build1                            i386         X.Org X server -- Neomagic display driver
ii  xserver-xorg-video-nouveau                 1:1.0.10-1ubuntu2                          i386         X.Org X server -- Nouveau display driver
ii  xserver-xorg-video-openchrome              1:0.3.3-1build1                            i386         X.Org X server -- VIA display driver
ii  xserver-xorg-video-qxl                     0.1.1-0ubuntu3                             i386         X.Org X server -- QXL display driver
ii  xserver-xorg-video-r128                    6.9.2-1build1                              i386         X.Org X server -- ATI r128 display driver
ii  xserver-xorg-video-radeon                  1:7.3.0-1ubuntu3.1                         i386         X.Org X server -- AMD/ATI Radeon display driver
ii  xserver-xorg-video-s3                      1:0.6.5-0ubuntu4                           i386         X.Org X server -- legacy S3 display driver
ii  xserver-xorg-video-savage                  1:2.3.7-2ubuntu2                           i386         X.Org X server -- Savage display driver
ii  xserver-xorg-video-siliconmotion           1:1.7.7-2build1                            i386         X.Org X server -- SiliconMotion display driver
ii  xserver-xorg-video-sis                     1:0.10.7-0ubuntu6                          i386         X.Org X server -- SiS display driver
ii  xserver-xorg-video-sisusb                  1:0.9.6-2build1                            i386         X.Org X server -- SiS USB display driver
ii  xserver-xorg-video-tdfx                    1:1.4.5-1build1                            i386         X.Org X server -- tdfx display driver
ii  xserver-xorg-video-trident                 1:1.3.6-0ubuntu5                           i386         X.Org X server -- Trident display driver
ii  xserver-xorg-video-vesa                    1:2.3.3-1build1                            i386         X.Org X server -- VESA display driver
ii  xserver-xorg-video-vmware                  1:13.0.2-2ubuntu1                          i386         X.Org X server -- VMware display driver
Comment 1 Chris Wilson 2014-07-16 06:13:46 UTC
You need to attach /sys/class/card0/error
Comment 2 Tom 2014-07-16 17:05:12 UTC
> You need to attach /sys/class/card0/error

I really tried finding it on my initial bug report, but I couldn't find it - no such file or directory :(


johny@Dell-LD830:/sys/devices/pci0000:00/0000:00:02.0$ sudo ls -al /sys/class/card*
ls: nie ma dostępu do /sys/class/card*: Nie ma takiego pliku ani katalogu


johny@Dell-LD830:/sys/class$ ls
ata_device  block      dmi       hidraw       leds      net            ppdev    pwm          scsi_disk     spi_master     vc
ata_link    bluetooth  drm       hwmon        mdio_bus  pci_bus        ppp      regulator    scsi_generic  spi_transport  virtio-ports
ata_port    bsg        extcon    i2c-adapter  mem       pcmcia_socket  pps      rfkill       scsi_host     thermal        vtconsole
backlight   devfreq    firmware  ieee80211    misc      powercap       printer  rtc          sound         tty            watchdog
bdi         dma        graphics  input        mmc_host  power_supply   ptp      scsi_device  spi_host      usbmisc        wmi


johny@Dell-LD830:/sys/class/drm$ ls
card0  card0-DVI-D-1  card0-LVDS-1  card0-SVIDEO-1  card0-VGA-1  controlD64  version


Info from /sys/class/drm/card0/error i've provided in first bug report. 
Now file /sys/class/drm/card0/error contains "no error state collected". 
Maybe this is file is not created in my Ubuntu distribution?

johny@Dell-LD830:~$ cat /etc/lsb-release 
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04 LTS"

I've recently installed ssh server, so now i have replicated again this bug (I know how to do it!).
Comment 3 Tom 2014-07-16 17:07:36 UTC
Created attachment 102928 [details]
Content /sys/class/drm/card0/error (no file /sys/class/card0/error on Ubuntu)
Comment 4 Matt Turner 2014-11-14 19:28:27 UTC

*** This bug has been marked as a duplicate of bug 80568 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.