Bug 81578 - intel_do_flush_locked when trying to use clEnqueueAcquireGLObjects
Summary: intel_do_flush_locked when trying to use clEnqueueAcquireGLObjects
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 10.2
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-20 23:17 UTC by wallnuss13
Modified: 2019-09-25 18:51 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wallnuss13 2014-07-20 23:17:35 UTC
I posted this bug on the (user) mailing list without getting any answers. Orignal posting: http://lists.freedesktop.org/archives/mesa-users/2014-June/000837.html and https://github.com/vchuravy/qjulia_gpu/issues/1

The gist of what I am trying to do is:

after creating the correct OpenCL and OpenGL contexts and the Texture and Image object I want to do the following calls to copy the computed information from the OpenCL Buffer to the Image.

glFlush
clEnqueueAcquireGLObjects
clEnqueueCopyBufferToImage
clEnqueueReleaseGLObjects
clFlush

After clEnqueueAcquireGLObjects I get the following error: "intel_do_flush_locked failed: No such file or directory"

The command itself succeeds but if I put a breakpoint on it and step through the rest of the function I get that error right after the call.

The problem might stem from my setup. I am using the AMD OpenCL implementation on an Intel CPU in combination with mesa on an Intel HD3000.

On the other hand if I use llvmpipe it works fine and I also don't get an error when running it with INTEL_NO_HW=1

Since I am new to mesa debugging how would I go about to get you more usable information? In the Github repo linked above I have a small c test case for the scenario I am describing and which reproduces the problem on two different laptops reliably.

Best Valentin
Comment 1 GitLab Migration User 2019-09-25 18:51:42 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1446.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.