Bug 82001 - GPU HANG using chrome and kubuntu
Summary: GPU HANG using chrome and kubuntu
Status: NEW
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-01 08:11 UTC by Matteo Croce
Modified: 2014-08-18 08:48 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
/sys/class/drm/card0/error (2.16 MB, text/plain)
2014-08-01 08:11 UTC, Matteo Croce
Details
screen corruption screenshot (90.83 KB, image/png)
2014-08-01 08:14 UTC, Matteo Croce
Details
lshw (16.25 KB, text/plain)
2014-08-01 08:16 UTC, Matteo Croce
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matteo Croce 2014-08-01 08:11:49 UTC
Created attachment 103797 [details]
/sys/class/drm/card0/error

I get a GPU HANG while using Chrome with Kubuntu 14.04 64 bit and a vanilla 3.15 kernel.
The system works fine for some time, then some black squares will appear in chrome, and then there is the GPU hang.

$ lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation 2nd Generation Core Processor Family DRAM Controller [8086:0104] (rev 09)
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)
00:16.0 Communication controller [0780]: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 [8086:1e3a] (rev 04)
00:1a.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 [8086:1e2d] (rev 04)
00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)
00:1c.0 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 [8086:1e10] (rev c4)
00:1c.2 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 [8086:1e14] (rev c4)
00:1c.3 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 [8086:1e16] (rev c4)
00:1d.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 [8086:1e26] (rev 04)
00:1f.0 ISA bridge [0601]: Intel Corporation HM75 Express Chipset LPC Controller [8086:1e5d] (rev 04)
00:1f.2 SATA controller [0106]: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] [8086:1e03] (rev 04)
00:1f.3 SMBus [0c05]: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller [8086:1e22] (rev 04)
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 07)
02:00.0 Network controller [0280]: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader [10ec:5229] (rev 01)


[    23.177] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    23.224] (II) Module intel: vendor="X.Org Foundation"
[    23.224]    compiled for 1.15.0, module version = 2.99.910
Comment 1 Matteo Croce 2014-08-01 08:14:52 UTC
Created attachment 103798 [details]
screen corruption screenshot
Comment 2 Matteo Croce 2014-08-01 08:16:07 UTC
Created attachment 103799 [details]
lshw
Comment 3 Chris Wilson 2014-08-01 10:35:34 UTC
The black squares are a symptom of the same bug - the hang occurs when those black pixels overwrite the batchbuffer instead of the render buffer.
Comment 4 Matteo Croce 2014-08-01 12:20:40 UTC
Thanks Chris.

If I can provide more information let me know.
It works fine with Ubuntu 3.13.0-32 kernel
Comment 5 Kenneth Graunke 2014-08-16 21:37:32 UTC
What version of Mesa are you using?  Stock Kubuntu 14.04 appears to ship Mesa 10.1.0, and we had a fix for a related issue in 10.1.1 or 10.2.0.
Comment 6 Matteo Croce 2014-08-18 08:48:57 UTC
I'm using mesa 10.1.3


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.