Bug 82046 - [Bisected] xbmc crashes with recent git mesa (git-150ac07) on r600g
Summary: [Bisected] xbmc crashes with recent git mesa (git-150ac07) on r600g
Status: RESOLVED DUPLICATE of bug 82538
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-02 07:48 UTC by Kertesz Laszlo
Modified: 2014-08-19 01:12 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kertesz Laszlo 2014-08-02 07:48:35 UTC
With recent mesa (+kernel, xf86-ati) from git xbmc started crashing with the following error:

state_tracker/st_atom_array.c:417:setup_interleaved_attribs: Assertion `array->_ElementSize == _mesa_bytes_per_vertex_attrib(array->Size, array->Type)' failed.
Trace/breakpoint trap (core dumped)

dmesg shows:

[472553.996080] traps: xbmc.bin[17682] trap int3 ip:7f8bb4847586 sp:7fff827674d0 error:0

It either crashes on startup or when clicking on any menu item for the first time or when scrrolling the menu (without having clicked on anything).
I recompiled  xbmca few times, it still does the same. Note that it was working until i did a mesa update from git a few weeks back.
The guys over the xbmc forums say that its a mesa issue.

glxinfo | grep -i open output:

OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD ARUBA
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.3.0-devel (git-150ac07)
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.3.0-devel (git-150ac07)
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.3.0-devel (git-150ac07)
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.0
OpenGL ES profile extensions:

I use Debian Testing 64-bit, mesa, drm, kernel, xserver built from git on an A8-6500. I also use glamor as acceleration method.
Comment 1 Michel Dänzer 2014-08-04 03:55:30 UTC
Can you bisect?
Comment 2 Kertesz Laszlo 2014-08-17 23:33:26 UTC
I bisected it. This commit turned up:

734e4946f50c1b83dafdb18ced652abc88e6a246 is the first bad commit
commit 734e4946f50c1b83dafdb18ced652abc88e6a246
Author: Marek Olšák <marek.olsak@amd.com>
Date:   Fri Jul 11 00:05:44 2014 +0200

    mesa: fix crash in st/mesa after deleting a VAO
    
    This happens when glGetMultisamplefv (or any other non-draw function) is
    called, which doesn't invoke the VBO module to update _DrawArrays and
    the pointer is invalid at that point.
    
    However st/mesa still dereferences it to setup vertex buffers ==> crash.
    
    Reviewed-by: Brian Paul <brianp@vmware.com>

:040000 040000 b52b7dc931a318657a82f535b497aea102bdbc99 340446a111ba97d9d11602c0150251135178b64e M	src
Comment 3 Michel Dänzer 2014-08-19 01:12:08 UTC

*** This bug has been marked as a duplicate of bug 82538 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.