Bug 8209 - r300 - broken selection rectangle rendering in Blender
r300 - broken selection rectangle rendering in Blender
Status: RESOLVED FIXED
Product: DRI
Classification: Unclassified
Component: libGL
unspecified
x86 (IA32) Linux (All)
: high normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-09 16:55 UTC by Jacek Poplawski
Modified: 2006-12-29 14:18 UTC (History)
1 user (show)

See Also:


Attachments
screenshot with broken rendering (168.22 KB, image/jpeg)
2006-09-09 16:57 UTC, Jacek Poplawski
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jacek Poplawski 2006-09-09 16:55:15 UTC
Rendering in the "selection" mode in Blender is currently broken on r300, it was
working correctly few months ago.

I've seen same problem on mga, and about year ago on r200 (then it was fixed on
r200).

To reproduce bug:
- start Blender
- press "b" once
- move mouse
You will notice lots of lines on the screen.

Code which renders these lines is in the function sdrawXORline
source/blender/src/glutil.c (in Blender source). This function simply draws a
line in some special mode (GL_INVERT).

driver: xf86-video-ati 6.6.2-2
OpenGL renderer string: Mesa DRI R300 20060815 AGP 4x x86/MMX+/3DNow!+/SSE TCL
Chipset: ATI Radeon 9800PRO NH (AGP) 
kernel: 2.6.17
X Window System Version 7.1.1
Comment 1 Jacek Poplawski 2006-09-09 16:57:50 UTC
Created attachment 6892 [details]
screenshot with broken rendering
Comment 2 Jerome Glisse 2006-09-14 10:47:16 UTC
We omitted to fallback on colorlogicop as we don't know yet how to do that.
The fallback might slow down blender.
Comment 3 Jacek Poplawski 2006-09-15 00:50:46 UTC
But it was working correctly on different version of driver, with exactly same
hardware. 
Was fallback enabled before? If yes, then it didn't slowed down Blender, it was OK.
With this bug Blender is almost unusable.
Comment 4 Jerome Glisse 2006-09-15 02:34:47 UTC
r300 history is sometimes hard to follow, but i don't remember
seeing anythings about GL_COLOR_LOGIC_OP in r300 before, maybe
somechange in core mesa lead us to not fallback.

Anyway i have commited yesterday the fallback stuff, i haven't
tested with blender as i don't know at all how to use this.
So please try with cvs r300 driver and report if it fixe the
issue you are seeing.

I will tackle color logic op after i am done with r300 cleanup
and smooth line, thus we don't fallback on it.
Comment 5 Jacek Poplawski 2006-09-15 02:40:00 UTC
To test it, please install blender, and perform following steps:

- start Blender
- move mouse cursor somewhere in the middle of the screen
- press "b" once
- move mouse

Incorrect behaviour is visible on screenshot - lots of lines. 
Correct one is selection rectangle just like in any other editor (like Gimp).

PS. ESC exits selection mode, "q" quits blender
Comment 6 popolon 2006-09-15 04:00:10 UTC
I don't have this problme with rectangle but with lasso selection, drawing are
kept in screen until some stroke...

In some case (with 'limit selection to visible' activated, not in wireframe mode
and in vertex selection mode only) the rectangle select hazardouzly vertex, not
all the vertex inside the rectangle selection, as you can see in these screenshots :
http://popolon.free.fr/Selection_bug.png
upper selection in solid mode (the bug in the selection)
lower selection in wireframe mode (all the vertex are selected).

The bug does not occur in whole software fallback.

Comment 7 Jacek Poplawski 2006-09-15 04:28:35 UTC
Popolon, are you sure that you are using r300 with 6.6.2 driver?
Comment 8 Jerome Glisse 2006-09-15 11:21:04 UTC
I can't reproduce the bug with lastest cvs (with my lastest commit).
Have you tried with lastest cvs ? We now fallback and thus use software
rendering for this.
Comment 9 popolon 2006-09-15 15:10:40 UTC
I used cvs from august 15, (or 25 ??) I've a segfault on every 3d applis (with
acceleration). Didn't verify recent dependencies
Comment 10 Jacek Poplawski 2006-09-24 23:49:42 UTC
It is fixed in current Mesa CVS.
Comment 11 Jacek Poplawski 2006-12-29 14:03:06 UTC
Has this bugfix been put into Mesa 6.5.2 release? I just installed new binary
packages of Mesa and Radeon driver and bug is still there :(
Comment 12 Jacek Poplawski 2006-12-29 14:18:40 UTC
I recompiled Mesa-6.5.2 and bug is fixed, sorry for false alarm, probably binary
package is broken.